Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 9 Jahren, 7 Monaten
Letzter Beitrag:
vor 9 Jahren, 7 Monaten
Beteiligte Autoren:
Piet van Zanten, Arie

WD11 Subscripted control in looper

Startbeitrag von Piet van Zanten am 11.04.2008 08:07

Hi Forum,

I'm trying to adress a subscripted control in a looper, but I get the runtime error:
"[ ] operator not supported by control."
This gives a runtime error:
looper1.edt_SomeEdit[j]=Myfile.MyField[j]

I can use the subscripted control if I omit the looper prefix.
edt_SomeEdit[j]=Myfile.MyField[j]

I also tried a non subscripted control like Edt_SomeEdit_1, Edt_SomeEdit_2 etc and use indirection. In this case I used:
looper1.{"Edt_SomeEdit_"+j,indControl}
this gives a syntax error on the first bracket: syntax error on {

Any suggestions?

Best regards,
Piet

Antworten:

Re: WD11 Subscripted control in looper: SOLVED

Found it! It's just like a table:
edt_SomeEdit[j]=Myfile.MyField[j]

Regards,
Piet


von Piet van Zanten - am 11.04.2008 08:23
Piet,

You can add a looper-attribute (say ATT_CustomerName) and assign that attribute to your edit-control. Can all be done in the looper-description-window.
Then you can use Looper1.ATT_CustomerName[j] in code, to assign you value. And de looper handles propagation to the edit-control.

Arie

von Arie - am 11.04.2008 08:28

Re: WD11 Subscripted control in looper: NOT SOLVED

Sorry, this solution does'nt work, the looper subscript is ignored

von Piet van Zanten - am 11.04.2008 09:43
Hi Arie,

Unfourtunately each subscript of the editfield in the attribute list is mentioned separately, so there's no way to address the editfield as an array.
I'll contact PCsoft. For now I'll make separate lines of code for each editfield.

Best regards,
Piet

von Piet van Zanten - am 11.04.2008 09:46
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.