Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
Phorum.org Hilfe-Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 17 Jahren, 4 Monaten
Letzter Beitrag:
vor 17 Jahren, 3 Monaten
Beteiligte Autoren:
Graim, Wolle, Thomas, Ralf

RC2 auf RC§

Startbeitrag von Ralf am 20.03.2000 13:03

Nun bastele ich hier schon seit gestern an der RC3 und bekomme das
Teil nicht ans laufen.
1. Diese Cookies regen mich langsam auf. Ewig und 3 Tage erhalte ich
im Adminbereich diese Warnmeldung:
Warning: Oops, php3_SetCookie called after header has been sent in stop/login.php3 on line 58
Kann es sein, daß eben wegen dieser Warnmeldung (dahinter steckt ja
irgendein interner Fehler) ich nicht in der Lage bin ein Forum zu
aktivieren? Anlegen läßt sich eines. Doch in der Datenbank fehlt der
xxxx_seq Eintrag. Der wird nicht geschrieben.
Ebenfalls ist mir aufgefallen, daß in der RC2 bei der Einrichtung der
Datenbank als Standard 3 Tabellen eingerichtet waren, alle mit Namen
forum, forum_bodies, forum_seq. Nun sehe ich lediglich forum.
Was mag da nicht stimmen?

Antworten:

RE: RC2 auf RC3

tja wie schon per EMail,
_seq wird (wie ich im Code gefunden habe) erst angelegt wenn benötigt, also wenn Nachrichten gepostet, vielleicht ist es mit Bodies genauso mittlerweile? :-(
Ich warte erstmal auf die nächste Version.

von Thomas - am 20.03.2000 13:44

RE: RC2 auf RC3

>Ich warte erstmal auf die nächste Version.

Ich glaube, das ist gar keine so falsche Idee ...

>Warning: Oops, php3_SetCookie called after ...

Die bekomme ich immer ... ich habe den Code soweit gecheckt ... ich dürfte sie nicht bekommen, denn er schickt NICHT an den Browser vor dem Scheiß Cookie ... :-(
Ich denke, daß das vielleicht mit der php3.ini und dem error_reporting zu tun hat ... habe ich bisher leider noch nicht ausprobieren können.

Desweiteren soll er doch für jedes neue Phorum (Ordner) eine Datei anlegen mit den Settings, oder?
Da hat er aber so richtig keine Lust drauf ... :-(

Kann er ja eigentlich auch gar nicht ... weil im Quell den ich hier habe:
function writefile($forum='', $main=false){
$forum mit "" überschrieben wird ...

Also ich denke in der RC3-Version ist noch der Wurm drinnen ... :-(((

Wenn Ihr es besser wißt, mail oder Postet es bitte ...

Danke
Graim




von Graim - am 20.03.2000 21:28

RE: RC2 auf RC§

Beim mir hat sich das Problem erledigt, nach dem ich das neue language File (aus dem RC3) mit eingebnunden habe.

Vielleicht benutzt du auch noch das aus der RC2 Version...


von Wolle - am 02.04.2000 18:22

RE: RC2 auf RC3


>Beim mir hat sich das Problem erledigt, nach >dem ich das neue language File (aus dem RC3) >mit eingebnunden habe.

>Vielleicht benutzt du auch noch das aus der >RC2 Version...

Habe ich nicht, aber Du hast Recht !
Es lag daran, daß das Language-File bei mir nach dem Schließendem PHP-Tag noch zwei LEERZEILEN enthielt, die der Include natürlich vor dem Setze-Mir-Mein-Cookie-Code jedesmal ausgegeben hat !!!

Hat ganz schön lange gedauert bis ich das gefunden hatte ... ;(

Graim



von Graim - am 03.04.2000 19:20
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.