Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
Phorum.org Hilfe-Forum
Beiträge im Thema:
6
Erster Beitrag:
vor 16 Jahren, 2 Monaten
Letzter Beitrag:
vor 16 Jahren, 2 Monaten
Beteiligte Autoren:
Adrenalin, thomas

Cannot add header information

Startbeitrag von Adrenalin am 22.01.2001 17:38

Warning: Cannot add header information - headers already sent by (output started at /bla/bla/apache/htdocs/bla/forum/read.php:9) in /bla/bla/apache/htdocs/bla/forum/read.php on line 272

Ich hab folgendes Angestellt: Alle phorum-dateien in mein Layout angepasst und nachher aufgerufen. Sobald ich aber auf "Nachrichten einzeln anzeigen" oder 'ne vergleichbare Funktion clicke, bekomme ich diesen Error. Hat jemand 'ne Ahnung, woran das liegt ?

Antworten:

schau mal hier

trifft wahrscheinlich genauso auf Dich zu.
NIE direkt die Dateien ändern, sondern nur die header.php und footer.php ... damit kannst Du fast alles ändern. Ansonsten kommt es eben zu den schon beschriebenen Fehlern.

von thomas - am 22.01.2001 17:42
Hm, dieses eine Post hab ich mir auch schon angeschaut... Dort scheint es dann aber auch geklappt zu haben, und mein Layout kann ich leider nicht via Header und footer einfügen........

Gibt's keine Lösung, ausser das ich gleich das ganze Ding umschreibe?

ciao,
Adrenalin

von Adrenalin - am 23.01.2001 15:17
was ist denn Dein Layout, so daß Du es nicht per Header und Footer anpassen kannst?

Nach meiner Erfahrung ist fast alles damit realisierbar.

Wenn es absolut nicht damit gehen sollte wirst Du Dich kräftig in Phorum einarbeiten müssen, da Du dann genau an den Punkten aufpassen mußt, wo Dateien included werden und wo Cookies gesetzt werden.
Da wo Cookies gesetzt werden darf KEIN Zeichen vorher ausgegeben werden und damit auch kein Layout ... darum wird der Header auch erst danach eingebunden.
Falls doch ein Zeichen vorher ausgegeben wird (wie es mit Deinem Layout wohl der Fall ist) ... bekommst Du die beschriebenen Fehlermeldungen.
Was Du probieren kannst, ist Cookies im Admin abzuschalten ... aber auch sonst ist mit Problemem zu rechnen.

von thomas - am 23.01.2001 16:28
Hm, das einzige Problem stellen noch die Cookies dar... Ich hab die mal abgeschaltet, und jetzt funzts:)

Wegen dem Layout: Das Ding ist ziemlich aufwendig gecodet, wird aus einer DB ausgelesen und hat auch sonst viele Include- & mySQL-Spielereien drin. Das Forum ist auch so umgeschrieben, dass sich die User registrieren müssen.

Durch die ausgeschalteten Cookies ist's jetzt einfach so, dass nur noch die Cookies vom Login gespeichert werden. Was wird denn eigentlich genau in den "ursprünglichen Cookies" gespeichert, ausser dem Usernamen, Addy & Co.?

ciao,
Adrenalin

von Adrenalin - am 24.01.2001 12:42
Okay, ich hab's jetzt hinbekommen :-) Die Abfrage, die dafür sorgt, dass man weiss bei wem jetzt welcher Beitrag "new" ist hat das ganze Zeug verwirrt... Die hab ich mal rausgenommen, und jetzt klappt es (im moment noch) wunderbar ;-)))

ciao,
Adrenalin

von Adrenalin - am 24.01.2001 12:49
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.