Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
Sam Forum
Beiträge im Thema:
8
Erster Beitrag:
vor 8 Jahren, 6 Monaten
Letzter Beitrag:
vor 8 Jahren, 1 Monat
Beteiligte Autoren:
Ansgar, Bernd Rische, Markus L, Harald Dreher

"selbstlaufender km-Zähler / wirre Geschwindigkeitsdarstellung"

Startbeitrag von Ansgar am 01.04.2009 09:01

Hallo Zusammen,

gestern hatte ich einen netten Effekt. Nach längerer Zeit wollte meine Haus-Elektro-Ingenieurin mal wieder Sam-Fahren. Da zeigt sie mir eine nette Fehlfunktion. Noch im Stand fängt der Tacho an hin und her zu schlagen. Dazu gesellt sich ein fröhliches km-Zählen...
Ich hab dann einen Reset durchgeführt und alles war wieder normal.

Da meine Chefin sich mal längere Zeit als Softwareentwicklerin für Embedded Systems betätigt hat wundert sie sich über die Effekte und möchte der Programmierung des Systems evtl. nachgehen.
Hat jemand sich schon mit ähnlichem beschäftigt?

Gruss
Ansgar (074)

Antworten:

Hallöchen,

kannst du mir sagen, was für einen Reset du durchgeführt hast?
Den am SOC-Modul?

Mir ist ansonsten so ein Fehler noch nicht bekannt geworden. :confused:


von Bernd Rische - am 01.04.2009 14:29
Hallo Berny,

jo, das SOC. Mehr ist ja auch nicht machbar.
Jetzt muss ich mal meiner Ingenieurin Material geben um das Problem nachzuvollziehen.
Das ganze war ziemlich seltsam.

Gruss
Ansgar

von Ansgar - am 01.04.2009 14:42
Hallo Ansgar,

Am Connector J8-Pin 20 des Kombi-Instrumentes liegt das Trigger-Signal für den Tacho an.
Es kommt direkt aus dem Steuergerät im Batteriefach.

Ich erinnere mich schwach an die Messung... glaube, es waren ca 127 Hz für 100 km/h.



von Harald Dreher - am 06.04.2009 20:09
Hallo Harald,

besten Dank für die Info. Das hilft mir weiter.

Gruss
Ansgar

von Ansgar - am 06.04.2009 20:29
Hallöchen,

aus dem Grund, dass eben das Tachosignal und dementsprechend der Kilometerzähler von der Motorelektronik kommt, hatte ich auch mich gewundert,
dass es besser geworden ist als der Reset am SOC-Modul gemacht wurde. :confused:
Denn die Motorelektronik im normalen SAM generiert ihr Tachosignal aus der Umdrehungszahl des Motors (Hallgeber im Motor).

Als Angabe zu den Impulsen hatte ich folgende Auskünfte 5 bzw. 8 Impulse pro Meter im anderen Forum bekommen.


von Bernd Rische - am 07.04.2009 12:04
Hallo Berny,

das Ergebnis muss ja nicht ursächlich miteinander zusammenhängen. Ich konnte den Prozess ja vor dem Sam stehend nicht direkt verfolgen :-) Vielleicht hat ja meine Frau noch die Bremse getreten :rp: und damit die Drehzahl reduziert. :cool:

Gruss
Ansgar

von Ansgar - am 07.04.2009 14:29
Habe heute auch bei meinem SAM beobachtet das der KM Zaehler (sehr langsam) laeuft auch wenn der SAM gar nicht faehrt.

Ich hatte die "Zuendung" laengers eingeschaltet und bemerkt das der KM Zaehler in der Zwischenzeit (weiss nicht mehr wie lange die Zuendung an war) ueber 1km gezaehlt hat.

Na ja, in der Praxis ist dies wohl kein Problem - normalerweise steht er ja auch nicht so einfach eingeschaltet herum.



von Markus L - am 16.08.2009 20:58
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.