Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
Senderbau und HF Technik
Beiträge im Thema:
16
Erster Beitrag:
vor 4 Jahren, 9 Monaten
Letzter Beitrag:
vor 4 Jahren, 9 Monaten
Beteiligte Autoren:
Elektronikbastler, astihome, Power-FM ne, Oszillatormann, Elektonikbastler

AM Sender Bastelei - Problem

Startbeitrag von astihome am 28.03.2013 13:00

Hi@all

Ich hab wieder mal ein kleines Problemchen bei dem Bau von einem amplitudenmodulierten Senderchen. Folgende Config habe ich mal auf ein Steckbrett aufgebaut:



Bis auf die Modulation funzt die Schaltung einwandfrei. Die erzeugten Frequenzen liegen zwischen 1 und 1,6 Mhz. Der Sinus ist einwandfrei anzuschauen (per Oszi). Keine Verzerrungen oder ähnliches. Einfach ein Bilderbuch Sinus :xcool: Wenn ich nun an "NF in" ein Musiksignal anlege, sieht man am Oszi zwar wie der Sinus sich im Takt bewegt, aber irgendwie nicht so, wie es eigentlich vorgesehen ist. Normalerweise bewegen sich bei der Amplitudenmodulation ja nur die "Wellenhügel" und die "Wellentäler" im Takt. Der Rest bleibt relativ still (sonst wäre es ja FM). Bei mir bewegen sich irgendwie die Seitenteile einer Halbwelle plus Hügel und Täler. Die andere Seite bleibt still stehen. Um es mal zu veranschaulichen habe ich mal was gezeichnet. Ich hoffe es ist erkennbar was gemeint ist.



Falls nicht erkennbar ist was gemeint, kann ich im Notfall auch noch ein Kurzes Video machen.
Was verursacht denn dieses Problem? Hat das was mit einer Phasenverschiebung an den Transistoren zu tun oder ist der Oszillator der Verursacher? Wär toll wenn mir jemand helfen könnte.

Antworten:

Hallo,

Sicher das der Plan so richtig gezeichnet ist? Ich möchte deiner Eigenkreation ja nicht zu nahe treten, aber einige Werte erscheinen mir schon extrem groß für Mittelwelle und auch so wundere ich mich, das die Schaltung schwingt.

Gehen wir mal davon aus, das der Plan so weit "io" ist, dann kann ich nicht erkennen wo der 10k von der letzten Stufe "hingeht". Hast du den direckt an deinem Walkman / mp3 Player angeschlossen, oder geht der noch auf einen einfachst Modulator mit Transistor oder LM386? Wenn du ihn direckt an deiner Audioquelle angeschlossen hast, solltest du das ändern, und z.B. einen weiteren 10k auf dazuschalten und diesen auf + legen dann das audiosignal provisorisch über 100nF "da wo sich beide 10k treffen" gegen Masse einspeisen - eventuell gehts dann...

Meine Meinnung noch zu der Schaltung / Tips...

Allerdings, wie gesagt, ich finde diese Schaltung etwas "seltsam". Das 22k Poti im Emmiter des Oszillator Transistors erscheint mir doch etwas sehr hoch - ich würde hier eher 1k einbauen. Dann auch die Kondensatoren die Werte sind viel zu gering (alleine schon der 4,7pF koppel C). Ich würde die Werte verzehnfachen also 330pF -> 330pF 56pF ->560pF. Ausserdem würde ich den 33pF (330pF) direckt von B nach E schalten und nicht erst einen Kondensator dazwischen. Die 220µH Spule hast du gut gewählt, somit kommst du ins Mittelwellenband, allerdings, würde ich den 47pF auch eher durch 470pF ersetzen

Das 2,2k Poti kannst du lassen - scheinbar hast du das so gemacht, das du die Ausgangsleistung deines Oszillators einstellen kannst das ist soweit ok. Allerdings würde ich am Ausgang einen Spannungsteiler bauen bestehend aus 2x 1nF oder 2x 470pF und in der mitte wo sich die Kondensatoren treffen dann den 22pF einbauen.

Den 3. Transistor würde ich ganz weglassen, und als Modulator verwenden...

Der 2. Transistor wird wie folgt geändert 330Ohm raus und irgentwas >1k ohm rein (aber auhc net zu viel eventuell 3,3k ohm maximal) den 33k durch 100-150k ersetzen

Dann nimmst du den 3. Transistor und schaltest ihn mit "Kollektor" auf + deiner Versorgungsspannung

Den Emmiter schaltest du auf den Widerstand, wo vorher der 330 Ohm war - ausserdem sollteste du dann von Kollektor deines 3. Transistors auf Masse 1-100nF schalten (was grad da ist). Von basis des 3. Transistors machst du dann den 10k Widerstand - der noch offene anschluss geht auf das vorher ausgebaute 22k poti (schleiffer) die anderen beiden anschlüsse des 22k potis sind wie folgt verschaltet: einer liegt auf - einer auf +

mit dem poti kannst du dann den arbeitspunkt des modulators einstellen

Deine Tonquelle schliesst du dann wie folgt an

Masse auf Masse
Audioausgang über 100nF + 1...10k an Basis des 3. Transistors

so solltest du einen kleinen AM Sender erhalten, der nicht besonders weit geht, aber wenigstens etwas vor sich "hinsendet".

Wenn du willst kann ich "Morgen" die Schaltung ja mal unverbindlich schnell testen, wie ich sie verbessert habe, die teile müsste ich größtenteils da haben (bis ev. auf das Poti da hätte ich glaube ich nur 2,5k aber ich ersetze es dann halt durch 2,2k festwiderstand)

von Elektronikbastler - am 28.03.2013 21:06
Erst mal ein paar Feststellungen Ich glaube nicht, dass die Leistung dafür reicht, den dritten Transistor bereits im C-Betrieb laufen zu lassen.
Und jetzt kommt schon eine Frage auf:
Welche Transistoren kommen zum Einsatz?
Dann die Frage nach der Modulation. Wenn du da, wo "NF In "steht einfach so den Ausgang einer Audioquelle anschließt, funktioniert das natürlich nicht.
Du musst da eine mit der NF überlagerte Gleichspannung anlegen, also z.B. einen Audioverstärker bauen, der dann als von der NF gesteuerte Stromquelle für die HF-Endstufe dient.
Es kann sein, dass du das gemacht hast, aber es geht aus dem beitrag und der Schaltung nicht hervor.
Das was du mit dem Sinusbild versuchst anzudeuten ist der FM-Anteil. Der wird bei dieser Schaltung auch nicht 100%ig wegzubekommen sein, dafür ist größerer Aufwand für die Pufferung und Abschirmung nötig (ist gar nicht so einfach, wie ich mal feststellen durfte).
Den Oszillator könnte man bezüglich der Frequenzeinstellung besser aufbauen (so wie jetzt gibt es ja gar keine Möglichkeit zur Frequenzeinstellung, oder machst du das über die Potis am Kollektor und Emitter? wenn ja wäre das der falsche Weg, weil das die ganze Schaltung "verschiebt").

von Power-FM ne - am 29.03.2013 10:51
Zitat

Allerdings, wie gesagt, ich finde diese Schaltung etwas "seltsam". Das 22k Poti im Emmiter des Oszillator Transistors erscheint mir doch etwas sehr hoch - ich würde hier eher 1k einbauen. Dann auch die Kondensatoren die Werte sind viel zu gering (alleine schon der 4,7pF koppel C). Ich würde die Werte verzehnfachen also 330pF -> 330pF 56pF ->560pF. Ausserdem würde ich den 33pF (330pF) direckt von B nach E schalten und nicht erst einen Kondensator dazwischen. Die 220µH Spule hast du gut gewählt, somit kommst du ins Mittelwellenband, allerdings, würde ich den 47pF auch eher durch 470pF ersetzen


@Elektronikbastler, ich weiß nicht genau, wie du darauf kommst, aber ganz grob überschlagen (wie man es bis ins Detail genau ausrechnet weiß ich leider nicht^^) müsste der Schwingkreis knapp über 1 MHz liegen, also die Werte im Schwingkreis sind so schon i.O.
Würde ich deine Werte einsetzen, dann lande ich im unteren MW Band bzw. eigentlich schon auf Langwelle, wenn man die 220µ Spule drin belässt.

von Power-FM ne - am 29.03.2013 10:58
Hallo,

ich habe mich jetzt Heute hingesetzt und einen kleinen AM Prüfsender für dich entwickelt. Ich beschäftige mich schon sehr! lange mit der Entwicklung verschiedener AM Sender (auch mit mehr Leistung also so um die 2W) und kenne die "Problemchen" die gerne mal auftreten. Der folgende 3-Transistor AM Sender ist sicher noch net perfekt, aber er liefert mir eine relativ saubere AM mit sehr geringem FM Anteil. Ich habe mir das Signal jetzt zwar nicht am Oszi angeschaut, aber bei meinem Kommunikationsempfänger höre ich die Musik ganz laut und klar in "AM" und in der Betriebsart "FM" höre ich kaum Musik, nur, wenn ich den Empfänger (Lautstärke) "voll aufdreh" ist auf FM etwas zu hören.

Zur Schaltung:

Die beiden 1nF Kondensatoren beim Oszillatortransistor unterstützen diesen, das er schwingt, und bilden zugleich einen Kapazitiven Spannungsteiler. Die am Spannungsteiler vorhandene Hochfrequenz ist in der Mitte der Kondensatoren vorhanden - und - wird entsprechend "schwach" durch den 22pF Kondensator ausgekoppelt. Der 2. Transistor arbeitet einfach nur als HF Verstärker - dieser verstärkt die Hochfrequenz des Oszillators. Der Transistor darüber ist der AM Modulator, dieser versorgt den Verstärker mit Gleichspannung - und - durch anlegen von Musik ändert der Transistor Gleichspannung die an der Endstufe anliegt im Verhältniss zur Musik - dadurch - entsteht ein AM Signal.

Der Sender hat natürlich kaum Sendeleistung, ich habe jetzt testweise ein 50cm Kabel als Antenne angesteckt, und erhalte so eine Reichweite von 10cm. Jetzt hab ich das ganze noch verbessert. wenn ich das Kabel mit 1mH in "lade" bekomme ich eine Reichweite von immerhin 1m.

Sicher nicht perfekt, aber bei soeinem Versuchs-Sender reicht das ja.

Hier mal der verbesserte Plan



oder als link

http://www46.zippyshare.com/v/3979693/file.html

Würde mich freuen, wenn du den mal nachbauen würdest, und mir berichten würdest, wie du ihn findest. Habe den Sender auch am Radio getestet (größerer Lautsprecher) und der Klang ist echt gut. Relativ viel Hub, und das typische "AM - Mäsige" einstellen der Frequenz (also nicht den Radio an den Rand der Frequenz stellen, sondern auf die Grundwelle, wie es bei AM Sendern üblich ist).

von Elektronikbastler - am 29.03.2013 13:14
Noch ein kleiner Nachtrag.

Der Sender schwingt bei mir bei ca 1,1Mhz ich habe den Trimmkondensator einfach als Komfort dazugebaut das man die Frequenz etwas einstellen kann. Den 100pF Koppelkondensator zur Spule kannst du auch vergrößern - dadurch sinkt die Frequenz. Den Mod. Arbeitspunkt einfach bei eingeschaltetem Audiogerät auf beste Tonquallität einstellen. Eventuell wirst du noch einen kleinen Pre-Amp brauchen, für einigermaßen Hub habe ich meinen Discman nämlich voll aufdrehen müssen.

Die Werte wo ich "von bis" angegeben habe sind unkritisch.

von Elektronikbastler - am 29.03.2013 13:17
Power FM

Ich habe da natürlich nichts berechnet, aber das "4,7pF" bei Mittelwelle *Etwas* wenig sind, sollte eigendlich auch dir einleuchten :-)

Ich habe jetzt extra für dich nochmal geprüft, nicht das es wieder heist, die 1,1Mhz die ich da habe seien eine Oberwelle - nein :-)

1,1Mhz ist die Grundwelle "drunter" ist nichts

vertrau´ mir hier einfach ich hab echt schon zu viele von diesen Senderchen gebaut.

von Elektronikbastler - am 29.03.2013 13:26
Vielleicht sehe ich das etwas falsch mit der Zusammensetzung der Gesamtkapazität in solchen Oszillatoren, aber dennoch mal mein Verständnis dazu:
Die Auswirkung des 4,7 p in der oberen und in der unteren Schaltung sind ganz anders. In der obigen Schaltung liegt der 4,7pF in Reihe mit der Transistorkapazität, diese beiden liegen zusammen parallel zum 33pF.
Wenn der Transistor nun ein BF199 ist, dann ist die Transistorkapazität sehr klein, wenn es aber ein BC547 ist, dann ist diese knapp 10 pF.
Macht also 4,7p in Reihe mit angenommen 10 pF = ca 3 pF
Dieses Gebilde liegt in Reihe mit dem 56p, das müsste also insgesamt etwas kleiner als 4,7 p sein. Das würde mit der Spule eine Frequenz von 5, x MHz ergeben.
Wahrscheinlich ergeben sich aber durch den Steckbrettaufbau andere, größere Kapazitäten, so dass es trotzdem auf ~ 1MHz schwingt.

In der Schaltung vom Elektronikbastler liegt der (hier auf 100p gewachsene) Kondensator nicht mehr parallel zur Transistorkapazität, sondern in Reihe zur Gesamtkapazität (Gesamtkapazität ohne den Trimmer).
Das macht dann im Endeffekt ~ 8 pF. In dieser Konfiguration hat der 100p einen erheblichen Einfluss auf die Gesamtkapazität. In der obigen Konfiguration (wenn sie denn wirklich so funktionieren sollte wie gezeichnet) dagegen macht sie relativ wenig an der Gesamtkapatität.
Hier kommt dann noch der Trimmer dazu, wodurch das ganze dann in der Frequenz weiter herunter gezogen wird.

von Power-FM ne - am 29.03.2013 19:08
Vielleicht hat die 220uH Spule selbst 30 pF Wicklungskapazität!

Gruß,
Oszillatormann

von Oszillatormann - am 29.03.2013 21:00
Hi@all

Erstmal Danke für die vielen Reaktionen auf mein Thread. Ich muss zu meinem bedauern noch hinzufügen, das ich einen 60pf Trimmer parallel zu der Spule L1 auf der Zeichnung vergessen habe, damit kann ich natürlich die entsprechende Frequenz einstellen. Die Frequenz liegt mit meinen angegeben Werten tatsächlich im Bereich von 1 - 1,6 Mhz (Nachgemessen mit der Frequenzanzeige am Multimeter). Die "Kapazitätswerte" im/am Steckbrett scheinen hierbei wenig zu beeinflussen. Nachrechnen kann man den ganzen Spaß HIER.(Dort Bei Kapazität zwischen 25 - 80pF und bei Induktivität 220µH eintragen)

@Elektronikbastler

Danke für deinen Schaltungsentwurf. Ich habs mal kurz durchgetestet. Die Kapazitätwerte im Oszillatorkreis senken die Frequenz deutlich herab. So zwischen 500 und 700 Khz. Wäre aber auch noch im Radio hörbar. Im Prinzip wollte ich mit der Schaltung mal testen wie leicht/schwer es ist ein sauberes AM Signal mit Modulation zu erzeugen. Jetzt leuchtet mir auf jedenfall ein warum immer ein Modulator (NF Verstärker) erforderlich ist wenn man ein Signal bei AM aufmodulieren möchte. Ich werd noch ein bisschen weiter testen.

von astihome - am 01.04.2013 14:49
Am besten so nachbauen, wie ichs gezeichnet habe. Auch beachten, das der Rückkoppel C jetzt direckt von B nach E sitzt und nicht erst von der Spule nach E.

Bei mir hat der Sender (habe ihn schon wieder "auseinandergebaut") eine sehr gute AM gemacht auch guten Hub.

von Elektronikbastler - am 01.04.2013 18:01
Hi,

Ich habe nochmal etwas an meiner AM Sender Schaltung rumgespielt. Sie funktioniert soweit prima, bis auf die Modulationsgeschichte. Am Oszilloguck habe ich mir, bei 4 eigenen Schaltungsvarianten (unter anderem die von Elektronikbastle) die Hüllkurve angeschaut. Ich bekommen es einfach nicht hin eine synchrone Hüllkurve zu erzeugen. Normal wäre ja Hügel oben, Hügel unten. Bei mir sieht man Hügel oben, Delle unterhalb...!? Muss dass so sein? Trotz Modulator? Was kann ich noch probieren um ein sauber moduliertes Signal hinzubekommen. Auch ein LM386 schafft irgendwie keine Abhilfe. Auf dieser Website sieht es ja irgendwie synchron aus. Kennt jemand eine gute Seite zum Thema AM Sender/Modulation?

von astihome - am 02.04.2013 14:45
Wenn es dir darum geht, einen sauberen Sinus zu erzeugen, solltest du am Ausgang einen PI Filter anbringen, der formt dir dein Signal zu einem Sinus Signal. Ich habe mir meine Schaltung mangels Bedarf net am Oszi angeschaut, sondern nur den Klang im Radio überprüft.

von Elektonikbastler - am 03.04.2013 10:11
Aus der Schaltung kommt auch so schon ein sauberer Sinus raus...
Das ist aber auch gar nicht gemeint.
Gemeint ist, dass statt einer Amplidtudenmodulation eine Überlagerung herauskommt, wenn ich die Beschreibung der Oszi-Bilder richtig gedeutet habe.
Dieses Problem hatte ich auch schon bei AM-Basteleien. Am Radio merkt man das tlw. überhaupt nicht, weil ein Seitenband zum Demodulieren dann ja trotzdem da ist.

Die Modulation würde ich mir mit dem Oszi im xY-Mode ansehen (an X das NF-Signal, an Y das modulierte HF-Signal. Das muss dann bei Modulation mit einem Sinuston ein Dreicekt ergeben.
Wenn das Dreicek vollständig zu sehen ist, dann moduliert man voll aus.

von Power-FM ne - am 03.04.2013 11:58
@Elektronikbastler

Der Sinus geht einwandfrei. Der wird auch garnicht bemängelt. Siehe Erklärung von Power-FM ne! Es ist in der Hüllkurve eine Überlagerung zu sehen, statt einer synchronen Amplitudenmodulation.
Diese "Kümmelspalterei" macht sich im Bastelbetrieb überhaupt nicht bemerkbar. Wenn es aber um z.B. Amateurfunk geht dann schon. Es gibt nämlich einen USB und OSB Betrieb (Oberes und Unteres Seitenband)

@Power-FM ne

Bei mir ist leider nur ein Trapez (oder schräges Rechteck) zu erkennen. Selbst mit einem BF961, der ja eigentlich dafür optimal scheint hab ich es nicht hinbekommen. Ich werd nochmal folgende Schaltung probieren:



Ich hatte es auch mal annähernd hinbekommen indem ich einen Transistor wie folgt angeschlossen habe. C an Plus, E an Minus, B an NF vom Modulator. Da konnte ich was synchrones auf dem Oszilloguck erkennen, leider habe ich dann gemerkt, das überhaupt keine direkte Verbindung (Kopplung) zur HF Endstufe bestand :xcool:. Der ganze Spaß muss sich wohl über die Plus und Minus Leitung eingekoppelt haben. Falls jemand was ähnliches versucht, kann sich gerne mit mir austauschen.

von astihome - am 03.04.2013 14:14
Hallo Astihome,

die AM-Modulatoren mit Kollektorspannungsmodulation funktionieren nur, wenn der HF-Transistor durch die HF an der Basis voll ausgesteuert wird. Er muß richtig in die Sättigung gesteuert werden. Du brauchst also viel Treiberleistung!.

Der MOSFET T2 kann über Gate2 eigentlich ordentlich moduliert werden. Es könnte sein, daß Du an Gate2 einen anderen Arbeitspunkt als 0V (R24 an ein Trimmpoti statt an Masse) einstellen mußt. Es kann auch sein, daß die HF-Amplitude an Gate 1 viel zu groß ist, so daß der MOSFET in der Sättigung ist und deshalb die Steilheitsmultiplikation nicht funktioniert. Gate1 sollte mit 1Vss zufrieden sein, wahrscheinlich ist der Pegel dort aber größer. Du könntest den Pegel mit einem Parallelkondensator zu R12 gut runtersetzen, z.B. mit 470pF.

Der MOSFET muß in deiner Schaltung auch mit einem kleinen Lastwiderstand abgeschlossen werden, sonst verstärkt er viel zu viel und ist mit allen Arbeitspunkten an Gate2 in der Sättigung. Ein 50 ...500 Ohm Widerstand vom Ausgang nach Masse ist daher extrem hilfreich. Noch einfacher wirds, wenn Du L20 gegen einen 100 Ohm Widerstand ersetzt. Dann kommt zwar kaum noch Leistung raus, dafür hast Du Modulation!

Deine 12V Versorgung hat hoffentlich einen Blocker parallel, so daß L20 auch HF-mäßig an Masse liegt!

Gruß,
Oszillatormann

von Oszillatormann - am 03.04.2013 15:47
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.