Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
Senderbau und HF Technik
Beiträge im Thema:
17
Erster Beitrag:
vor 4 Jahren, 3 Monaten
Letzter Beitrag:
vor 3 Jahren, 5 Monaten
Beteiligte Autoren:
Power-FM ne, Shunth, Oszillatormann, carkiller08, joergel, frankyy, Elektonikbastler

Endstufe schwingt wild, aber nur bei bestimmter Eingangsfrequenz

Startbeitrag von Power-FM ne am 28.10.2013 18:16

Hallo,
es wird mal wieder länger, und vielleicht sind wieder einige dumme Fragen dabei. Egal ;-).

Ich habe in den letzten Tagen 4 mal eine kleine Verstärkerschaltung gebaut. Ob die Anpassung zwischen den Stufen und zur Antenne hin korrekt / "gut" ist sei mal dahin gestellt, es ist in der Praxis jedenfalls so, dass auf dem SWR-Meter bis zu 600 mW angezeigt werden und auf dem "Spekki" die Grundwelle auch die stärkste ist (1. Oberwelle ist ca 35 dB schwächer) und der angezeigte Pegel auch in etwa zu den max. 600 mW passt.

Die Schaltung (bzw. der Teil, um den es mir geht) sieht so aus:


Diese Schaltung habe ich insgesamt 4 mal aufgebaut. Der erste Aufbau war auf einer Platine mit viel Kupfer in der Insel-/-Kratz-Technik. Damit kam am meisten Ausgangsleistung (um die 600mW), vermutlich weil die großen Inseln die Induktivitäten zufällig in die richtige Richtung verstimmt haben.

Das gleiche habe ich dann noch mal auf einer geätzten Platine mit Leiterbahnen und nicht ganz so HF-tauglicher Leiterbahnführung aufgebaut, hier musste ich von C3, C4 und L4 etwas verändern (Try & Error), womit ich das ganze auf ungefähr 500 mW in Bandmitte und 200 mW am unteren und oberen Bandende bringen konnte, wildes schwingen gab es nicht.
Das funktionierte problemlos, auch ein weiterer Aufbau auf einer exakt gleichen Platine hat sich genau so verhalten.
So weit so gut.
Noch ein Aufbau, auf einer ebenfalls identischen Platine und mit exakt gleichen Bauteilwerten verhält sich nun nicht ganz so schön.
Einziger Unterschied: Auf der Platine ist in einem Teil, der bei den anderen beiden Aufbauten unbenutzt ist, eine PLL-Steuerung vorgesehen (aber noch nicht bestückt).

Und jetzt zum eigentlichen Problem:
In diesem Aufbau funktioniert eigentlich auch alles, nur wenn die Eingangsfrequenz der Verstärkerschaltung zwischen ca. 90 und 94 MHz eingestellt wird, schwingt die Endstufe im Bereich um 1-10 MHz selbst und dieses Signal mischt sich mit dem UKW-Signal, so dass sich also neben der Grundwelle in kleineren Abständen jeweils "Spiegelfrequenzen" befinden.
Das lässt sich so eindeutig auf dem Spekki erkennen (auch dass die Endstufe in Bereich unter 10 MHz herumschwingt).

Nun ist es ja so, das generell wild schwingende Endstufen meist gar nicht selbst auf UKW schwingen, sondern irgendwo im Bereich unter 10 MHz und dieses Signal mischt sich dann mit dem Nutzsignal, also genau der gleiche Effekt wie bei mir.
Das liegt wohl daran, dass die Verstärkung der Transistoren im unteren Frequenzbereich viel höher ist und dadurch ganz leicht rückkoppelt und ins Schwingen Gerät.
Darum ist ja bei Klasse-C Endstufen oftmals ein recht niederohmiger Widerstand von der Basis nach Masse eingebaut, um dieses zu unterbinden.
Auf die gleiche Idee bin ich auch gekommen und habe das mal ausprobiert:
10 Ohm von der Basis nach Masse:
Das wilde Schwingen hört auf, aber die Leistung sackt auch auf 100 mW ab.
220 Ohm: Das wilde Schwingen bleibt, die Ausgangsleistung bleibt gleich wie ohne Widerstand (auch auf den Frequenzen gemessen, wo die Endstufe nicht ins schwingen Gerät, also keine vorgetäuschte Leistung durch das wilde Schwingen).
Was kann man denn noch dagegen machen (also um das Oszillieren der Endstufe im Bereich unter 10MHz zu unterdrücken)? und warum passiert das ganze nur bei einer Eingangsfrequenz im Bereich 90-94 MHz???
Und noch viel wichtiger: Warum passiert dass in den anderen Aufbauten nicht (Bauteile sind zu 100% gleich, zumindest in den Versionen mit gedruckter Schaltung) ???

Antworten:

[attachment 11 123qwe.jpg]

Die Spulen am Kollektor sollten eigentlich nicht direkt an die Spannungsquelle
angeschlossen werden, Da sollte eigentlich immer noch eine Drossel oder - bei kleineren Leistungen -
ein Widerstand sitzen.
Bei der Endstufe kannst du das mal probieren mit der Drossel, dem RC-Glied in Serie und dem
Widerstand parallel zur Spule am Kollektor.

Der Vollständigkeit halber sei noch erwähnt, daß im Verbindungsbereich der beiden Transistoren
praktisch einen Schwingkreis mit einer Resonanzfrequenz von ca. 8,8Mhz vorliegt
(Masse, L2 , C2 , L1 , Kondensatoren von +12 nach Masse).
Der ist "hart" an beide Transistorstufen gekoppelt und dürfte bei Instabilität der Schaltung die Schwingfrequenz mitbestimmen.

Zitat

Und noch viel wichtiger: Warum passiert dass in den anderen Aufbauten nicht (Bauteile sind zu 100% gleich, zumindest in den Versionen mit gedruckter Schaltung) ???


z.B. Layout-Änderungen oder Abweichungen ,andere Verstärkungseigenschaften der verwendeten Transistoren

von carkiller08 - am 28.10.2013 19:20
Hi,

eventuell auch beim 2. Transistor die Spule auf Masse mal stark verkleinern auf 220nH oder so. Ausserdem würd ich eher Klasse A mit Spannungsgegenkopplung wählen, da Klasse C auch meinen Erfahrungen nach gerne selber schwingt. Wie von carkiller08 schon vorgeschlagen würde ich auch nicht die 2. Spule im Kollektor direkt auf die Stromquelle legen sondern per Schaltung wie beschrieben. Als RFC kannst du deine 10µH nehmen.

Alternativ mal probieren auch einfach nochmal einen 47k zwischen B und C einzubauen und dann mal die Ausgangsleistung anschaun.

Ich habe bei einem Sender mit klasse A recht gute Erfahrungen gemacht (Allerdings mit Widerstand direkt von + auf Basis) bekomme so problemlos (nicht präzise gemessene) 2,5W+ auf VHF welche mit einer Softlite Lampe ermittelt wurden (welche wiederrum zum Vergleich an einem CB Funkgerät angeschlossen wurde, und die Helligkeit bei 1 sowie 4W "gemerkt" wurde und dann die Lampe an Sender Ausgang und Helligkeit vergleichen. Die Reichweite passt auch wenn ich den Sender mit weniger Spannung betreib so das er "vermutlich" 1W macht hab ich einige Kilometer Reichweite (die Sicht Reichweite konnte ich noch net austesten da ich da net viel weiter als 8,5km vom Sender weg kann und dort geht's noch superstark her). Allerdings nutze ich einen 2N3553 als Endstufe. Der wird bei geschätzten 1W mit Kühlring "noch anfassbar" warm. Die 1W reichen auch für das typische zwicken / hf heiss werden beim berühren der Antenne. Ich habe zwar ein Leistungsmessgerät, aber ich weis net, ob das in diesem Bereich noch akkurat ist daher die Messung mit der Lampe. Steuerleistung für den 2N3553 dürfte so bei 0,4W liegen schätz´ ich. Die Softlite Lampe ist am Senderausgang viel viel heller als bei 1W vom CB Funkgerät aber noch net *ganz* so hell wie an 4W. Daher "2,5W"

von Elektonikbastler - am 29.10.2013 01:01
Der Oszillatormann hatte doch hier mal einen sehr gut dimensionierten 100mW-Breitbandverstärker gezeigt.
Die Endstufe dieses 100mW-Verstärkers wäre genau richtig dimensioniert
als Eingangsstufe des Verstärkers im ersten Beitrag.

[attachment 13 100mW_Pufferverstrker.jpg]

Der BFR96 hat allerdings eine höhere Verstärkung als der 2N2219
Für den 2N2219 müßten wohl die Widerstandswerte leicht angepasst werden.

von carkiller08 - am 29.10.2013 19:14
Meiner Erfahrung nach gibt es nur ein Heilmittel gegen wildes Schwingen: Treiberleistung runterdrehen.
Alle anderen Methoden wie

1) LR Dämpfungsglieder an der Basis
2) Betriebsspannungssiebung für tiefe Frequenzen niederohmig bedämpfen
3) Kollektorabschlußimpedanz ändern
4) Betriebsspannung und / oder Strom ändern

helfen nur bedingt. Wenn die Antennenimpedanz sich ändert oder die Frequenz geändert wird oder die Leistung runtergeregelt wird findet sich eigentlich immer ein Betriebszustand, in dem der Transistor wild schwingt oder wild schwingen kann. Der Ärger beginnt oder kann beginnen, wenn der Transistor in die Sättigung gerät, d.h. die Kollektorspannung kleiner als die Basisspannung wird. Man muß also letztendlich auf Wirkungsgrad verzichten, wenn die Endstufe auch mit anderen Stehwellenverhältnissen als 1:1 fertig werden soll und auch breitbandig sein soll.

Gruß,
Oszillatormann

von Oszillatormann - am 30.10.2013 15:38
jeep!!!! Ich stimme Oszilatormann absolut zu! Genau diese Beobachtungen von Power FM habe ich vor Jahren schon gemacht und nur beheben können, wenn die Vorstufen/Endstufen so vor sich "hin blubbern"......Aus dieser Erfahrung herraus, fahre ich jede Endstufe nurnoch mit "halber" Kraft.

Wilde Schwingungen können vor allem bei breitbandigen Verstärkern auftreten. Eine Lokalisierung der Ursache für ungewolltes Schwingen ist meist sehr zeitaufwendig. Die Fehlerquellen sind häufig:
1. Versorgungsspannung ungenügend abgeblockt
2. Kollektorschwingkreis wirkt als Nebenresonanz
3. Drosselspule von Basis nach Masse wirkt als Nebenresonanz
4. ungeeigneter Aufbau des Verstärkers
Für den Fall 2 und 3 versuche es mit 100 Ohm parallel zu den Spulen. Ich habe meistens Erfolg gehabt, wenn ich über den 100 Ohm die Kollektorspule gewickelt habe.

Gruß
Shunth

von Shunth - am 31.10.2013 11:54
Das Schwingen entsteht, weil die Kollektor-Basis-Diode des Transistors während der Sättigungsphase leitend wird. In dem Moment fließt ein riesiger Basisstrom von der Basis zum Kollektor. Da eine Periode später der Kollektorschwingkreis eine andere Restenergie hat als zuvor ( es sei denn, er ist perfekt abgeglichen) wird der Basisstrompuls zu einem geringfügig verschobenen Zeitpunkt entstehen. So entsteht eine tieffrequent verschobene zeitliche Modulation der Basisstrompulse und daher die tieffrequente Modulation des Sendesignals. Man muß also letztendlich die Sättigung des Transistors vermeiden und der Basis ein möglichst kleines Steuersignal anbieten, also auch ein oberwellenarmes Steuersignal an der Basis bereitstellen.

Das im Spektrum sichtbare tieffrequente Signal entsteht im Transistor als Mischprodukt. Die hochfrequenten Seitenbänder sind also "zuerst da".
Ich hoffe, das ist verständlich.

Gruß,Oszillatormann

von Oszillatormann - am 31.10.2013 17:54
@Oszillatormann

hui, das nenne ich mal elektronische Chirurgie.......Ja, ich verstehe aber was du meinst.....
Trotzdem mal ne Frage.......Sicher ist, dass es viel mit den Layouts zu tun hat. Wenn ich mir so Endstufen anschaue, wie bei R&S, sieht mann, was da so mit den Leiterbahnen "angestellt" wird. Nun die Frage:
Warum ist das bei Röhren nicht so? Wenn ich mir da so die wilde Verdrahtung anschaue.......und da schwingt nicht viel.....

Gruß
Shunth

von Shunth - am 31.10.2013 18:17
Roehren und Fets haben eben keinen Basisstrom, den brauchst Du aber für den Effekt.

Gruß,
Oszillatormann

von Oszillatormann - am 31.10.2013 18:41
.....o.k. Danke!

von Shunth - am 31.10.2013 19:03
Zunächst mal Danke für die ganzen Tips.
@ carkiller08
Warum ich die Drosseln zur Betriebsspannung hin vergessen habe weiß ich ehrlich gesagt nicht. Habe sowas ja schon öfter gebaut, früher ist mir sowas nicht passiert ;-).
Es hat aber auch nicht geholfen sie einzubauen.
Das RC-Glied und der Widerstand parallel zum Kollektor allerdings auch nicht. Was funktioniert, ist ein 10 Ohm Widerstand von der Basis nach Masse, allerdings auch mit erheblich weniger Output. Wenn ich den Widerstand größer mache (bis 470 Ohm) taucht das Problem genau so wie vorher wieder auf.
Das mit dem Schwingkreis zwischen den beiden Stufen ist mir auch auf den ersten Blick gar nicht aufgefallen. So ein Schwingkreis ergibt sich aber dann oft bei der Zusammenschaltung von HF-Verstärkerstufen..

@ Elektronikbastler
Klasse A scheidet schon von vornherein aus. Ist viel zu ineffizient, und warum sollte ich linear Verstärken bei FM?
Und mit der Glühlampe schätze ich meine Leistungen auch nicht, ich messe die lieber mit dem Lügenmeter (HP500) und dem Antennebnmessgerät. Ist "etwas" genau als sich die Helligkeit eines Glühlämpchens zu "merken" ;-), abgesehen davon siehst du an dem Glühlämpchen auch nicht, ob die Stufe wild schwingt oder ob überhaupt die Grundwelle die stärkste ist.

Falls die Frage aufkommt warum ich den 2n2219 als Treiber verwende (dieses ist ja eigentlich kein so optimaler Transistor für UKW und generell HF), es hat keinen speziellen Grund, sondern einfach nur den, dass ich davon seit Jahren ein ganzes "Säckchen" voll herum liegen habe und die irgendwie sinnvoll verbauen will ;-).

Wie auch immer, es ist nach wie vor so, dass die Schaltung auf den anderen völlig identisch aufgebauten und auch geätzen Platinen problemlos funktioniert, während nur auf dieser einen diese Schwingneigung besteht (aber eben nur bei 90-94 Mhz).

Ich hatte dann noch mal versucht, diese Schaltung auf einer kleine Extra.Platine nach zu bauen (mit geritzten Lötinseln) und von dem oszillator und Puffer auf der problemplatine gespeist.
Ergebnis:
Genau das gleiche. Unter 94 MHz schwingt das Ding rum, drüber nicht.
dann habe ich da auch noch mal alles eingebaut was ursprünglich vergessen wurde (also alle Maßnahmen die hier schon angesprochen wurden), hat aber auch nicht geholfen.
Ich habe es dann aufgegeben und noch mal was ganz anderes (bewährtes) gebaut, was auch von der Problemplatine gespeist zuverlässig läuft ohne wildes schwingen.
Sieht so aus:

Zunächst hatte ich nur die BFR96-Stufe gebaut, damit war schon kein wildes Schwingen mehr festzustellen und das HP500 zeigte sogar ein Watt an (was aber nicht stimmt, da das Ausgangssignal fast rechteckig ist und somit extrem Oberwellenhaltig, womit das HP500 ja nachweislich meist viel zu viel anzeigt), die zweite Stufe hatte ich dann zunächst auch wieder mit einem 2n3866 und auch testweise mit einem 2n3553 gebaut.
Da war dann erst mal wieder alles Mist ^^, nämlich auch wieder diese Schwingneigung unter 94 MHz da, die sich zwar mit den Maßnahmen von Oben beseitigen ließ, aber die Leistung ging dadurch auch wieder in Richtung nur noch 150 mW :-(.

Ich hatte dann die Schnauze voll und habe einen 2sc1970 mit Kühlkörper (mit Isolierscheibe und Glimmerplättchen) eingebaut, seit dem schwingt nichts mehr wild über das ganze UKW-Band, auf dem HP500 werden mir sogar 1,4 Watt angezeigt und alles ist gut. Auch wenn die Leistung auf dem HP500 wieder nicht stimmt, es werden praktisch eher um die 800 mW (auf 98 MHz) sein.
Ich habe die Vermutung, dass das ganze auch damit zusammen hängen kann, dass beim 2n3553 und 2n3866 ja nur mit einem Kühlstern kühlen kann, der ja leitend mit dem Kollektor verbunden ist. Beim 2SC1970 liegt zwar auch der Kollektor auf dem Gehäuse, aber da kann man ja eben mit Isolierscheiben arbeiten...

von Power-FM ne - am 31.10.2013 21:25
Wieviel Steuerleistung geht jetzt eigentlich in den Verstärker rein ?

Wenn die Steuerleistung tatsächlich schon so hoch ist, dass der BFR96 hier in
Klasse-C Betrieb arbeiten kann, dürfte der 2SC1970 mit seinen ca. 10dB Leistungsverstärkung die 800mW Ausgangsleistung ja schon alleine ohne den BFR96 schaffen .

Den Angaben zur 1.Schaltung nach ging ich eigentlich von einer Steuerleistung von ca. 20mW aus, mit der eine Klasse C-Stufe noch nicht funktionieren dürfte.

von carkiller08 - am 31.10.2013 22:24
So etwa 60-90 mW dürfen das sein, kann ich leider nicht genau messen. Es ist eun BF961-Oszillator mit einem weiteren BF961 als Pufferstufe (so beschaltet wie auf dem folgenden Bild):


von Power-FM ne - am 01.11.2013 10:44
Und jetzt mal nachgerechnet. Stimmt, theoretisch müsste ich auch ohne die bfr96-Stufe auf etwa 800 mW kommen (70 mW + 10 dB = ~ 810 mW). Müsste ich mal testen...

von Power-FM ne - am 01.11.2013 10:52
möchte beisteuern, dass sich die kammertechnik zusätzlich zu den genannten massnahmen bewährt. Jede Stufe in eine eigene Blechkammer. Damit sind Verkopplungen nahezu unmöglich.
lg

von frankyy - am 11.06.2014 16:58
Das mit dem Entkoppeln der Spulen ergibt ja durchaus alles Sinn und ist auch richtig.
Aber dennoch frage ich mich, wieso funktionieren eigentlich so viele Aufbauten, wo außer der Anordnung im 90° Winkel keine weiteren Entkopplungsmaßnahmen beachtet wurden, dennoch stabil und sauber, so lange sie mit einem ganz bestimmten Pegel angesteuert werden? Diesen Effekt habe ich nämlich schon oft beobachtet, so lange das Eingangssignal in dem "optimalem" Bereich bleibt, läuft alles astrein. Aber wehe, es wird auch nur etwas schwächer oder stärker oder fällt ganz weg, dann Schwingen die Stufen wie verrückt rum. Schaltet man dagegen die Endstufe direkt ohne Eingangssignal ein, schwingt nichts rum.
Es ist quasi so, dass das (im "korrektem" Pegelbereich liegende) Einganssignal die Endstufe vom wilden schwingen abhält, quasi die Endstufe "synchronisiert".
Sowas habe ich schon vor Jahren bei Eigenbauten beobachtet. Wie kommt das zustande?

von Power-FM ne - am 13.06.2014 19:22
... abhält, quasi die Endstufe "synchronisiert".

Schwingt immer noch. Siehste nur wegen des starken Nuztsignals nicht. Spekki dranhängen und sich am schönen Lattenzaun erfreuen (Mischprodukte aus Oszillation und Nuzsignale und deren Mischprodukte)

Baue selber nur noch Verstärkerstufen mit "Schwingbremse" (Gegenkopplung)

von joergel - am 23.09.2014 13:19
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.