Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
ChessBits-Computerschachforum
Beiträge im Thema:
13
Erster Beitrag:
vor 16 Jahren, 1 Monat
Letzter Beitrag:
vor 16 Jahren, 1 Monat
Beteiligte Autoren:
ELVIS, F.Huber, Harald Faber

Problem Rebel user Buch zu editieren

Startbeitrag von Harald Faber am 17.07.2002 04:47

Was mache ich falsch? Win 98SE, ich starte "rebel.exe s w7" und nach Laden eines korrekten Userbooks harald.rbm (im erforderlichen ASCII-Format mit korrekten Zügen wie E2E4 E7E5) bleibt im Menü "Bücher" (F5) der Menüpunkt "Bearbeite Benutzerbuch" grau und damit deaktiviert. Welche Bedingungen und Voraussetzungen müssen erfüllt sein, damit ein Bearbeiten möglich ist?
Es macht auch keinen Unterschied, wenn ich ein neues Benutzerbuch erzeuge, auch dann ist kein Bearbeiten möglich. Auch ein Wechsel in den Player-Player-Modus brachte keinen Erfolg. Hat irgendjemand eine Idee, woran es liegt und wie ich das Problem beseitigen kann?
Mein erster Gedanke war, dass eventuel im Pfadnamen irgendwo mehr als 8 Buchstaben vorkommen, aber auch ein Anlegen eines neuen Buches als C:\mein.rbm half nicht. Da ich Win98SE laufen habe, kann es an fehlenden Schreibberrechtigungen nicht liegen, auch das Dateisystem kann es nicht sein, denn auf dem anderen Rechner funktioniert das Bucheditieren unter Win2000prof auf NTFS.

Bin für jeden Hinweis dankbar!

Antworten:

Hi Harald,

das Buch selbst oder den CAP ?
Wie Du schreibst, wohl ersteres.


Ich habe dieses Problem noch nicht gesehen - falls Du vor einem totale Neuinstall ( versuchsweise ) zurückschreckst -

gibt's für mich nur einen Rat, der wohl der Beste überhaupt ist :

Problemschilderung an Schroeder BV helpline - zuzgl. an
Lex Loep +
Jeroen Noomen.

Da wird Sie geholfen - ich bin sicher.


Best



von ELVIS - am 17.07.2002 12:25
Hallo Harald,

das Problem dürfte wahrscheinlich bei der Maus(unterstützung)
liegen!

Meine ausführlicher Antwort findest Du im @#$%&-Forum.

Grüße,
Franz.

von F.Huber - am 17.07.2002 12:50
F.Huber schrieb:


> Hallo Harald,

>das Problem dürfte wahrscheinlich bei der Maus(unterstützung)
>liegen!

>Meine ausführlicher Antwort findest Du im @#$%&-Forum.

Hi Franz,


ich habe in diesem Forum nach Deiner Antwort gesucht und sie gelesen.

Natürlich ist Dir erst einmal für Deine Hilfestellung zu danken -

sie geht aber am Kern vorbei und ist technisch alogisch, resp. aus verschiedenen Gründen schon vom Ansatz her falsch,

wenn auch gut gemeint - daß das blos klar ist / bleibt !

Rebel / Century arbeiten im DOS protected mode genauso wie nach einem nativen DOS Diskettenstart.

Den hook on to W.xx siehst Du an vielen Dingen - schon der startup screen fordert Dich - AUCH aus W.xx heraus gestarted auf, eine Taste zu drücken oder.....einen Mausklick zu vollziehen.

Daß W.xx nur im "Tiefschlaf" resident liegt - siehst Du an der Geschwindigkeit des change backs von einem OS zum anderen - ergo ist der mouse.drv auch mit "entliehen" - resp. wird normal mit eingebunden.

M.E. nach kann DAS NICHT die Ursache sein - aus technischen Gründen.

Best



von ELVIS - am 17.07.2002 13:09
Übrigens, falls es absolut nicht klappen will / kann - dann mail' mich an.

Falls Du alles über DOS vergessen hast....:D

'bau ich Dir dann fix ne autoexec + ne config,sys - was man seit DOS 3.0 gelernt hat, vergisst man nicht.

Nur, wenn Du einen speziellen mouse.drv wünschst, brauch' ich die korrekte location von dem Teil für den Aufruf.

Best



von ELVIS - am 17.07.2002 16:02
Hi Elvis,

>Natürlich ist Dir erst einmal für Deine Hilfestellung zu danken -
>sie geht aber am Kern vorbei und ist technisch alogisch, resp. aus >verschiedenen Gründen schon vom Ansatz her falsch,
>wenn auch gut gemeint - daß das blos klar ist / bleibt !
>M.E. nach kann DAS NICHT die Ursache sein - aus technischen >Gründen.

ich frag mich nur, warum es - wenn schon ´technisch alogisch´ bzw.
´vom Ansatz her falsch´ - dann aber doch funktioniert ? :confused:

Na ja, wahrscheinlich hab ich mit meinen 20 Jahren Computer-
praxis doch noch etwas weniger Erfahrung als Du -
trotzdem kann ich eigentlich fast immer meine Probleme (oder
die anderer) lösen! :-)

Solltest DU mal ein Problem haben, hoffe ich für Dich, dass Du
jemand kompetenteren als mich findest. :D

Grüße,
Franz.

von F.Huber - am 17.07.2002 16:38
F.Huber schrieb:


Hi Elvis,

Hi Franz -

>ich frag mich nur, warum es - wenn schon ´technisch alogisch´
>bzw.
>´vom Ansatz her falsch´ - dann aber doch funktioniert ?
:confused:

Das ist einfach beantwortet - und das weisst Du auch :

Harald fragte gar nicht nach einem singulären DOS Start.
Der ist ähnlich lange dabei wie Du + ich.....
ein Multiboot hat jede 3. klassige sharewaresammlung parat - fix + fertig.....

Rebel / Century ist so programmiert, daß die gesamte GUI unter DOS in der Box funzen MUSS -

vgl. dazu ganz unten :-)

>Na ja, wahrscheinlich hab ich mit meinen 20 Jahren Computer-
>praxis doch noch etwas weniger Erfahrung als Du -
>trotzdem kann ich eigentlich fast immer meine Probleme (oder
>die anderer) lösen! :-)

Das bezweifle ich auch nicht - mit keinem Wort.
Ich fummel an den Dingern seit ATARI XL 800 rum - ohne Pause....spielt aber gar keine Rolle.
Keiner weiss alles + oft ist ein Tip vom anderen Kopf der Bringer -

Ich habe mir nur erlaubt, auf den technischen Zusammenhang hinzuweisen -
und deswegen die Anmerkung auf den falschen Lösungsansatz, der zwar funzt - aber quasi durch eine andere Straße.....um die ging's aber nicht -

ich hatte - gehofft - daß man das technisch / pragmatisch für - mit Harald diskutieren könnte, leider scheinst Du mein posting in den "falschen Hals" gekriegt zu haben -

völlig unnötig -
trotzdem sorry, wenn's so sein sollte !

>Solltest DU mal ein Problem haben, hoffe ich für Dich, dass Du
>jemand kompetenteren als mich findest. :D

Im Gegenteil - ich rufe Dich an ! ;-)


Best

PS :
was ist denn nun ?
Siehst Du eine Möglichkeit, das Teil DOCH mit den erwünschten Prämissen unter Wxx zu starten ?
Zaunpfahl :
Rechtsklick - Eigenschaften....na ? :D :D




von ELVIS - am 17.07.2002 17:04
Hallo Elvis,

also da ich diese ´Streit´-Threads absolut nicht ausstehen kann,
ist das jetzt meine letzte Antwort zu diesem Thema:

Im Gegensatz zu Deinem Vorschlag, sich an Ed Schröder usw. direkt
zu wenden, habe ich wenigstens versucht, dem Problem bzw.
seiner Ursache auf den Grund zu gehen - und ich bin mir sicher,
diese Ursache (nämlich die fehlende Mausunterstützung) auch
gefunden zu haben.

Was Harald dann aus meinem Hinweis macht, ist seine Sache.
Ob er nun Rebel im reinen DOS startet, oder im DOS-Modus oder
DOS-Box unter Windows, soll er selbst entscheiden - in jedem
Fall braucht er jedoch eine aktivierte Mausunterstützung, wenn
er ein Rebel-Buch editieren will - mehr (oder weniger) habe ich
mit meiner Antwort an Harald nicht gesagt.

Natürlich könnte es auch im DOS-Modus klappen, aber wahrscheinlich
hat er dann eben die Mausunterstützung nicht eingestellt.
Das kann (und will) ich aber gar nicht ausprobieren, da ich
jedenfalls solche Programme immer unter reinem DOS starte
(eben mit Boot-Menü) - die laufen damit einfach sicherer.

Grüße,
Franz.

von F.Huber - am 17.07.2002 17:51

Re: Problem Rebel user Buch - wird Harald wohl lösen

Na, das klingt dann doch etwas anders als im Forum der Herren Kollegen.

Harald hat Dir dortens ja recht deutlich geschrieben, was er zu machen gedenkt und was er eben nicht möchte.

Fazit :

jeder ist Herr über seinen Recher -

BTW :
wie hiess der Rechner von vor 20 Jahren ?

ZX 80 oder wie ?


Best



von ELVIS - am 17.07.2002 17:55
ELVIS schrieb:

Zitat

Übrigens, falls es absolut nicht klappen will / kann - dann
mail' mich an.

Falls Du alles über DOS vergessen hast....:D

'bau ich Dir dann fix ne autoexec + ne config,sys - was man
seit DOS 3.0 gelernt hat, vergisst man nicht.

Nur, wenn Du einen speziellen mouse.drv wünschst, brauch' ich
die korrekte location von dem Teil für den Aufruf.

Best

ELVIS
Editor In Chief
ChessBits Magazine


Also bislang klappt es nicht. Weder mit aus-einschalten der Maussteuerung direkt unter Rebel noch mit dem vergeblichen Versuch, in der autoexec nen maustreiber einzubinden. (C:\mouse\mouse.exe) Hole ich mir dann die dos-eingabeaufforderung, und will diesen maustreiber noch mal aufrufen, meckert win98, dass bereits ein (anderer) Maustreiber geladen sei.
Allerdings werde ich noch mal meine grauen Zellen anstrengen, denn da war ja was mit mouse.drv in der Tat...

Auf jeden Fall wieder nix als Ärger mit dem DOSen-Dreck...
Kannst mir ja evtl. kurz per email noch mal auf die Sprümge helfen wg config und autoexec, ich frickel mal eben weiter...

von Harald Faber - am 17.07.2002 18:41

DAS IST DIE LÖSUNG

Franz hat mich noch mal auf den richtigen Dampfer gebracht: "Einfach" die rebel.cfg löschen, danach ging es wieder!
Weiß der Henker, was sich da eingenistet hatte, um ein Bucheditieren zu verhindern.

Für Elvis: An Ed direkt habe ich mich nicht gewandt, weil seine Antwortzeiten meistens zwischen 2 Wochen und unendlich liegen. Und da er jetzt eh für so einen "Killefit" keine Zeit hat, um irgendwann mal Rebel XP (zur Erinnerung: angekündigt für April, spätestens Mai diesen Jahres, jetzt haben wir Mitte Juli...und man hört nichts mehr davon seit Wochen, angekündigt ist es auf seiner Homepage auch nicht) herauszubringen, habe ich ihn gar nicht erst direkt gefragt, sondern nur in seinem Forum "angeklopft". Bis zu diesem Zeitpunkt nicht eine einzige Antwort.

von Harald Faber - am 18.07.2002 04:43

So geht´s natürlich auch ...

daß man die Entgegnungen der anderen einfach löscht!

Da bleibt dann der Eindruck SO stehen, wie ihn die Forums-
Betreiber gern haben möchten.

Danke!

von F.Huber - am 18.07.2002 20:41

Re: So geht´s natürlich auch ...

Es geht NUR so, hier jedenfalls, werter SF Huber !

Wir haben hier von Anfang an bestimmte Forumsregeln.
Wer hier getroffene Aussagen in andere Fora trägt, um sie dortens völlig verzerrt wiederzugeben, dem unterstelle ich eine gewisse Insistion.

Ausserdem bin ich nicht bereit, hier mit alltäglich stundenlangen Aufwand darüber zu wachen, daß der Nettiquette des www und im übrigen dem BGB für alle Leser / Besucher hier Genüge getan wird

um mir im "Gegenzug" dann Artigkeiten der besonderen Art, wie von Ihnen dargelegt, bieten zu lassen.

Unternehmen Sie analoge Versuche andernorts, beispielsweise, indem Sie z.B. die erwähnte Medikamentenvermutung dem Dieter andienen - sie werden dann wohl Ihr posting schneller erased sehen, als wie sie es selbst würden lesen können.

Und wenn auch nicht - jedes Forum hat seine Regeln - wir hier unsere.
Personenschutz gilt auch,selbst wenn Sie das kaum glauben mögen,
auch für mich - und wenn ich 20 x Mitherausgeber und Chefredakteur bin, das ändert nichts an der Wahrung der Menschenwürde.

In diesem Sinne



von ELVIS - am 18.07.2002 21:10
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.