Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 6 Jahren, 9 Monaten
Letzter Beitrag:
vor 6 Jahren, 9 Monaten
Beteiligte Autoren:
Erik Schwarz, Arie, Manfred

Weird error in app

Startbeitrag von Erik Schwarz am 28.09.2011 15:01

Hi,

a small app, which I added some functionality. Runs fine on all my pc's.
At the customer the following error message comes up:

HReadFirst function called.
file unknown in analysis, or query/view not initialized.

where the path mentioned is the one on my development pc.
Did clear cpl directory, recompile, repair, creation.
Nothing helps. By chance it ran once at my customer and since then no more.

Any ideas?

Erik

Antworten:

Erik i think that y:spos:ou need define the connection, in develop pc you have a default connection


see this http://doc.pcsoft.fr/en-US/?1000003044107&name=hopenconnection-example

Regards

Manfred

von Manfred - am 28.09.2011 15:10

Re: Weird error in app (full info)

Sorry, didn't see that the forum did not show the complete sentence of the message I copied:
(Changed the greater and smaller signs into minus and try again

HReadFirst function called.
-QRY_BuchungZeitJournal- file unknown in -C:\A14-TT7-Entwicklung\TimeTouch-Version7\TimeTouch7.wdd> analysis, or query/view not initialized.

Hope that clears up, database connections are all defined (no default)

And, I didn't anything else than I did the last years and had never had this message.

Erik


von Erik Schwarz - am 28.09.2011 16:53

Re: Weird error in app (full info)

This means there something wrong with your query QRY_BuchungZeitJournal
I guess you use HExecuteQuery(QRY_BuchungZeitJournal) somewhere before. It will result FALSE. At that point Herrorinfo() will give you what is going wrong.

All further actions on this query then will also going wrong, i.e. HReadFirst(QRY_BuchungZeitJournal).

von Arie - am 28.09.2011 17:04

Re: Weird error in app (full info) - Solution

Hi,

to be sure, I deleted all cpl directories - recompile - regeneration of exe.
At my customer, creating all new directories and copy the program files there.
Now all is running again like ever :) .

Seemed that anywhere at the customers pc there was a 'hidden' link to my development-folder instead of the local one :confused:

Thanks for all hints

Erik

von Erik Schwarz - am 29.09.2011 09:39
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.