Disable automatic variable naming

Startbeitrag von jeff am 28.08.2012 02:00

Is there any way to disable the automatic variable naming that happens in WD14? For instance, I want to create a data model file following the pattern "prefix_name" but it insists on renaming it to "Prefix_name." I know it seems silly, but it drives me crazy.

Thanks,
Jeff

Antworten:

Hello Jeff

It is controlled from the project description, but first make sure you have access to it.

From the main IDE menu Tools > Options of the environment turn on "Advanced Project Options"

Then in the Project > Descriptions > Options you will find the programming charter options.

Regards
Al

von Al - am 28.08.2012 02:47
Al,

Thanks for the response. Even if I completely disable the checkbox labeled "automatically prefix the variables and elements found in the project" WD seems to behave the same way. Just to be clear, it doesn't seem to add a new prefix to the data model file, but rather just forces the very first letter to be uppercase. For example, let's say I'm creating a table for User objects in an application named My Application. I'd end up creating a table named "ma_user" in MySQL and I'd want to name the file in the WD analysis the same way. It insists on naming it "Ma_user" and forces that intitial capital letter pattern no matter how crafty I get (using any combination of backspace/delete, pasting in a different value, etc). Any other ideas?

Thanks,
Jeff

von jeff - am 28.08.2012 21:26
Hello Jeff

Sorry I missread your first post. The solution I mentioned only works in the code.
I have similar issues in the analysis with it capitalising field names randomly and generally I allow it to save that row and then go back and edit it and it is ok.

In terms of the file name, I must admit I have never tried to create a lower case name but I have just opened up my V16 analysis and it allows me to create lower case file names so it may be a V14 issue.

Regards
Al

von Al - am 28.08.2012 21:56
Al,

Would you mind telling me what screen you're doing that on? Here's what I'm doing:

1. Open the Data Model Editor screen (Project->Load the analysis)
2. Right click on a MySQL file, choose Item Description
3. Click the File Properties button (the icon under the name and just above the table)
4. Make sure the Info tab is showing, and attempt to make the "Name" field start with a lowercase letter

Thanks,
Jeff

von jeff - am 29.08.2012 01:56
Hello Jeff

I don't have any MySQL files but there is certainly no issue with normal Hyper files or MS SQL Server files.
I created a MuyQL file in the analysis as best I could to test for you and had no problems creating a file name starting with lower case and then changing back and forwards from upper and lower case. The only proviso is that I did not have a valid connection to a MySQL database.

It looks like it could be a V14 issue or maybe something inherited from a setting in the MySQL database you are connecting to ?

Regards
Al

von Al - am 29.08.2012 09:16
For anyone else that happens to run into the same problem, I was able to come up with a reasonable workaround. I created my new table in the MySQL database with the name and all of the columns/attributes I wanted, then simply used the WinDev data model file import. For whatever reason, it imported the name as-is (which was lowercase).

Thanks,
Jeff

von jeff - am 30.08.2012 22:34
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.