Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 5 Jahren, 1 Monat
Letzter Beitrag:
vor 5 Jahren, 1 Monat
Beteiligte Autoren:
Alexander S., Paulo Oliveira

"/" separator do not work in URL rewriting (Webdev 17)

Startbeitrag von Alexander S. am 27.09.2012 19:52

When I use "-" separator in URL rewriting all work ok, and the pages with 2 parameters open fine, fo exampe:

http://misite/category-model.awp


But when I use "/" separator I have the error "The webpage cannot be found HTTP 404".
fo exampe:

http://misite/category/model.awp -- do not work((


(Apache/2.2.22 (Win32) mod_ssl/2.2.22 OpenSSL/1.0.1c PHP/5.3.3 Server at localhost Port 80)

Why the "/" separator do not work?

Antworten:

Is there anybody who have this problem too?

von Alexander S. - am 28.09.2012 20:29
Alexander why / as a separator?
the / is a used as a standard separtor in the url to separate the protocol, domain and so on.
If you really need to use the / in your page name, i can't find out why but....
you have to use some decode method, check the help for URLDecode to see how you can do it.
http://doc.windev.com/en-US/?3024040&name=urlencode_function&q=URLDecode

von Paulo Oliveira - am 01.10.2012 09:56
Quote
Paulo Oliveira
Alexander why / as a separator?
the / is a used as a standard separtor in the url to separate the protocol, domain and so on.


Paulo, you do not understand me maybe... I mean a Webdev URL Rewriting

For example, a page used to display a list of products whose URL is:
http://www.mysite.com/PAGE_ProductForm.awp?Category=Cars&Make=Ferrari&Year=2008

can be presented to the Web users and to the search engines with the following URL:
http://www.mysite.com/car-ferrari-2008.awp

or:

http://www.mysite.com/ferrari/2008/cars.awp

Last URL with / separator do not work in Webdev 17 and with my configuration (Apache/2.2.22 (Win32) mod_ssl/2.2.22 OpenSSL/1.0.1c PHP/5.3.3 Server at localhost Port 80), do not know about others....

von Alexander S. - am 01.10.2012 19:12
Today I received an answer from a free technical support: bad news((

Quote

Hi Oleksandr,
The "/" separator is indeed not supported with Apache, it will run with IIS. My suggestion is to use "-" instead, that will work with both servers.
Our developers are aware of this problem that has no solution at the moment. Please use this reference if you contact me upon this matter again: #73 637/528942. I'll keep you posted.

The Free Technical Support is entirely at your service.


von Alexander S. - am 02.10.2012 14:30
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.