Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 5 Jahren, 6 Monaten
Letzter Beitrag:
vor 5 Jahren, 6 Monaten
Beteiligte Autoren:
Paul Murray, Al

Cannot deploy Windev Mobile App to Samsung Galaxy Tab

Startbeitrag von Paul Murray am 23.12.2012 04:21

Greetings all,

At some point today I was able to create an emulator for the Samsung Galaxy Tab. At some point it came up (in landscape as opposed to the desired portrait view).

Then I tried to connect directly to the device. I have 'USB debugging' turned on.

Each time I connect the device it seems like some times it is finds it and some times not.

Sometimes I see that it 'sees' the Samsung Galaxy Tab. Then immediately aftwards I see my Windows XP system is now looking for a CDC devices which it does not find.

So I cannot deploy to the device and I cannot deploy to the emulator. Even though I 'see' the device in the emulator window. Earlier today I could run the Galaxy Tab in the emulator. Now I cannot. I get this error:

The 'SamsungGalaxyTab' emulator was not detected after its startup.

I have restarted my computer and done all I can to to connect to either the emulator or the physical device.

Can someone kindly provide any kind of step by step process to include this device in my project?

P.S., I ran the SDK Manager and I see it is running 2.3.3 which is what this device can run as is. Also, I ran the AVD Manager and created the new emulator, but outside of the thing actually being connected via the USB cable I cannot figure out how else it would know it is connect to..

The device is up and running when I try to connect.

Any guidance is appreciated.

Thanks!!

Paul

Antworten:

Hello Paul

I have 4 hardware identical workstations running XP. Three of them could not see the Samsung tablet and one could, so I cloned the hard disk from the one that could and now I have two workstations that can see the tablet. I was never able to find out what the magical differences were in the operating systems of the workstations.

Try downloading the Samsung Kies software.
http://www.samsung.com/au/support/usefulsoftware/KIES/JSP

If it can see the tablet, the problem is with WIndev, if not, and this was the case on my workstations, then the problem is in your workstation.

Regards
Al

von Al - am 23.12.2012 04:32
Thanks Al,

I find this all confusing and so I probably did not note the most important part. When I try to deploy to the Samsung Galaxy Tab emulator (because I can't see the real thing)...I get an error stating that:

**********************************************

The 'SamsungGalaxyTab' emulator was not detected after its startup.

**********************************************

Technical Information

What happened?
The 'SamsungGalaxyTab' emulator was not detected after its startup.

Error code: 46
Level: non-fatal error (EL_ONRETURN)

Dump of the error of 'WDJAVA.DLL' module (17.0.163.0).
Identifier of detailed information (.err): 19576
"

The ODD thing is that after I get this error and click the Close button I get a new error window that says The 'SamsungGalaxyTab' emulator was not detected after its startup.'

But of course, I then see that I have two windows open:

One is entitled tools/emulator-arm.exe and is a dos window with nothing in it.
The second is entitled 5554:SamsungGalaxyTab and it actually has a very nice emulator running. The PROBLEM is that I can't find my application anywhere in it. And normally my application is the first thing I see when I deploy.

PATRICK where are you when I need you?

Best to all and thanks for all of your help!!

Also, Merry Christmas, Everyone!!!!!!!!!!!!!!!

Paul

von Paul Murray - am 23.12.2012 05:25
Al,

I forgot. Sorry, I will try this next: Try downloading the Samsung Kies software.
http://www.samsung.com/au/support/usefulsoftware/KIES/JSP

Best,

Paul

von Paul Murray - am 23.12.2012 05:26
I download and installed Samsung Kies. It also seemed not to be able to connect to the device. I tried the diagnostic and that didn't help either. Now when I have the Galaxy Tab connected I hear the bonging of what sounds like multiple connection attempts. Who knows maybe I have the wrong driver installed from before and there is some conflict.

von Paul Murray - am 23.12.2012 17:59
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.