Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
7
Erster Beitrag:
vor 5 Jahren, 6 Monaten
Letzter Beitrag:
vor 5 Jahren, 6 Monaten
Beteiligte Autoren:
Gianni Spano, Michael Drechsel, Chris du Toit, Piet van Zanten, Fabrice Harari

Webdev 17 -Trying to deploy my first site

Startbeitrag von Gianni Spano am 12.02.2013 11:07

Hello to all

I'm trying to deploy my first site (Intranet) using a remote server in our lan.

All seems to be fine, except for these errors message from the ftp server :

Checking the version of the application server
Validating the deployment parameters
Failure sending information via FTP.
Error message returned by system:Unable to create TEMC557.tmp file or to open it in write mode.
Last Server Response: 200 Type set to I
227 Entering Passive Mode (192,168,26,235,5,163)
550 Permission denied

Check whether the FTP communication is not disrupted by a firewall. To do so, try the active and passive transfer modes (available in the advanced options).

Any help?

Thanks in advance

Gianni

Antworten:

Hello Gianni

haaaaa... the first deployment on a new server... always so peacefull :D

Well, as the message state, this message may indicate that you have a firewall problem, but also IPSEC problem; or even simply permissions/rights problem on the target directory...

So, when you configured the server, did you follow in details the PDF of instructions coming with webdev server?
If no, start by there... If yes, try deactivating the firewal and fully opening IPSEC to see if it's coming from there...

And let us know

Best regards

von Fabrice Harari - am 12.02.2013 13:28
Hi Gianni,

I don't want to discourage you, but my experience with the remote setup by ftp is very frustrating.
On none of my Linux servers I could get the ftp part of the remote setup working. (I tried many)
I always had to manually configure the sites on Linux.
When I switched to Windows 2008 server the remote setup still was faulty and I decided not to spend too much time on this.
Now I create a setup by physical media, manually transfer the Install folder to my server by ftp and then execute the setup program on the server. Simple and it always works. It also avoids having to "pollute" my server with extra users and home directories for each site.

Regards, Piet

von Piet van Zanten - am 12.02.2013 13:55
Hello Fabrice & Piet

Thank you both for your suggestions.
Tomorrow morning i will give a try.

Thanks again.

Gianni

von Gianni Spano - am 12.02.2013 17:18
My remote setup works well (Sorry Piet ;) ) but it took a lot, and I mean a lot, of trial and error.

On Windows and Linux it finally turned out to be permissions related. I lost a lot of time and sleep getting it working but once it worked, it worked.

von Chris du Toit - am 12.02.2013 19:37
Yes,

for me its also working.

The only thing that I can´t get into work is:

Set the site settings remote (User, Timeout etc.) to the "default configuration". No way since WB12 ....

von Michael Drechsel - am 13.02.2013 07:06

Re: Webdev 17 -Trying to deploy my first site **SOLVED**

Hello to All

As suggested by Piet, i've created a standalone setup and installed on the local server.
All is running fine...Wow!! Sorry, i seem to be a child using the new toy!! :)

There was another simple problem with Apache 2.2, but it has been resolved:
it was depending from the configuration file.

Thanks to friends that helped me...

Regards

Gianni

von Gianni Spano - am 14.02.2013 10:05
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.