Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
8
Erster Beitrag:
vor 5 Jahren, 4 Monaten
Letzter Beitrag:
vor 3 Jahren, 2 Monaten
Beteiligte Autoren:
Marijan Tomasic, Gus, Piet van Zanten

Installing Wedev app server on Linux - help please!

Startbeitrag von Marijan Tomasic am 14.02.2013 11:59

Hello All!

After 2 days of playing with Ubuntu Server 12.04, I'm stuck ...
I installed according to instructions WebDev App Server (free version), but there was a mistake I do not know rectified. I am a beginner to Linux.

At the link: http://servername/WD170AWP/WD170AWP/version

I get:


WebDev 17.0 Linux 32bits
Copyright © 1993-2012 PC SOFT
WD170AWP ​​17.0.141.4 VI: 30A170069w
wd170session 17.0.141.4 VI: 30A170069w
wd170admind 17.0.141.4 VI: 30A170069w
(TST) 430384167-1688684475-139978-TC
10CNX




Other links do not work:

http://servername/WDAdminWeb170
http://servername/WDAdminHF170
http://servername/WDAdminSaaS170


Response is:


Not Found

The requested URL /WDAdminWeb170 was not found on this server.
Apache/2.2.22 (Ubuntu) Server at 10.0.176.50 Port 80




I suspect the problem is in / etc/apache2/WebDev17.conf file.
The following lines generate an error when starting the Apache server, so I have omitted them:


...
Action application/WebDev17-awp /WD170AWP/WD170AWP virtual

Action application/WebDev17-awws /WD170AWP/WD170AWP virtual
...




I would be very grateful for your help!
Thank You!

Marijan

Antworten:

Hi Marijan,

I think in the latest Apache releases the config files are structured in a different way.
Webdev is not aware of that yet.
I must do this by heart, but the Action commands are probably stored in the Actions.conf file instead of the in httpd.conf file.
So what you can do is remove these lines form the Wedev17.conf file and move them to the Actions.conf file.

Regards,
Piet

von Piet van Zanten - am 14.02.2013 12:20
Thank You Piet,

You are right. But problem is not solved.
So if enybody have needed experience (Linux, Apache) let put few lines here please!

Regards,
Marijan

von Marijan Tomasic - am 18.02.2013 06:28
Hi Marijan,

I think I remember what was the case now.
The actions and alias modules are probably not enabled by default.
You need to enable them by moving the configuration files from the available to the enabled directory.
I don't have a Linux server anymore so I cannot give exact directions.

Regards,
Piet

von Piet van Zanten - am 18.02.2013 10:10
Thank you Piet, it helped.

Now it works.

Best Regards!
Marijan

von Marijan Tomasic - am 18.02.2013 10:52
Hello Marijan:
Could you please tell exactly which configuration files you moved from available to enabled directory?

I 'm struggling with the same problem.

Regards;
Gus

von Gus - am 13.04.2015 18:52
Quote
Gus
Could you please tell exactly which configuration files you moved from available to enabled directory?


Hello Gus,

I'm sorry I can not remember specifically what I did, but I know that it should enable the module actions and module alias on Apache (thanks to the advice of Piet).
This has solved my problem.

Regards,
Marijan

von Marijan Tomasic - am 14.04.2015 05:58
Hello Marijan:
I figured it out.

Basically, you need to run
sudo a2enmod actions

and restart apache:

sudo service apache2 restart.

After this, it should work.

Thanks for the reply.
Gus

von Gus - am 14.04.2015 15:59
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.