Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
3
Erster Beitrag:
vor 4 Jahren, 9 Monaten
Letzter Beitrag:
vor 4 Jahren, 9 Monaten
Beteiligte Autoren:
Fabrice Harari.pcs.crosspost, Piet van Zanten, Stef.pcs.crosspost

WTF ? Wierd bug

Startbeitrag von Stef.pcs.crosspost am 25.03.2013 08:02

Any command on the first line of an "Exit with modification (onchange)" browser code of an edit control is rejected with errors that are completely not appropriate and simply incorrect.

For example
EDT_v1..X=200 generates an error saying "indirection is not allowed in browser code".
This isn't even indirection !!!
Any correct command I write there is rejected with the most insane error notifications.
When I simply add an empty line first all correct code is suddenly accepted ?!
Removing the empty line causes the errors to re-appear ??

I must admit that this is the wierdest bug I have ever seen. The workaround is simply leaving the empty line so the problem is solved for me, I just wanted to inform all of you about this issue.
I just updated my WebDev 17 with the latest release, maybe this causes the error I have not experienced before ?

Message forwarded from pcsoft.us.windev

Antworten:

Hi Stef,

The editor has problems keeping browser code up to date.
The only way to get rid of obsolete or erratic error messages is a complete recompile. :(

Regards,
Piet

von Piet van Zanten - am 25.03.2013 12:23
Hi Stef

I tried the same thing without any problem...

You should try to exit your project, delete the .cpl directory and the
..env file, then renter the project and recompile and see if that solves
the problem

best regards



On 3/25/2013 4:02 AM, Stef wrote:
> Any command on the first line of an "Exit with modification (onchange)" browser code of an edit control is rejected with errors that are completely not appropriate and simply incorrect.
>
> For example
> EDT_v1..X=200 generates an error saying "indirection is not allowed in browser code".
> This isn't even indirection !!!
> Any correct command I write there is rejected with the most insane error notifications.
> When I simply add an empty line first all correct code is suddenly accepted ?!
> Removing the empty line causes the errors to re-appear ??
>
> I must admit that this is the wierdest bug I have ever seen. The workaround is simply leaving the empty line so the problem is solved for me, I just wanted to inform all of you about this issue.
> I just updated my WebDev 17 with the latest release, maybe this causes the error I have not experienced before ?
>
Message forwarded from pcsoft.us.windev

von Fabrice Harari.pcs.crosspost - am 25.03.2013 12:37
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.