Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
12
Erster Beitrag:
vor 5 Jahren
Letzter Beitrag:
vor 4 Jahren, 11 Monaten
Beteiligte Autoren:
Michael Drechsel, kingDR, Piet van Zanten, Fabrice Harari, Kingdr, KenKnight, kingdr

WB17 runs on IE compatiblity mode

Startbeitrag von kingDR am 03.04.2013 20:01

Hi All

Just upgraded IE10 on Windows 7-64 bit but need to click little compatibility button
to run wb17 apps and it's all ok in IE9 and other browsers.

Any clues as I don't find out any patches from windev site at all.

Thx in advance.

Cheers
King

Antworten:

but it works automatically under Windows 8 - 64bit (IE10), I meant without clicking
any compatibility view at all.

???

King

von kingDR - am 03.04.2013 20:08
Hi King

from what I've read on the web, IE10 is still quite buggy and incompatible with everything else... Several 'expert' opinions have read are stating to wait to install it for now...

So we may be waiting for an IE update before we get a webdev update :-)

Best regards

von Fabrice Harari - am 03.04.2013 20:29
Thanks for yr quick reply Fabrice

Hmm... there's no way to downgrade to IE9 any more.

Thanks anyway

Cheers
King

von Kingdr - am 03.04.2013 20:32
Hi King,

You can remove the update with remove programs, display updates.

Regards,
Piet

von Piet van Zanten - am 04.04.2013 06:24
Thanks Piet but it looks like IE10 will have a patch soon.

Cheers
King

von Kingdr - am 05.04.2013 07:42
Hi everybody

one temporary fix seems to tell IE10 to work in IE9 mode by doing the following:
- Go in the page description (or template description)
- Go in the ADVANCED tab :
- Add the following:
http-equiv
X-UA-Compatible
IE=EmulateIE9

That should help... Of course, it would be better to wait for IE10 to work correctly, but I'm pretty sure our users wont listen to us

Best regards

von Fabrice Harari - am 17.04.2013 21:23
Hi,

On www.windev.com on the download WB17 section there's a IE10 compatibility update.

Regards,
Piet

von Piet van Zanten - am 18.04.2013 09:47
Thanks All for advice, must try out anyway.

For Fabrice, pls let me know when you'll have latest version of training videos
for wx17 or above, pls give me a shout then.

Thanks again

Cheers
King :)

von kingdr - am 19.04.2013 01:52
Hi,

I have some problems with Ajaxcalls in IE10 and WB16.
The results from the ajax calls are always empty.
I put "[meta http-equiv="X-UA-Compatible" content="IE=EmulateIE9" /]
in the html section from the advanced section but it doesn´t work.

No problems with IE9, FF, Chrome, Opera.

Any Ideas ?

von Michael Drechsel - am 15.05.2013 13:52
ok, solved. When I put it in the table it works.

von Michael Drechsel - am 15.05.2013 13:57
Hi all,

Just a quick note here. If you manage your own server you can put the X-UA-Compatible as a header that is automatically delivered by the server, for the entire server or for specific apps. However, if you do this to an existing site, make sure you put some kind of expire header in for a few days so that people who have previously cached instances of your content in their browser will get an update. If you don't some of the pages may display incorrectly.


Cheers!
Ken

von KenKnight - am 23.05.2013 12:02
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.