Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 4 Jahren, 9 Monaten
Letzter Beitrag:
vor 4 Jahren, 9 Monaten
Beteiligte Autoren:
Geoff B, Gianni Spano, Giovanni Carella

WB17 - MySQL Native Access - SOLVED!

Startbeitrag von Geoff B am 10.04.2013 05:24

I'm trying to create an analysis for a new php project by importing an existing mysql database.

1. I have installed the mysql native driver.
2. I have updated my "path" environment variable to include...
C:\WebDev 17\Programs\Engine\PHP\bin
3. I have made sure that libmysql.dll is in that folder
4. When this failed, I have copied the Xampp mysql version of libmysql.dll to the same folder.

I still get the attached error when I try to import the database.

Any idea what I can try??

I can run the "Blogs" example application and it connects to my database, but it uses an analysis based on Hyperfiles, and I want to use an existing mysql database for the analysis.

I am not running IIS.

Windows 7 64 bit
Xampp 1.7.7
[attachment 301 mysqlnative.png]

Antworten:

Re: WB17 - MySQL Native Access - no can do!

Hello Geoff

You need to install the LIBMYSQL.DLL file in the same directory where you install/deploy the executable files.

HTH
Gianni

von Gianni Spano - am 10.04.2013 06:59

Re: WB17 - MySQL Native Access - no can do!

Last Minute.....

There are around the web a lot of different version of the LIBMYSQL.DLL file.
I remember, some year go, i had the same problem with Windev.

If you want, i can send you the version i'm using...
Pls, contact me at gmspano at tiscali dot it

Gianni

von Gianni Spano - am 10.04.2013 07:02

Re: WB17 - MySQL Native Access - no can do!

you must be use a 64bit of LIBMYSQL.DLL, is different...

von Giovanni Carella - am 10.04.2013 07:18
Thanks for the tips!

I did a search for libmysql.dll 64bit and found some advice that said I needed to copy the libmysql.dll file into the c:\windows\SysWow64 folder.

I copied the libmysql.dll file from my mysql\lib folder to c:\windows\SysWow64 folder and now WebDev can connect ok to my database!

(I suspect that WebDev is running 64bit which is why the file needs to be copied to that folder - pretty sure the version of mysql I am using is the 32 bit version?)

von Geoff B - am 10.04.2013 10:49
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.