Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
6
Erster Beitrag:
vor 4 Jahren, 9 Monaten
Letzter Beitrag:
vor 4 Jahren, 5 Monaten
Beteiligte Autoren:
Charles U. Schneiter, Fabrice Harari, Frans

[Also on WD 18] Insufficient rights for Restore...

Startbeitrag von Charles U. Schneiter am 25.04.2013 11:45

Hi folks,
--> This was in regard to [WD 17] -> see latest message from me re the same problem on WD 18!

Very frequently I develop on my notebook @ home and continue on my workstation @ the office and vice versa. I do this by going to Tools \ Save the project... and save it onto an USB stick.

On the other machine I do the vice versa and now (since taking up development in earnest, this did work a few months ago..) I get the following error message on either machine (highlite by me) :

**********************************************
Problem restoring the archive of the project.
Insufficient rights to access this file.
**********************************************
Technical Information

What happened?
Problem restoring the archive of the project.

Insufficient rights to access this file.

Error code: 0
Level: fatal error (EL_FATAL)

Dump of the error of 'WDPRJ.DLL' module (17.0.245.6).
**********************************************


Going to the properties of the zip-file, I checked that the file is not write protected. Checking one of the files inside the zip, it shows Administrators as owner. On both machines I do log on with Admin rights...

Any body seen the same stuff before?

Thaks for your time!

Charles

P.S: Notebook @home is running Win XP Pro SP3
Workstation @ office runs Win 7 Pro latest...

Antworten:

Re: [WD 17] Insufficient rights for Restore...

Hi Charles,

I use it very often. Never had such a problem.

You could restore it within windows explorer.
Or try to use WdZip (menu; tools; WdZip).

von Frans - am 25.04.2013 12:32

Re: [WD 17] Insufficient rights for Restore...

Hi Charles

you can try to extract the whole thing using a regular zip manager... You will easily see this way if the problem is coming from the zip file...

You can also start by copying the zip file on the hard drive and try restoring from there (problem coming from the flash drive)

Finally, you can try to rename your original project directory and try restoring on an empty target (problem coming from the in place project directory

Best regards

von Fabrice Harari - am 25.04.2013 12:36

Re: [WD 17] Insufficient rights for Restore...

Hi Frans and Fabrice,

Many thanks for your input!

Well, it works when I copy the Backup to the harddisk - irrespective into which directory I do this.
Probably for the same reasons, it works when first unzipping the backup to a directory on the harddisk.

So, its not the zip file, it's not the local directories on the haddisk, but it somehow seems to be connected to the usb stick (Pretec 32 GB) ? But then again, I can write/read files to/from this usb stick without any problems at all!

I am a little bit stumped since this used to work before...

von Charles U. Schneiter - am 26.04.2013 11:02

Re: [WD 17] SOLVED: Insufficient rights for Restore...

Hi folks,

Sorry for dragging up this slightly aged topic, but I thought that the solution - or better explanation - might spare somebody some time some day...

On afterthought, it is quite obvious:
Sometimes and without being fully aware, I tried to restore the project while it was opened :sneg:. Doing so resulted in the somewhat imho misleading error message.
When closed, restores work without flaw, being it from an usb stick or even via dropbox (btw. a very handy facility!).

That it worked when copying the files over the existing installation is clear: I always closed not only the project but also windev when doing this...

So problem solved - or rather explained. FWIW...

von Charles U. Schneiter - am 30.05.2013 08:12

Re: [WD 18] Again: Insufficient rights for Restore...

Hi Folks,

After having found the solution to this problem in WD 17, I do again have the error about insufficient rights, this time in WD 18, as per this screenshot:
[attachment 592 Restore_InsufficientRights.png]

- The project is closed (that fixed it with WD 17) ...
- The zip-file to restore sits in my DropBox Folder on C:\...
- The erros shows its ugly head on both Win 7 Pro workstations...
- I have Admin-Rights on both of these WS's...
- It works, when unzipping the very same zip-file with any brand zipping utility (e.g. 7 Zip) to the projects directory
outside of WD 18 ...
- It doesn't work regardless of where I put the zip-file and try to restore from inside WD 18 ...

Since I have a way to restore the app, I am OK, but it sure would be nice not ahving to resort to footwork ...
Or am I missing something obvious?
I again tried all the fixes proposed by the kind souls above, but to no avail :-(

Thaks for your input!

von Charles U. Schneiter - am 04.08.2013 12:03
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.