Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
4
Erster Beitrag:
vor 5 Jahren, 2 Monaten
Letzter Beitrag:
vor 5 Jahren, 2 Monaten
Beteiligte Autoren:
kingdr, Fabrice Harari

Problem when upgrading webdev deployment server

Startbeitrag von Fabrice Harari am 26.04.2013 16:29

Hi everybody

I just ran into a problem when upgrading one of my web server to webdev 18 and I would like to give you the solution if you get the same one...

Context: windows server 2003, IIS, webdev 15 server installed, HFCS 15 installed
Target: update HFCS to 18, webdev server to 18 (both webdev server are FULL versions, not 10 connexions)

1rst problem: I was unable to upgrade HFCS15 to 18, the process would block each time saying that it couldn't stop correctly the Hyperfile service
In the service utility, the Hyperfile and manta service were correctly stopped, which means that the error message was incorrect (probably the same problem than later)...
I worked around that one by:
- doing a backup of all DB in the HFCS15 control center
- uninstall HFCS15
- install HFCS18
- restore all DB into HFCS18
- restart the server... HFCS is working!!!

2nd problem: I was unable to upgrade webdev 15 to 18!!!
First you need to know that you have to use the BIG $$$ installer from the time you bought it (you should have received a DVD or a downbload link) and NOT the upgrades available from pcsoft website (to be applied later)
I run the big installer without any problem, and installed on D:\webdev18... At that point I was in w18 35e PRE-version, so I needed to upgrade (fast) to 56...
When upgrading to 56, I got an error message saying that wdadmin18.exe could not be overwritten, either for a permission problem, or that it was used by another program...
I checked the permissions (full admin), and therefore tried to find out what program was HOLDING my exe... I will pass on all the methods that failed to achieve that goal and give you what worked:
- download Process EXPLORER from sysinternal
- run it
- do a CTRL F and type (in my case) D:\w then click on search... I was shown that my exe was hold by WMIPRVSE.exe... Several search on the web later, I did the following
- look on the left, lookon the right, stop breathing, KILL wmiprvse (right clic on it in process explorer to do so)
- very quick, before anybody arrives, run the upgrade to 56 (works like a charm)
- even quicker, restart the server
- check that everything is working
- start breathing again...

I certainly do not reccomend any of this, but if you are in that situation (and I still have no idea why), it may help

Best regards

Antworten:

Hi Fabrice

It must be wb18 bugs but all I know it's a beta version and it never works out in my life
for any wx beta version anyhow.

I believe that you're eligible to get latest wb17 (it's stable) app Server or ask pcSoft for such.

I guess they tested out well in Windows Server 2008/12 (64-bit/32-bit) while ignoring Windows 2003 server and I guess you're running it as 32-bit env.

Just for FYI and nothing much that I could help, sorry.


Cheers
King

von kingdr - am 27.04.2013 07:15
Hi King

thank you for your answer, but It makes me think that I was not clear in my first post...

I was not asking for a solution, as I solved the problem. I was giving the instructions on how to solve it if you had the same one...

Furthermore, the v18 is NOT in beta... The ENGLISH version is in what we call in france PRE-version, ie all translations are probably not completely finished. But the v18 provided is already 5 months old, and went through 3 differents upgrades, which makes it stable enough for me to install. Now of course that is not to say that it is bug free, just stable enough for my needs :-)

Finally, my main problem was coming from the OS (windows server 2003) blocking a file, not from webdev.

Best regards

von Fabrice Harari - am 27.04.2013 14:03
Hi Fabrice

If you're not using any WMI services, why not just shutting it down permanently by
stopping/disabling such to see if running good as I do have it running on Windows 2003 64-bit (primary domain) and 32-bit (2nd domain) but in hfcs17/wb17.

Just let pcSoft know to fix it and I will be waiting for wx19 upgrade instead of 18 as it looks buggy and same as Windows 8. By all means, it's way too much time to
upgrade such to any live server if there's no benefit at all but suffering from unknown and painful problems.

Cheers

King

von kingdr - am 28.04.2013 12:08
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.