Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
3
Erster Beitrag:
vor 4 Jahren, 11 Monaten
Letzter Beitrag:
vor 4 Jahren, 11 Monaten
Beteiligte Autoren:
Jeff Graham

SOLVED - JavaLoad error in deployed application

Startbeitrag von Jeff Graham am 13.05.2013 18:32

Greetings,

We are trying to install a WinDev application that uses JavaLoad and JavaExecute function. Java is installed and used by other applications. Our application is running on three other machines. However one this one we get an error in the JavaLoad. We tried updating Java and get a strange error when we then start WinDev saying MSVCR100.dll was not found. Reboot clears that error but the Java does not update and we still get the error

We get the following error with JavaLoad:
Quote

Error at line 5 of Initialization of WIN_Pvs_Scanner process.
JavaLoad function called.
Error initializing classpath of Java virtual machine.

----- Technical Information -----

Project : PvsData

WL call:
Process of 'Initialization of WIN_Pvs_Scanner' (WIN_Pvs_Scanner), line 5, thread 0
'JavaLoad' function, syntax 0

What happened?
Error initializing classpath of Java virtual machine.

Error code: 110002
Level: fatal error (EL_FATAL)

Dump of the error of 'wd170jav.dll' module (17.0.33.0).
Identifier of detailed information (.err): 110002
Debugging information:
Fonction (11,0)
Additional Information:
EIT_PILEWL :
Initialization of WIN_Pvs_Scanner (WIN_Pvs_Scanner), line 5
EIT_DATEHEURE : 13/05/2013 11:00:33

Help


Any suggestions would be appreciated!!!

SOLUTION

The network administrators had a block on Java updates such that any attempt to update to Jre 7 caused the dll error and a reboot removed the update. Like Deep Freeze does. Had to recompile all for Jre 6.

Thanks,

Antworten:

More Java related issues:
https://www.dropbox.com/s/vlbaizfeuqggm7k/JdbcOdbc_error.png

On the machine that now will get past JavaLoad and start of JavaExecuteFunction, I am getting the above error.

Our application works on several different machines and OS versions. However, one XP machine does not read data correctly. It connects but then gets the attached error. If the hfAccmealsCS data source is incorrect, it will get a connection error. However if correct, the data read gets an error on this machine only. This is using jre 6. I installed the jdk 6 but that did not help.

Are there any additional components needed to read data from HF ODBC?

Thanks,

von Jeff Graham - am 14.05.2013 18:23
Just for future information,
    Sequence of events:
  • My Java application was compiled for Jre7 and they only had Jre 6, so we installed Jre7. After install, the WinDev application would get an error saying MSVCR100.dll was not found and we had to reboot to clear the error.
  • The group policy for the machine had a script that checked for Jre7 and did an uninstall if found due to another Java application having problems with Jre7.
  • So I recompiled my Java for Jre6 and installed the changes. However, the JavaLoad would still get the same error. I tried multiple corrections per the WX help for JavaLoad. Such as adding the jvm.dll directory to the PATH environment variable and adding a JAVA_HOME variable. Still no success.
  • The network admin turned off the policy and the machine was rebooted. Suddenly, JavaLoad worked. We ran the application for lunch POS.
  • He turned the policy back on and we rebooted multiple times and JavaLoad still works.

I suspect that one of the corrections I made per the help required a reboot before it really had an effect, or once it failed something was cached. I don't care to back them out at this point to find out.

von Jeff Graham - am 15.05.2013 21:24
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.