Diese Seite mit anderen teilen ...

Informationen zum Thema:
WinDev Forum
Beiträge im Thema:
Erster Beitrag:
vor 5 Jahren, 1 Monat
Letzter Beitrag:
vor 5 Jahren, 1 Monat
Beteiligte Autoren:
Kingdr, Paulo Oliveira, Fabrice Harari, kingDR

fListFile not able to read mapped netDrive in WB17

Startbeitrag von kingDR am 24.06.2013 17:31

Hi All

Appreciated all if you could help resolve as captioned as
it's perfectly ok in wd17 while wb17 could only handle local drives (c:, d:, e:) but
not mapped perfectly OK with network drives (n:, p:, q:) or even supplying things like "\\netDomain\myDrive" or

Pls help.





I haven't tested, but the user running a webdev session is IUser (internet user) and by default, this users has rights on nothing but the the web site itself. So it's perfectly possible that you simply have a permission/rights problem

von Fabrice Harari - am 24.06.2013 18:10
Hi Fabrice

Thx for your info but I don't know how to set IUser permission right in such case and
appreciated if you could give me some direction.



von kingDR - am 24.06.2013 21:27
It depends on the web server used by you. IIS, APACHE, ...?

Check this page in the help:

von Paulo Oliveira - am 25.06.2013 10:56

IUser (or the prceise IUser in your case, depending on your settings, as stated by Paulo, is a regular windows user (or linux user, depending on your server). So settings permissions for it is like setting permissions for any user: you go on the directories you want to access as an administrator, go into the properties, and change the permissions for the user

Best regards

von Fabrice Harari - am 25.06.2013 12:23
Hi Paulo/Fabrice

I'm very closed to the authetication but I rec'd errors as below:

HTTP Error 401.2 - Unauthorized
You are not authorized to view this page due to invalid authentication headers.

when disabled anonymous by putting in a valid domain user and
set the netDir allowing that domain user read/write... still with no success.

Pls point out what's the last step to do.



von Kingdr - am 25.06.2013 12:43
Sorry, I beg your pardon, I managed with one domain user but I
couldn't figure out of how to set all domain users. Well, my short solution is to create
a common domain user instead but when I clicked the permission folder I could see
users/domain, how to select such is ...

Thanks for your kind effort indeed.


von Kingdr - am 25.06.2013 13:00

Resolved but would like to let anyone who might need such:

1. run iis mgr
2. select site (highlight wb app)
3. select/dblClick (icon) Authetication
4. select Anonymous Authentication >rightClick and select Disabled
(to force local admin/all domain users to login)
5 select/rightClick Basic Authentication >Edit > type in Default domain
(A popup login dialogue asking you to type in domainUsername/password
without typing myDomain\username, then password with chked login auto for
nxt use).

Thank you.

King :))

von Kingdr - am 25.06.2013 14:57
If you need to check the permissions of the domain users you have to uncheck the Anonymous Authentication and use the windows Authentication instead.

If you are using IIS 7 or above you have to install the windows Authentication option of the IIS, if you are using IIS 6 or below just uncheck the Anonymous Authentication option and check the Integrated Windows Authentication option.

To check if you are using Anonymous/Windows Authentication just use the task manager of your webserver and look for the user who is running the WD170SESSION.EXE program.
For Anonymous should be default user setup by you, for windows should be the user logged on in the client pc.

Windows Authentication only works if all the accesses to your site are made from pcs using domain accounts, if not you have to use everyone permissions and that's very dangerous.

von Paulo Oliveira - am 25.06.2013 16:42
Thanks Paulo and I'll check accordingly.

Besides, (just roll-out wb app), this wb app is only for intranet for sharing domain users
with netDrive accessible so security is not really a concern in this case.

Thanks again and such little chk/unchk things bothered me for a whole week.



von Kingdr - am 25.06.2013 17:39
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.