[WD17] Integrity Error

Startbeitrag von David Egan am 01.07.2013 07:55

Hi
I changed a link between 2 files, deleting one and its corresponding field which had previously been suggested by Windev. Recreated the analysis, synced files etc. Now whenever I try saving a record in the unchanged file I get an Integrity error. Initially it told me that the field in the other file didn't exist which is of course true but it shouldn't have any bearing on it.

I have tried repairing the analysis, deleting cpl folder, env & Rep files, still the same result. Deleted the link altogether but still the same result. In desperation I went back to a previous version of the analysis, before any links were defined on the file. When I tried generating & syncing again though I got an error that the field which I had previously deleted is not in the file! I ignored that but now when I try to save a record I still get an integrity error reported, no details attached though.

Obviously Windev has got itself in a total knot. I don't really want to restore from backup if I don't have to but I'm thinking today might just have to be written off. Before I do that though does anyone have any bright ideas?

Thanks

David

Antworten:

Hi, produce a printout of the current analysis first. Then, in the HyperFile Control Center do a double-click on the database and choose o Links - there you can inspect and edit the file-link information. You should be able to something ..

von GuenterP - am 01.07.2013 09:19
Guenter
You're a life saver! Worked like a charm.

Thanks heaps

David

von David Egan - am 01.07.2013 19:16
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.