Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
9
Erster Beitrag:
vor 5 Jahren
Letzter Beitrag:
vor 4 Jahren, 11 Monaten
Beteiligte Autoren:
kimor, Al, GuenterP, Steven Sitas, Jose Antonio Garrido

WD18 Crashing when generating executable

Startbeitrag von kimor am 08.07.2013 20:14

Hi All,

Recently my Windev project started to acting up when generating a Windows executable.
Somtetimes the first generate window appeared ok and sometimes (more often) Windev froze. I've tried both 32 and 64 bit and on another machine. I have cleaned the exe directory.
Now it freezes all the time. Anyone who knows how to fix this?


Regards
Kim

Antworten:

Quote
kimor
Hi All,

Recently my Windev project started to acting up when generating a Windows executable.
Somtetimes the first generate window appeared ok and sometimes (more often) Windev froze. I've tried both 32 and 64 bit and on another machine. I have cleaned the exe directory.
Now it freezes all the time. Anyone who knows how to fix this?


Regards
Kim


Hi Kim,

the IDE of WinDev 18 v56h is frequently freezing, sometimes it needed 30+ seconds on my PC to come back into life. After installing version 62j it behaves a lot better, yes it's still freezing but at rather long intervals and much shorter duration than before. Today's morning it simply crashed after loading a small project and told me something about a general protection error. It did not do it again for the whole day while loading / closing more than a dozen different projects. So, it may have been a short spike / outage of the power line - or not. Who knows?

von GuenterP - am 08.07.2013 21:08
Hi.

I did not had any freeze or crashing problem that I can remeber. Neither with version v56h nor 62j.

I'm using Windows7 64bit.


(edit: except if I create a new rad pattern)

Regards,
José Antonio.

von Jose Antonio Garrido - am 09.07.2013 08:45
Hi,
Is there anyone else but me that has/had this problem?
I've tried different suggestions from PCS with no success.
I even reinstalled...the same on another machine.

I'm using WD18 63C
And it's about freezing (not responding) when trying to make an Windows executable, nothing else...
Please don't tell me that you don't have this problem, that doesn't help but please try to make an executable
of an example or your own several times and see if it works or not.

Regards
Kim

von kimor - am 09.08.2013 19:13
Hello Kim

If it is happening on every project and on different computers then it must be something unique to you - perhaps a fault in the downloaded copy of Windev ? PCSoft can send you a DVD copy.

Is there anything in the Windows events - application logs to indicate what the problem might be ?
When you reinstall Windev, try deleting the PCSoft section in the registry, it will recreate what it needs during installation.

I suppose you have tried the usual tricks of deleting the CPL folder and the project .env files

If you step through all the exe creation process, at which point does it freeze ?

If you nominate one of the examples that causes you problems then the forum members can try to create an exe to see what happens.

I run V18.63c on XP Pro and on Win8 Pro computers without freezing on exe creation.

Regards
Al

von Al - am 10.08.2013 02:43
Hi Al,

Yes, I tried all that.
I'm quite sure there's nothing wrong with the downloaded file since there's no error during unpacking and they're seperately downloaded on both machines.

It is at the first stage it freezes. When the generation wizard window displays it should show text and so in in the grey window, which is blank.

Try WD Mail for example.

I just thought of trying 56h since I think the problem was introduced in 62J...Will install from DVD.

Regards,
Kim

von kimor - am 10.08.2013 07:18
Hi Kimor, what type of machine is it?
Windows? Which one? 32/64 bit? All updates there?
Prozessor?
Motherbard?
Are drivers for the motherboard loaded?
RAM? How much?
Hard disk? What's left in Gigabytes?
Is it a big project?
Did you look into the device manager of Windows?
Any drivers missing?

If you think everything's ok then I can offer you to compile the project on one of my machines?
Give me a download and I can check it.

von GuenterP - am 10.08.2013 10:55
Hello Kim

I tried the WDmail example and it compiled without any problems - sorry I know that doesn't help you find a solution.

Regards
Al

von Al - am 10.08.2013 13:09
Hello Kim,
1. If you have installed WD in c:\program files ..., you may have a UAC problem.
2. Sometimes my WD "freezes" because my dongle "goes crazy". Check to see if everything is OK with your dongle.

And last but VERY important - there are settings in the Registry for your WD installation.
Last year I installed a french beta version for WD17. Later I installed the US version and I couldn't make an exe - I found out that the registry had the FRENCH file directories names.
Something like programme instead of program.
So look at your registry settings.


Steven Sitas

von Steven Sitas - am 10.08.2013 20:39
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.