Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
7
Erster Beitrag:
vor 4 Jahren, 6 Monaten
Letzter Beitrag:
vor 4 Jahren, 6 Monaten
Beteiligte Autoren:
DarrenF, Arnaud Benhamdine, GuenterP, Al

[WD18] Simple project giving errors

Startbeitrag von DarrenF am 09.07.2013 22:56

Hi,

I've just installed WD18 and thought I'd get the ball rolling by converting a very simple project that works in WD16 and WD17, but not in WD18! :confused:

There are 2 window templates and 2 windows (1 window based on each template). Each window (including the templates) has a GUI error, but the errors only occur in WD18:

[attachment 565 GUIErrors.jpg]

When I hit GO in WD18 I get a blank (standard) "Fatal Programming Error" window with a bare minimum of detail and it doesn't report the errors above:

[attachment 564 WD18_NonError.jpg]

The strange thing is that this error window doesn't stay on screen - it disappears after a few seconds without any interaction from me! :confused:

Does anyone have any idea what's going on?

I don't want to convert my major project until I know what's going on! :(

Antworten:

Hi Darren,

- these GUI errors have nothing to do with your error window.
They just say that the / some controls on these two windows have no anchoring defined.

- however, the error window is strange, indeed.
There must be a hint to something in your code somewhere,
otherwise I couldn't explain. Have a look, can you see any red underlining somewhere?

von GuenterP - am 10.07.2013 03:11
Hello Darren

I had similar issues. The error was "The version number of the subscription information is not compatible with this version of Windev"
"The subscription information was reinitialized"
"(.src\lien.ccp249)"

This only occurred on V16 windows imported to V18 and only if I clicked on the control and moved it. It only occurred once and then went away.
Tech support were not able to reproduce it , which wasn't surprising. I imagine that there may be a fair bit of junk in the windows that accumulates from version to version and some of mine started life in V5.5. Also the compiler gets stricter in each version.

For you other problem, the only way might be to put in a series of "STOP" commands to try and isolate when it occurs. If you are really stuck, the project sounds small enough that you could zip it up and send the whole thing to tech support.

Regards
Al

von Al - am 10.07.2013 03:53
Thanks Guenter & Al as always... :spos:

The anchor problem - all the controls on the windows seem to be valid. If I give (say) a button to the right of the windows a "right" anchor, then the error go away, so not much to worry about as I know the fix.

As for the weird error window - yes, it looks like I'll report that one to PCS as the project is so very small. [[5]]

von DarrenF - am 10.07.2013 07:38
Try to rename the projects, it often fix such weird problems after a conversion from an older version of wd.

von Arnaud Benhamdine - am 12.07.2013 09:05
Thanks Arnaud, I'll give it a try :spos: ...but ultimately, what if I don't want to rename it? I don't really want to have to rename every project with a number on the end, like; Project2 or PerfrectProjectName3! :eek:

Well - I've sent the project off to PCS for them to take a look at [[5]]

von DarrenF - am 13.07.2013 09:30
I think there's a fundamental problem with my WD18 - just created a brand new project in WD18 from scratch - 1 new window and still get the same error window popping up!!! :( :sneg: :(

Don't know what to do or where to even look for what's causing the issue - I just hope PCS get back to me... :eek: ...or I'll be asking for a refund!

von DarrenF - am 13.07.2013 17:02
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.