Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
1
Erster Beitrag:
vor 4 Jahren, 11 Monaten
Beteiligte Autoren:
ccc2

[WD18] query object sqlite

Startbeitrag von ccc2 am 06.08.2013 14:52

Hi,

I wonder anyone encounter such strange problem .
I writing a simple convert program to convert data in HF to sqlite . while reading the data from HF , I also query the data in sqlite for emp_dept_key .
I create query object with simple sql
select
emp_dept_key
from
emp_dept
where
emp_dept_name = 'AAB'

whenI run the query from WD18 it return me result but when I run direct from the program with hexecutequery() , it return me no result.

there's no error and hnbrec() return 1 . I also verify that I not forget to put Hreadfirst() . but I still get nothing in the result .


after try and error , I give up . i not using hexecutequery() and query object but change to hexecutesqlquery() .
this time it return result .

this is my first time use of sqlite in WD also first program i write using WD18 , I not sure if this is normal or just another bugs in WD18 .

Antworten:

Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.