Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
3
Erster Beitrag:
vor 4 Jahren, 4 Monaten
Letzter Beitrag:
vor 4 Jahren, 4 Monaten
Beteiligte Autoren:
Stefan Bentvelsen, Fabrice Harari

[WD17] LIKE in query

Startbeitrag von Stefan Bentvelsen am 02.09.2013 12:56

Hi,

I have the following query that does not work in HyperFile/CS. No error, but there are also no records found.

SELECT *
FROM TblOrderRegel
WHERE TblFactuurCD LIKE '!%'

When I change the LIKE '!%' in the value LIKE '!2%', it does find three records and that is correct. Can someone explain why it doesn't work without the extra '2' ?
I just want to retrieve the records where TblFactuurCD starts with an exclemation mark.

In the helpfile I cannot find anything about an exclamation mark (!) and reserved characters. There are only underscore (_) and procent (%) mentioned.

Antworten:

Hi

Not sure it's the problem, but you should check in your analysis to see if that key takes all punctuation characters into account or not (you have the option for accented characters, and another one for punctuation)... If not, you cannot search for "!" on it

Best regards

von Fabrice Harari - am 02.09.2013 14:08
Hi Fabrice,

I think you hit the nail on his head!
Thank you for your response.

von Stefan Bentvelsen - am 02.09.2013 14:14
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.