WM18 Looper

Startbeitrag von Paul Turner am 17.10.2013 08:48

Hi all

Today I tried the tutorial database app in WM18 and notice that in the deployed app the looper control does not redisplay properly after modifying or adding a new record to the underlying table. Instead it shows a duplicate record after adding, or no changes to the modified record if modifying. Yet if I exit the page (go back to the menu) and then back into the page with the looper it displays correctly.

It does this on both Jellybean and ICS devices. However in the emulator it works as it should.

Has anyone else noticed this? If not, any ideas on what could be causing the problem?

I'm using 64bit JDK 1.7.045 and x86_64_20130917 ADK.

Thx
Paul

Antworten:

Hi Paul

I haven't looked at that example, so all the following is just a supposition. However, one of the things that make a big difference in android is that there is NO MODAL WINDOW. Which means that when you exit a window, NOTHING happens in the "mother" window if you don't explicitely code for it in the closing of the CHILD...

I'm guessing that something is incorrect in that part of the coding

Best regards

von Fabrice Harari - am 17.10.2013 13:38
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.