Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
10
Erster Beitrag:
vor 4 Jahren, 8 Monaten
Letzter Beitrag:
vor 4 Jahren, 7 Monaten
Beteiligte Autoren:
Steven Sitas, David Egan, Vassilis Boutsikas, GuenterP

Handle in an invalid state (1609)

Startbeitrag von David Egan am 22.11.2013 06:58

Hi
Whilst I have had this error every now and again in the past I have been able to get past it by either re-starting Windev or rebooting the computer a few times. Today though nothing has worked; within a couple of minutes of going into Windev the dreaded message appears & kicks me out. It was working fine yesterday, no updates that I'm aware of today.

I've uninstalled the dongle & drivers & allowed it to reinstall which I thought had solved the problem but instead of it crashing within 5 minutes it merely delayed it to about 45 minutes. Anyone have any ideas? I've lost a full day on this so far which I really can't afford at the moment. I'm using WD17 on 32bit Win7 machine.

Thanks

David

Antworten:

Hi David,
the OS + drivers or even the hardware may be the culprit. I had no problems on any of my desktop computers but just a single 17"-laptop with Windows Vista showed unexplainable crashes of WinDev 17 plus some bad behaviour when using WinDev 17. After formatting the hard disk and installing Windows 7 all of the problems disappeared. Info: there are some Wx-cracks available somewhere on the web. PC Soft fights them with constantly changing weapons. Mostly, they let Wx-products crash with various errors when detecting a dongleless program running. Therefore: if WinDev cannot access the dongle properly or in time (USB-port / USB-driver / dongle driver / Registry?) then it may crash. First advice: put the dongle to a physically different hardware port. Second advice: save everything, wipe the disk and re-install the/a new operating system .. takes at least three days of work on each of my desktops. Third advice: buy yourself a new computer. This may be cheaper than investigating the possible causes of the crashes.

von GuenterP - am 22.11.2013 08:04
Thanks Guenter
Tried different port without luck. Impractical to wipe, reinstall etc so looks like my backup machine has become my development machine for the time being; so far so good on it!

Cheers

David

von David Egan - am 23.11.2013 05:43
Hi David,
I am also getting this on my development machine.
Started happening this week ....

Using Windev 17 and Windows 7/32 bit

von Steven Sitas - am 23.11.2013 11:30
I just saw that there is a version 17 - 78np - that handles these problems.
My WD17 version is 78p - BUT the faqs date is 28.1.2012 - a lot older than my 78p version.
So is 78np an update to 78p ?

http://faq.windev.com/4408-handle_invalid_state_dongle_upgrade_safenet_usb-read.awp

von Steven Sitas - am 23.11.2013 11:38
Hi Steven
Wish I'd been aware of that before, I would have tried it but I never even thought of trying the PC Soft FAQs. I have mine set to automatically check for updates so I would have thought if it was an update to 78p that it should have happened automatically though (or at least we would have been notified that there was an update).

Mine only turned bad this week like yours so maybe there's been some sort of an update to the 32bit driver that we're not aware of. My backup machine is 64bit; it's all working perfectly there so I'm going to leave it alone & try & makeup my lost time!

David

von David Egan - am 23.11.2013 23:57
I had the same problem on my laptop with window 7, and after installation of the upgrade from: http://faq.windev.com/4408-handle_invalid_state_dongle_upgrade_safenet_usb-read.awp, the problem is gone.

Vassilis

von Vassilis Boutsikas - am 25.11.2013 05:54
Hi Vassilis,
did you install ABOVE version 78p (WD 17) ?

Steven Sitas

von Steven Sitas - am 25.11.2013 14:17
Hi Steven,
Yes I installed this upgrade over the allready installed WD 17p. When the installation is in progress, the known screen of the PCSoft upgrade products is appeared. After that, when WinDev is started, the version is xxxx78p# (obviously p+).

Regards
Vassilis

von Vassilis Boutsikas - am 26.11.2013 05:50
Thank you very much

Steven Sitas

von Steven Sitas - am 26.11.2013 11:56
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.