Diese Seite mit anderen teilen ...

Informationen zum Thema:
WinDev Forum
Beiträge im Thema:
Erster Beitrag:
vor 4 Jahren, 3 Monaten
Letzter Beitrag:
vor 4 Jahren, 3 Monaten
Beteiligte Autoren:
Jim Carson, Piet van Zanten

WB18 Closing a browser vs LogOut?

Startbeitrag von Jim Carson am 04.12.2013 13:17

Is there a way to LogOut and close a session in WB? I am finding that when I log on to my WB site, all goes well. However, if I just close the browser and then try to go back to the site within the 10 minute Idle time setting, I get an error 38 saying that my session is still active.

Is there a way to have a "LogOff" button that will end the session immediately.


Hi Jim,

Create a static page to redirect to (e.g. PAGE_Logout) and have code like this in a logoff button:
HCloseConnection(My_Connection) //if you use a connection

(Endprogram will close the session)
On the static logout page you can have a link to log in again if you want to by specifying the link action to display the first dynamic page of the project.


von Piet van Zanten - am 04.12.2013 16:45
Thanks Piet

von Jim Carson - am 04.12.2013 16:59
Tried Piet's solution.

I am still getting:

Connection denied (You are already connected to this site)
38 ERR_AlreadyConnected

Well. It does work. I think that the server sometimes just takes a while to disconnect. Not the full 10 minute Idle setting anymore. I guess I was just rushing it.

Well.... It doesn't really work. The IP stays active ;( Maybe a PCS server issue?

von Jim Carson - am 05.12.2013 22:09
Hi Jim,

Strange when I use the logout button as described in my previous post, the connection instantly disappears from the list.
I checked my sites in the WB admin and the setting for max number of connections for a user, is : A single connection automatically recycled.
However, I need to investigate what happens if several users from the same IP connnect to the site.
Starting two session from the same browser are possible, but when switching from one to another both sessions are lost.

Will get back on this.


von Piet van Zanten - am 06.12.2013 08:46
I figured out the problem.

Instead of displaying a static "Thanks for visiting" page, I had it directed to the static "Index" page which then displays the User Groupware Login. At which time it starts a new session. Duh.

Thanks again Piet

von Jim Carson - am 06.12.2013 22:16
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.