Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
12
Erster Beitrag:
vor 3 Jahren, 8 Monaten
Letzter Beitrag:
vor 3 Jahren, 3 Monaten
Beteiligte Autoren:
DarrenF, Terry Mullican, Fabrice Harari, Steven Sitas

[WD18] UI errors on reports...

Startbeitrag von DarrenF am 06.03.2014 19:15

Hi guys,

I've just noticed that I have 86 "GUI errors", although they are on reports. I've tracked down that the errors seem to relate to the Background image of 86 of the column headers on some of my reports. I don't think it's causing any problems, but you never know, and I'd rather I didn't have them hanging around...

It's basically saying it can't find; "F:\WX\Gabarit\WD\110 ActivVISTA\Report_ActivVista.jpg"

I have no idea why it's using the "F:" drive; this is a recovery partition on my HDD that I have no recollection of ever using, especially for any of my WD projects :confused:

Does anyone know how I can change or fix these errors as a batch, i.e. without having to go into each element and changing where it's pointing to?

Thanks...

Antworten:

Hi Darren

if your report tables are using a style, then correcting the style and recompiling will do the trick...

Otherwise, you'll have to do the correction everywhere

Best regards

von Fabrice Harari - am 06.03.2014 19:20
Hi Darren,
did you do a RESTORE (from a backup) of this WD project ?
If so I can help you with this ....

There is a nasty bug when doing a RESTORE and it shows these kind of problems.

The trick is to close your WD IMMEDIATELY after you import a WD project.
You must close WD, NOT only your restored project.

Steven Sitas

von Steven Sitas - am 06.03.2014 20:02
Hi Steven,

No I haven't restored.

von DarrenF - am 06.03.2014 20:25
Hi Fabrice,

Thanks for your reply...

Yes, they're using the ActivVista style, but you've lost me (not difficult I assure you ;-) ), but forgive me, how can a Style be "corrected"? I've never needed to correct a Style up until now, is there a menu option somewhere to manage them or a particular technique?

von DarrenF - am 06.03.2014 20:25
Hi Daren

you correct a style the same way you modify a style: go to a control using it, go to select a style, click on modify button, change what you want (in this case, the path pointing to the icon of the table)

Best regards

von Fabrice Harari - am 06.03.2014 20:56
Fabrice,

Yes, I thought about that, but double clicking on the "Static" control of a column header of a report doesn't bring up the same windows as it does for (say) an entry field or of a button a window - or maybe I'm missing something?

If I double click on a column heading on a report, it's a simple 3 tab properties box. If I select the "Style" tab, then "Background" from the "Element:" drop-down, and clicking the 3 "..."'s button it brings up a standard Windows file selector dialog which does default to the correct "Report_ActivVista.jpg" graphic which I can then click Open, but only the column on the report I selected changes. Compiling the project has no effect on anything else, i.e. it does correct the style.

I tried going to (say) a window, selecting a "Static" control and getting into the Style Sheet editor that way, but "Background" is an available option in the Element drop-down on this properties window :confused:

von DarrenF - am 07.03.2014 00:28
Hmmm, I think I might have opened a "can of worms" here... as I've also found other column headers where the Style Background points to a previous WD16 project folder. Wonder why these aren't being updated?

von DarrenF - am 07.03.2014 08:24
Hi guys,

I had to fix the errors manually, BUT when I create a new report, WD continues to try and use the invalid "F:\..." path, thus perpetuating my problem!

Does anyone know where I might find where this "bogus" path resides? I'm thinking "registry"? ...but if so, where?

Thanks in advance...

von DarrenF - am 20.03.2014 19:57
I am getting the exact same issue after upgrading a project to v19. Any fixes for this?

I have re-applied the Styles, repaired the project...

Error:The file was not found on the disk (used 4 times).
RPT_List_AssetCategories, , line 1, column 1

This path is not editable from anywhere I can find.

von Terry Mullican - am 06.08.2014 16:27
Hi Terry,

Looks like it might not be precisely the same problem.

Here's how I found the offending path/file references:

1) In the IDE, with the GUI Errors listed, double click the error and WD will open the offending report (or whatever it is) with the control(s) highlighted for you.
2) Right-click a highlighted control and click "Description..."
3) Click the "Style" tab on the left.
4) Click the "Element" field, and in my case I needed to select "Background" from the list.
5) In the "Background Image" field I could see the dodgy filename; "F:\WX\Gabarit\WD\110 ActivVISTA\Report_ActivVista.jpg"
6) I would then click the "..." button to the right of the filename to search for the correct jpg.
7) Select the correct file from the file picker and click the "tick" button on the "Description..." dialog box.

I couldn't fix them all because some of the errors (probably these are the same as yours) didn't have a path I could correct. These were controls such as check-boxes on windows for example.

I still had 1 or 2 of the "F:\..." errors... not sure why :confused: ...I'm putting it down to the way I upgrade (...or used to upgrade) my projects - Fabrice enlightened me on a method of upgrading via this post; http://27130.foren.mysnip.de/read.php?27131,218616,218632#msg-218632

I'm still monitoring the situation...

von DarrenF - am 06.08.2014 18:47
Darren,

That fixed it! Thanks for the follow up!

von Terry Mullican - am 07.08.2014 18:28
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.