Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
6
Erster Beitrag:
vor 8 Jahren, 7 Monaten
Letzter Beitrag:
vor 8 Jahren, 7 Monaten
Beteiligte Autoren:
Jeff Graham, Al, Andres Sanchez

Window Locked with Error

Startbeitrag von Jeff Graham am 11.05.2009 20:51

Hi Everyone,

I got a project from a new developer. An internal window he was working on is now unable to open and get error in initialization part 0. Every time you open the project or try to run a project test it says it has to recompile the internal window. It does so but you can't open or access the window in code or with ChageSourceWindow.

Even after a reboot, you can't rename the file or delete it as it says it is open by another application. I tried a project repair. He has a lot of changes and no recent backup.

You can't use file -> versions for the window because you can't open it. At least I can't find a way.

There are .tkw and .bkw entries in the backup directory. Is there a way to manually restore from those entries?

Cheers,
Jeff

Antworten:

Hello Jeff

Deleting the cpl directory will often fix compiler problems.
Also check there isn't a copy of the file in the project groupware directory

To open a backup file and save a backup file into the current project there are two ways.
If you want to replace an existing window, copy that windows .wdw file somewhere and delete it from the current project and project directory , then drag the bkw or tkw file onto the main windev project window and save it into the project directory as filename+"wdw"
If you just want to open a backup file and copy and paste from it, just drag it onto the main windev project window, it will open as filename +"1"

Regards
Al

von Al - am 11.05.2009 21:48
Hi Al,

Thanks for the suggestions.

I deleted the cpl directory - no luck.
There are no files in project groupware directory.

I tried all ways to recover the backup but I get the same error:

Error loading D:\WX-LDI\window finale\IW_Main_Employees.bkw window.

Unable to complete initialization:
Error reading part (0)

I have tried to rename the .bkw as well and it says the file is open in another application even after reboot. This may be some Vista problem. I have changed permissions on the project folder to allow full control, etc. Still can't rename many files including the Backup directory.

I managed to reboot and rename the backup directory and restore the .wdw file and still it cannot be renamed or moved or used by WinDev. It says it is opened in another application. Wierd.

I give up for now. He will just have to recreate the window changes.

Thanks again,
Jeff

von Jeff Graham - am 12.05.2009 00:30
Hello Jeff

One last try :)
http://ccollomb.free.fr/unlocker/

It may unlock the files

Regards
Al

von Al - am 12.05.2009 00:49
Hi Al,

That is a great tool. Thanks for the link. I was able to unlock the files and rename, etc. However, the data inside is corrupt apparently.

Cheers,
Jeff


von Jeff Graham - am 12.05.2009 14:57
Jeff:

If the developer machine is Vista, you can probably right-click the file and check if it has older versions, Vista do backup of files automatically.

Last resort?

Andres Sanchez

von Andres Sanchez - am 12.05.2009 16:15
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.