Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
8
Erster Beitrag:
vor 3 Jahren, 12 Monaten
Letzter Beitrag:
vor 3 Jahren, 12 Monaten
Beteiligte Autoren:
Stefan Bentvelsen, Allard, Fabrice Harari

[WD19] Groupware blocks reports

Startbeitrag von Stefan Bentvelsen am 23.07.2014 08:14

Hi,

I have converted a project from WD17 to WD19 and have worked with it some time without problems. But now I've a report that cannot be executed. No error, nothing, but also no report in preview (and no preview) while I'm sure there is data to be printed.

I suspect it is an issue of the user-groupware (WD19 version, converted from WD17-data), because when I start the report via the debugger, it runs a number of GPU-procedures and I can see that the report stops running at the end of the initialization-code.

Even as supervisor (groupware user) the report (and some other reports, but not all) is not executed.

Deleting the CPL-directory does not help, either project-repair does.
Restarting the whole WinDev environment does not help either.

I got this error message from a client (for another report):

WL call:
Process of 'Click BTN_PrintVleeskuikenhouders' (frm_PrintRittenplanning.BTN_PrintVleeskuikenhouders), line 10, thread 0
'iPrintReport' function, syntax 0
What happened?
You have no rights to access the 'RPT_PlanningVleeskuikenhouderij' element.
Contact an administrator of the application.
Error code: 1028
Level: fatal error (EL_FATAL)
Dump of the error of 'wd190vm.dll' module (19.0.176.4).
Identifier of detailed information (.err): 1028
Debugging information:
Fonction (21,0)
Additional Information:
EIT_CORRIGE_ETAT : RPT_PlanningVleeskuikenhouderij
EIT_PILEWL :
Click BTN_PrintVleeskuikenhouders (frm_PrintRittenplanning.BTN_PrintVleeskuikenhouders), line 10
Click BTN_Print (Frm_Rittenplanning.BTN_Print), line 41
EIT_DATEHEURE : 15/07/2014 15:39:32

Someone has a suggestion ?

Antworten:

Hi stefan

Is this report edited by reports and queries?

allard

von Allard - am 23.07.2014 09:34
Hi Allard,

no, the setting voor reports and queries in user-groupware is checked, so reports and queries cannot be changed by the module 'Reports and Queries'.

von Stefan Bentvelsen - am 23.07.2014 10:41
Hi stefan,

Ok.You could try out what happends if you give a report the ability to be edited. If an error occurs then you have the same error I had.

But before you do that . Did you add the groupware screens to your application? . are the screens appart of your application, so you can edit them ?

If so you can change that By using the automatic user groupware. the fault might just disappear.
For your sake I hope not that this is the case for then you cannot solve the problem, accept for using the automatic groupware


Regards

Allard

von Allard - am 23.07.2014 11:05
Hi Stefan

if you are using the STANDARD groupware, you are basically screwed, as you have no control on what is going on behind the scene.

However, if you are using the CUSTOM version, then I think I remember that not only the windows but also their code is accessible. This means that you can use the debugger to see exactly WHY the permissions for your report are not correctly managed.

It may be something as stupid as a too long report name with a too short field to contain it, or some exotic bug, but the debugger is your friend

Best regards

von Fabrice Harari - am 23.07.2014 12:07
Hi Fabrice

In essence I agree it should be debuggible. But that is not the case. I have no faults what so ever in the groupware ( version 18) indeed I only use the screens in English. No faults but:

If I want to use reports and queries at runtime to change a report a bug appears. If I change the groupware to default "Automatic" then the bug is gone.

So I guess there is a difference in code in the automatic and the custom user groupware ( if you change nothing to the code ).

regards

Allard

von Allard - am 23.07.2014 12:27
Hi Allard, Fabrice,

the user groupware is set to custom. I have the groupware windows/classes in my project available. So I think I should be able to debug this.
I will give it a try.

von Stefan Bentvelsen - am 23.07.2014 12:37

Re: [WD19] Groupware blocks reports (SOLVED)

Hi,

I have debugged the problem and you know what's funny ?

It doesn't anything to do with the user groupware. At least not in this particular case.
It was a special report with one page without and one page with a data source before I saved-as it to a new report. But the new report only has the page without data source. But I forgot to change this data source to no data-source and because of no data there was no reason for printing the report.

Thanks anyone for the suggestions.

von Stefan Bentvelsen - am 23.07.2014 18:18
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.