Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
3
Erster Beitrag:
vor 3 Jahren, 8 Monaten
Letzter Beitrag:
vor 3 Jahren, 8 Monaten
Beteiligte Autoren:
Yogi Yang, Arie

Cannot edit data in Edit control which is in looper control in WM17

Startbeitrag von Yogi Yang am 13.10.2014 06:54

I have three controls in a Looper control.

Two controls are Statics and one is an Edit control.

By default there are no content in Edit control. I want to allow the user to enter content in the Edit control and then save in Database in WM17.

But when I load the page with Looper control and try to edit/add contents to the Edit control it behaves like read only and the input focus just does not go there.

Have I to set any other special properties to achieve this?

TIA

Yogi Yang

Antworten:

Yogi,

both the looper and the edit-control need to be "editable". Then it should work.
You should also use attributes in the looper and tie them to the controls.

So save the data you can do something like this

nRow is int
FOR nRow = 1 TO Looper1..Occurence
Info(Looper1[nRow].ATT_CustomerName)
END

I prefer the code above, because is more clear what is actually going on, but it can be simplified :
FOR EACH Looper1
Info(Looper1.ATT_CustomerName)
END

von Arie - am 13.10.2014 09:33

[Solved] Re: Cannot edit data in Edit control which is in looper control in WM17

Arie,

Thanks for the information. I tried in every way to solve this problem but could not solve it so wht I did was to delete the Looper and recreate it.

Now things are working as expected.

TIA

Yogi Yang

von Yogi Yang - am 16.10.2014 03:46
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.