Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
15
Erster Beitrag:
vor 3 Jahren, 3 Monaten
Letzter Beitrag:
vor 3 Jahren, 3 Monaten
Beteiligte Autoren:
John Marrone Jr, JP, Al, Fabrice Harari, DarrenF

[WD18] New - Chkbox in table disappears when runned from EXE

Startbeitrag von John Marrone Jr am 19.11.2014 16:00

Hi

Original Message

I have a checkbox in a table column. When I am in the development environment it is there. When I create the EXE and then run the EXE it is not visible. I can click where it should be and the record reflects that the checkbox is checked, you just can not see it. The column is there in the table, just no checkbox. I really, really need to solve this. Has anyone ever had this problem and if so would you please tell me how you fixed it. I have 3 other apps with a checkbox in a table column and they work just fine.

I really hope somebody can help me. I have been fighting this for 5 hours now. I have no clue what's causing this. Am I missing a DLL?? I really need help with this.

New info

I built my exe then ran it. It errored out when I clicked on a button that had a bad line of code. The error message box popup but was missing it's scrollbar and there was a big long RED "X" where the scrollbar should of been. WD could not find the scrollbar image I guess. The same I think is going on with my checkbox, I don't know. I have been fighting this for 2 days now.

I can not be the first person dealing with this. Can somebody please help.

Antworten:

Hi John,

The red X does indicate that the runtime version of your exe cannot find the image file. I suggest open the properties of the checkbox in the WD IDE and check the path setting for the image file. Perhaps change it and re-change it back as that should make WD ask if you want to move the image to the project directory.

Make sure the image file can be located by the exe. If the image file is not compiled into the EXE then where will the EXE find it during runtime and at a client computer? You need to solve this. One technique I have used to force the inclusion of an image file in a project is to create an image control off-screen on some window i.e. not within the window but outside of it. This means the image cannot be seen but it forces WD to include the image file in the compiled exe. I hope I explain it OK.

von JP - am 19.11.2014 16:11
Hi JP

I do not see an image file in my project folder or the exe folder. I looked in a couple of my other projects where I use checkboxes and could not find that I was using any checkbox images. Any other suggestions. I thank you so much for your help. I have been using WD since Version 7.5 and I have never ever run into a brick wall like this one. Two days of just trying to solve this. I hope somebody is able to figure this out. You would think I am not the first one??

Thanks again and I welcome any other ideals you may have.

von John Marrone Jr - am 19.11.2014 16:56
John,

You have much more experience with WD than me as I am newbie here so forgive my newbie input :) The checkbox can have a style associated with it. Does your checkbox use a specific style? If it does I would try removing any associated style and get it back to just a simple, plain checkbox and see if it appears then. If it does then you know its something to do with the style it was associated with.

I found strange behaviour like this with radio buttons when I decided to delete some image files in my project folder that I did not recognize and did not realize WD was using for some radio buttons. So check the style setting on the checkbox would be my starting point.

von JP - am 19.11.2014 17:22
Thanks JP, I have already checked the properties out. I am not using any images at all. I have used checkboxes in all of the projects I have done over the years and have never run into this. The error box WD popup missing the scrollbar has got to be the red flag but what?? Thank you again so much for your suggestions.

von John Marrone Jr - am 19.11.2014 18:00
John, can you post a screenshot to help us see the problem?

von JP - am 19.11.2014 18:03
Hi JP

Here are the images.

From Exe runtime enviroment
[attachment 1248 chkbxatruntime.png]


From WD enviroment
[attachment 1249 chkbxinwdenv.png]

Hope this helps.

von John Marrone Jr - am 19.11.2014 18:20
John,

When I have come across problems like this (not exactly this one) I tried to find out what was different from another table where I had a similar set of controls. I then compared every single setting under the description of the "working" table with the "not working" table and invariably I found a setting which was different and causing the problem. That is where I would start - this assumes you have another table which has a checkbox column and which is working so you can compare.

Second, did this used to work? If so, do you have a backup where you can either (a) restore the working window copy, or (b) rename the previously working window and do the compare between that and the current one as described above.

Third, your tables seem to have some sort of styling applied to them, at least it seems so to me from the screenshot. I believe those styles might be having an effect where the image for the checkbox is accessible from the development environment but not from the runtime environment. I would carefully re-check all style settings for the table and this specific column to see if any setting might be causing a problem.

Also have a look at the image attached. It shows a table I have with a checkbox column. Look at the areas I have highlighted in red boxes. These affect the style of the checkbox. Does anything there help solve the riddle?
[attachment 1250 Untitled.png]

von JP - am 19.11.2014 19:02
Hi JP

Again I want to thank you for your time and effort.

1. I have compared my settings for this table column with settings from other projects where I have used a checkbox in a table column. They were all exactly the same.

2. It never worked. This was a small 3 day project so I didn't even bother to do a build until I was piratically done.

3.I have compared the table settings also. They are the same to other tables I have created that have a checkbox column.

4. I have even tried different type of checkboxes, done work.

You have really devoted some of your time with this. I am really grateful. I have been using WD for 10 years and have been programming for over 25 years and have not ever had a brick wall to over come like this wall. This is a WD bug I guarantee you. I was just hoping someone else has had to deal with this and could tell me what and if they were able to do to correct it.

I have a work around that I have thought up, but I should not have to do a work around.

Again thanks for your help JP.

von John Marrone Jr - am 19.11.2014 19:39
Hi John

something is striking me as strange...

In several post, people (me included) have talkd to you about the STYLE of your checkbox, and you have answered back talking about IMAGES...

Now, that may be a language problem, or that may be the cause of your problem, as those two things are completely different.

So, just to be sure :
- in the project description, make sure that GUI error are managed by the compiler. If they were not and you enable them, you may have your answer immediately
- then, go into the table, select your checkbox COLUMN, then go into the STYLE TAB. There you should see all the elements of style applied to your checkboxes. The problem is probably there with an image referenced outside the folder of your project.

Best regards

von Fabrice Harari - am 19.11.2014 20:49
Hi Fabrice

I wrote earlier that when I built my exe then ran it. It errored out when I clicked on a button that had a bad line of code. The error message box popup but was missing it's scrollbar and there was a big long RED "X" where the scrollbar should of been. WD could not find it's own scrollbar image I guess. The same I think is going on with my checkbox,

In any checkbox I have never used an image. Under the style properties there is only one place you can use an image in a checkbox column and that is for the column header. But in any case if WD Error massagebox can not find it's own scrollbar image then I was thinking I am having a problem with WD and how my project was setup or something. But I rechecked my project info and there is nothing wrong. In any case I give up. I can do a work around here but I am worried that in all future projects I am not going to be able to use checkboxes in table columns. I am thinking about re installingWD as a last resort.

Thanks for your time and effort in any case Fabrice.

von John Marrone Jr - am 20.11.2014 00:15
Hi John,

Sorry we could not solve the problem.

It just seems to me that if you have another project with a table with a checkbox column and that table works OK but this one does not then it cannot be a fault in WD but rather some setting either in the faulty Window+Table+Checkbox column or the faulty project itself. I believe somewhere, either at checkbox, table, window, or project level, a style setting is being used which can be found at design time but cannot be found at runtime. This is my suspicion. Have you checked the project level style settings?

von JP - am 20.11.2014 09:33
I would tend to agree; where it works in 1 project and not another does point towards a style issue. It may be that when something is within a control, it can't show the red cross of "style not found"?

I know it's not precisely the same issue, but I thought I'd mention it just in case it helps... I had an issue with styles on reports and on some windows and it turned out it was the way I'd transferred the project from 1 version of WD to another.
http://27130.foren.mysnip.de/read.php?27131,198300,306514#msg-306514

Also, do you have your GUI errors turned on or off? I had mine turned off so never noticed the problems for a few weeks.

In my case, there are still instances that I simply can't sort out because I can't access the required properties field (or it doesn't exist) I don't know.

von DarrenF - am 20.11.2014 10:06
Hello John

To take a leaf out of the tech support handbook, if you can put the table in window and put it into dropbox folder we can download it and see how it goes in our environments and that may turn up an answer for you

Regards
Al

von Al - am 20.11.2014 13:21
Hi

This might help solve the problem. I never use a theme style on my windows. I always select None for my window theme. What I did was I changed the Window Theme to the Zune theme in the window properties. Then I clicked the run button. Inside the WD environment it looks great. I then built an EXE and ran it. The window had nothing but RED X's everywhere.

My project can not see any themes styles images at all, period. Does anybody know what would cause this. I think the answer to this would solve my problem for sure. It has to be a setting in the project description I would think. Can someone help.

Hi Al

I will get back to you if this new fact I just came across doesn't led to a solution. Thanks Al.

von John Marrone Jr - am 20.11.2014 14:31
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.