Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
8
Erster Beitrag:
vor 7 Jahren, 11 Monaten
Letzter Beitrag:
vor 7 Jahren, 11 Monaten
Beteiligte Autoren:
Fabrice Harari, John Marrone, Jimbo, christoph

Wlangauge security error

Startbeitrag von John Marrone am 26.03.2010 11:52

Hi

On a vista and windows 7 and an XP machine I am trying to unzip a zip file. Both of these machines are 64 bit and the XP machine is 32 bit. You can run 32 bit apps on 64 bit machines which I know you people already know but just trying to give all the details I can.When I make a call to unzip a file I get an WD error as follows.

"Unexpected problem detected by WLanguage security mechanism"

That's it, and I have been trying to get around this for a while. Has anybody ever got this error message from WD and what did you do to fix it.

I would use WD zip function but zipExtractFile returns a 3 which is that the file is corrupted. But I have been dealing with these zip file for years and any other unzip tool I use can unzip them but I need to unzip them with through source code.

Heck I can't even get the dll to register with source code. I have tried these 2 ways that I got from 2 fellow members but they don't work.


WHEN EXCEPTION IN
errString = uzZip>>filename
DO
retCode = API(fExeDir() + "\ChilkatZip2.dll","DllRegisterServer")
IF retCode 0 THEN
retCode = DDEStart(fExeDir() + "\Regsvr32.exe " + fExeDir() + "\ChilkatZip2.dll -s")
IF retCode 0 THEN
retCode = CallDLL32(fExeDir() + "\ChilkatZip2.dll","DllRegisterServer")
IF retCode 0 THEN
Info("The zip control ChilkatZip2.dll did not register. " + Charact(13) + Charact(13) + "You will have to unzip the data zip files manually until this problem is resolved.")
END
END
END
END



This does not work on Vista and Windows 7. On the XP machine I get the error from my program that the "http request failed".

And when I just open a regular cvs text file and I parse it and put the data into HF databases and when the process has finished WD errors out with the same message and I have imported thousands of these files with this code. But the data was there and saved.

What in the world would the WLanguage have to worry about a security issue but most important how can I turn this off or fix it. I really need help with this one. I am hopping some one else has had to deal with this and found an answer or a work around.

Something is telling me it has something to do with permissions maybe but why would WD throw the error and the logged on user is the administrator. Or maybe something to do with opening or closing files?

I would be really really grateful for any help or suggestions. This could be a show stopper and I have put around 4 years of my spare time working on this upgrade for my users. Please help if you can.

I think if I could just get WD's zip to unzip the file all my problems would be over.

Thanks in advance

Antworten:

Hello John,

for register *.dll in Vista (and Windows7 ??) you must deactivate in Windows "Benutzerkontenverwaltung" . Sorry - I dont found this word in the dictonary.

Christoph

von christoph - am 26.03.2010 12:43
Hi John

I'm confused...

If I understand correctly, you are talking about the wlanguage unzip function, but you are showing us a call to an external dll and I can't see the relationship between the two...

Do you have two different problems? If it's the case, I would advise that you create two separate thread and publish the faulty code for each...

best regards



von Fabrice Harari - am 26.03.2010 12:44
Fabrice

I have one problem. I am trying to register a third party unzip dll activeX control. I was just explaining the reason I was using a third party unzip dll was because I could never get WD to unzip a file or I would just use WD zip functionality. I need to get this unzip dll to register in windows. And now when I import a cvs file and when my routine is done WD will throw an error with the error message being

"Unexpected problem detected by WLanguage security mechanism"

I need to get this control to register. When I manually register this control and then call it in by app it then crashes with the above error also.

And now after trying to register this dll when I open a csv text file to parse and import the data to HF databases and the import finishes the program crashes with the above error message. This import problem only started happening after I started trying to get this dll to register.

Hope this helps.

von John Marrone - am 26.03.2010 13:34
Hi John

is this dll compatible with vista and seven 64 bits?

Best regards



von Fabrice Harari - am 26.03.2010 13:44
Hi again

and maybe you should revisit why you couldn't get the unzip functions to work... I've used them here and there without any major problem...

Are we talking about an exotic zip format here?

best regards


von Fabrice Harari - am 26.03.2010 13:46
Fabrice

The publisher of the dll, ChilKatSoft.com says it is windows 7 compatible.

The zip files are nothing special, they don't even contain passwords. Ever other zip tool can unzip them. I was using Inner Media unzip dll but he retired some years ago and I guess it is 16 bit or something but it won't work on Windows 7, it worked on vista though.

Is there anyway I can send you the zip file and see if you can get WD zip functions to unzip it? I don't think I did anything wrong, but maybe it is me?

von John Marrone - am 26.03.2010 13:54

The word, imho is 'User Account Control'
Regards, Guenter

von Jimbo - am 31.03.2010 19:51
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.