https on login screen

Startbeitrag von issah am 23.01.2015 09:09

Hello,

how do you get the login page and any other page to move to https mode in WB17?

regards

issah

Antworten:

Hi Issah,

Here is an example, in French, but I'm sure you know how to convert it in English.

To put at the top of the page declaration section:


SI PAS ValeurEnvironnement("HTTPS", "off") ~= "on" _ET_ PAS EnModeTest() ALORS
gsURL est une chaîne = PageAdresse(MoiMême,paSECURISEE)
ScriptAffiche(gsURL)
FinProgramme()
FIN


And the procedure ValeurEnvironnement() is as follow:


PROCEDURE PRIVÉE ValeurEnvironnement(LOCAL sNomValeur est une chaîne, LOCAL sValeurDéfaut est une chaîne = "")

sValeur est une chaîne = SysEnvironnement(sNomValeur)
SI sValeur "" ALORS
RENVOYER sValeur[[Position(sValeur, "=") + 1 A]]
SINON
RENVOYER sValeurDéfaut
FIN


Best regards,
Alexandre Leclerc

von Alexandre Leclerc - am 23.01.2015 14:06
Thanks.

Do I have to do anything on the server?

regards

issah

von issah - am 25.01.2015 13:32
Hi issah,

Whel, this is all server code. But maybe I do not understand correctly. On the server you have to have a good SSL certificate and HTTPS configured properly with your website. i.e. if https is working properly, the above code will simply redirect the internet traffic from a non https page to it's https equivalent (using the same URL, the only difference being that one uses https as protocol).

I hope this answers your question.

Best regards,
Alexandre Leclerc

von Alexandre Leclerc - am 26.01.2015 13:29
Ok, thanks.

This means i have to start from IIS and configure the web server with a certificate.

My web skills are just not up to standard. WB makes the application development relatively easy but sometimes you realize you just don't understand the tech completely.


Thanks

regards

issah

von issah - am 26.01.2015 19:36
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.