Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
18
Erster Beitrag:
vor 3 Jahren
Letzter Beitrag:
vor 2 Jahren, 11 Monaten
Beteiligte Autoren:
Ola, JP, Al, Dave B, Fabrice Harari

[WD19 & Win8.1] Weird problems

Startbeitrag von Ola am 30.01.2015 11:06

I have some weird problems with WD19 in Win8.1. I suspect the problems come from the new Windows OS.

1) I have experienced this now maybe for a couple of months.
I've tried re-installing WD19, but it has no effect on this:
Whenever I close WD19, I always get two similar consecutive errors:

"WinDev19.exe (WinDev 19) - Win32 has stopped working
Windows can check online for a solution to the problem.
- Check online for a solution and close the program (this does not find any solution:-)
- Close the program
View problem details:

Problem signature:
Problem Event Name: APPCRASH
Application Name: WinDev19.exe
Application Version: 19.0.150.8
Application Timestamp: 53a9acb5
Fault Module Name: WPOBJ.dll
Fault Module Version: 19.0.356.39
Fault Module Timestamp: 53a05bf4
Exception Code: c0000005
Exception Offset: 000eaab1
OS Version: 6.3.9600.2.0.0.768.101
Locale ID: 1035

(Additional information may change, for instance:)
Additional Information 1: 5861
Additional Information 2: 5861822e1919d7c014bbb064c64908b2
Additional Information 3: 84a0
Additional Information 4: 84a09ea102a12ee665c500221db8c9d6
----
Additional Information 1: 8072
Additional Information 2: 8072f92983404638b5672432a5ce24e6
Additional Information 3: 0dfc
Additional Information 4: 0dfc0ab0edfbe77b4985acf8918fe444
----
Additional Information 1: 8072
Additional Information 2: 8072f92983404638b5672432a5ce24e6
Additional Information 3: 7e90
Additional Information 4: 7e901b446d618e050b0ce1cc1b702076

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=280262

If the online privacy statement is not available, please read our privacy statement offline:
C:\WINDOWS\system32\en-US\erofflps.txt"

----------------------------------------------------

2) Lately also WD19 has started to be have weirdly when running an app in testmode: quite unbelievable things can happen, even though the code has not changed. Like forms cannot be updated; OK button calls some other window!
Compiled Exe programs fortunately run OK.
I've tried the normal tricks; re-start windows, delete the app.cpl directory, run the app repair process. No effect on this.

Any hints to fix these problems will be highly appreciated.

P.S. Oh how I miss my old XP machines... (I still have one as a combined file server/work station).

Best regards
Ola

Antworten:

Re: [WD19 & Win8.1] Weird problems

Hello Ola,

My main development machine is in the same configuration (windows 8.1) and I have ZERO problems with windev (or webdev, or mobile) in any version...

Therefore I doubt it is coming from the OS

On another hand, the kind of behavior you are describing CAN come from a very agressive anti-virus...

So what are you using on that front, and did you exclude the windev directories (and your project directories) from it's area of control ?

Best regards

von Fabrice Harari - am 30.01.2015 11:36

Re: [WD19 & Win8.1] Weird problems

Hi Fabrice,

Thanks for the hint.

I use Avira AntiVirus.

I first excluded the development directory from the real-time scan: no effect, same problem.
Then I turned the real-time scan off: noeffect, same problem.

I still suspect the Windows, especially its automatic updates, as these are known to have caused severe problems, not for all installations, but many.

Best regards
Ola

von Ola - am 30.01.2015 18:10

Re: [WD19 & Win8.1] Weird problems

Hi all,

Problem 2 fixed. It was actually my own code change, which brought together a weird situation only in testmode. Sorry for bad alarm on this.

Problem 1 still exists. Perhaps re-installation of windows and all software might help, but this approach would cause wasting a week re-installing and re-adjusting everything again...

Best regards
Ola

von Ola - am 31.01.2015 17:06

Re: [WD19 & Win8.1] Weird problems

Ola,

Re problem #1

Does this happen if you just open WD, load your project but do not run it, then exit WD ? Or does this only happen if you actually run your project in test mode and then try and exit WD?

If it happens only if you run in test mode and the debug report shows the Fault Module Name: WPOBJ.dll - then I suspect your app is doing something during the test that causes WD to have a problem in properly shutting down the test environment. I had such a problem when using a 3rd party OCX but once I got the OCX working properly then the problem of exiting WD cleanly disappeared.

von JP - am 31.01.2015 17:33

Re: [WD19 & Win8.1] Weird problems

Hi JP,

Thanks for the hint.

First I thought that I always get the error, when closing WD. I now did more testing and found that there are two cases, where my WD closes without errors:

1) If the sign in the "IDENTIFICATION" window (sign in to WD) is closed with the cancel button: no error.

2) IF there is nothing done and nothing opened in WD Workspace: no error
Anything more than that will cause the two similar errors when closing WD.

I do not use OCX nor any other third party components in my APP.
Also the APP does not seem to have any effect on this. I get the errors with WD sample apps as well as my own app.

Best regards
Ola

von Ola - am 31.01.2015 18:58

Re: [WD19 & Win8.1] Weird problems

Ola,

Is it possible to test on another machine with the same OS version to try and eliminate if it is machine specific? I am using Windows 8.1 Pro with WD19 and have no problem. I am sure this is a particular machine which has a compatibility issue in the environment vs. WD.

jp

von JP - am 01.02.2015 08:48

Re: [WD19 & Win8.1] Weird problems

JP,

Cannot currently do that test; I only have one 8.1 machine. Others are 7 and XP. I'll just have to live with this quirk. Its not the worst one I have with WD.

Thanks for suggestions.

Best regards
Ola

von Ola - am 01.02.2015 19:17

Re: [WD19 & Win8.1] Weird problems

Ola, last thing I would try is actually uninstall the anti-virus entirely.

my 2c.

von JP - am 02.02.2015 07:55

Re: [WD19 & Win8.1] Weird problems

Hi JP,

I did not uninstall anti-virus. But I did a full virus scan. Anti-Virus did not find anything, so the only virus is Microsoft:

I have to users set up in my WD computer. The first one is my original user account, which Microsoft hi-jacked in connection with one of its windows updates, probably it was the one "upgrading" win 8.0 to 8.1. This was a forced update. I did not "order" it. Microsoft changed my user name and password to those of my hotmail email account!!!! I did not like this, so I set up a second user to use the user name and password I specified.

The problem, the two errors when closing WD, exist in the second user account only.
I now tried also the first account, the one hi-jacked by Microsoft, and there Windev closes normally, without errors!!!

Can anybody explain this?

best regards
Ola

von Ola - am 03.02.2015 20:22

Re: [WD19 & Win8.1] Weird problems

Hello Ola

I can't explain it but I agree that it might be a Microsoft issue. We started getting the "program not working" error on our compiled exe's when our clients moved from XP to Win7 and I put it down to just some weird timing issue with Win7. I can't remember getting the error when quitting from the IDE

However, it still could be a combination of PCSoft and MS. From the beginning of V19 I would get the "stopped working" error occasionally when the debug was running in the IDE but it just kept going if you clicked on the message. Now of course my debugger is on strike, sometimes it works quickly and other times 4-5 second between the steps.

Regards
Al

von Al - am 03.02.2015 20:36

Re: [WD19 & Win8.1] Weird problems

Ola,

So basically the errors occur only under the second user account => This account was created after you had already installed WD under the credentials of the first user account and the second user account had not yet been created. Therefore it is most likely that the second user account does not have all the registry entries that WD requires and/or access to all the local files/folders that WD requires.

I would suggest a complete uninstall of WD, cleanup the registry and any left-over folders in Windows related folders of the original WD installation, and then reinstall WD under the desired user account.

JP

von JP - am 04.02.2015 05:44

Re: [WD19 & Win8.1] Weird problems

Hello Ola

If you are contemplating a re-install, a quick and dirty solution is to delete the PCSoft registry entry in HKey_Current_User\Software

When you start windev again it will write a new set of registry entries

Regards
Al

von Al - am 04.02.2015 06:10

Re: [WD19 & Win8.1] Weird problems

Hi JP & Al,

Thanks for the good hints. I will be busy in another activity for the next three weeks or so, so I'll re-attack this problem after that, and will then report the results.

I believe that Al's suggestion, cleaning the register, should do it, because traditionally Windev has been quite an independent installation without too much tieing down to the opsys, so it has been easy for instance to move an old installation to a new machine just by copying the installation directory. But we'll see.

Best regards
Ola

von Ola - am 04.02.2015 09:52

Re: [WD19 & Win8.1] Weird problems

Ola,

One last suggestion; login with the second account (the one with the problem) and start WD as Adminstrator i.e. with Admin rights. This might allow WD to create or set all the necessary registry entries etc. that it might be having a problem with.

jp

von JP - am 05.02.2015 07:45

Re: [WD19 & Win8.1] Weird problems

Hi again!

Back from holidays. Burned my skin.

Back at the lathe:

@JP
Started WD as administrator. No change. Exactly the same problems.

@Al
Deleted the PCSoft registry entry in HKey_Current_User\Software.
Some improvement: Now I only get one error message when closing the WD, instead of two!

Additional info: Now I have noted that I get two similar, consecutive error messages also from Pegasus email program (only in some problem circumstance).

Best regards
Ola

von Ola - am 07.03.2015 14:09

Re: [WD19 & Win8.1] Weird problems

Hi Ola

If have haven't already, there should be a directory under .cpl directory in your main project folder. If you exit WD, then delete the .cpl directory this will blow away any previous compiles. Start WD and the compile folder will be re-created and project will recompile during opening.

Also, look for .env in your project folder. If you have one, you can delete it and it will be recreated next time the user logs in. (With all settings back to default)

If you find after doing the above that the issue is still occurring, they try exiting WD and renaming / deleting .env The file will be recreated when you next open the project, and the environment will be reset back to default.

Dave B.

von Dave B - am 07.03.2015 20:32

Re: [WD19 & Win8.1] Weird problems

Hi all

First, even though the double error was reduced to a single error after deleting the PCSoft registry keys, the double error returned on consequtive exits from Windev.

Found a new file I haven't prviously see: debogage.ref. It's a small binary file only 43 bytes long, situated in
x:\Apname\AppName.cpl\anonyme\
(I don't use a user name in Windev, therefore the user is called "anonyme".)
Possibly this is created when the error happend when exiting WD.

Deleting x:\Appname\AppName.cpl complete with its sub-directories is the normal default operation when any weird things happen in Windev, and this I have done several times. Did again.

I don't have a secondusername.env in my project directory, but I do have AppName.Env
The environment file AppName.Env I delete only seldom, because it, well, deletes all environment settings and brings back many earlier disabled weird non-existing errors which then have to be re-checked and re-disabled. Now I deleted it, too.

The result: the double error was again reduced to single error when exiting WD for the first time after deleting the environment settings. But later exists again caused the double error.

Best regards
Ola

von Ola - am 08.03.2015 12:31
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.