Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
6
Erster Beitrag:
vor 2 Jahren, 12 Monaten
Letzter Beitrag:
vor 2 Jahren, 12 Monaten
Beteiligte Autoren:
David Egan, Yogi Yang, L Jack Wilson

[O/T] PosReady 7

Startbeitrag von David Egan am 23.02.2015 01:59

Hi
Not really a Windev issue but hoping someone may have come across this & have a solution.

We create & write to a text file which interfaces to some other software. Using POSReady 7, if the path to write the data is the system drive (usually c:\path\file or c:\myprogname\interface\file) it throws an invalid path error. The file is created but that's as far as it gets. Normal Win7, Win 8 & XP process the file correctly. Even mapping a folder on the C:\ drive doesn't work but using any other drive is fine. Permissions are all OK (things like Notepad can write to the desired path). We suspect there's some sort of a filter in POSReady which prevents non-MS apps writing to the system drive, but having said that the program installs on the system drive and our data files (in this case classic HF) also write correctly. We've spoken to the suppliers and distributors of the machine but neither of them were able to help.

As a work around we are using a USB stick. If anyone has any other solutions or ideas as to the cause of the problem I'd greatly appreciate it.

Thanks

David

Antworten:

David,

What you describe is unusual. I have observed if we install our app anywhere outside Windows reserved folders like Windows, Program Files, Program Files (x86), etc. writing something to the file in the folder of the app is never a problem. Unless of course there is any rights set that prevents an app from writing any data to the HDD.

Have you tried to run you app as Administrator?

M2 cents.

Yogi Yang

von Yogi Yang - am 23.02.2015 06:21
Hi Yogi
Yeah, we'd tried that. As you say it really is unusual. We've confirmed the behaviour at 2 separate sites now. Fortunately we don't have many sites using the combination of PosReady & local writing; most sites run over a network & the files are created on the server so the issue doesn't raise its head.

David

von David Egan - am 23.02.2015 18:50
David,

I would compare the security permissions on the file it creates but won't write too versus a file you create in notepad to the same directory. Might give you a clue.

...jack

von L Jack Wilson - am 23.02.2015 22:41
Have checked the antivirus software.

I have observed that at times if we exclude the software and the folder where the software is installed from Antivirus realtime scanning it seems to solve the problem.

HTH

Yogi Yang

von Yogi Yang - am 24.02.2015 04:27
@Jack - checked permissions on files, both identical

@Yogi - removed antivirus Not that either I'm afraid.

Thanks for the suggestions but still banging my head!

David

von David Egan - am 24.02.2015 18:50
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.