Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
3
Erster Beitrag:
vor 3 Jahren, 2 Monaten
Letzter Beitrag:
vor 3 Jahren, 2 Monaten
Beteiligte Autoren:
Danny Lauwers, Peter Holemans

[WB19] Test query gives error (WX Framework) [SOLVED]

Startbeitrag von Danny Lauwers am 02.04.2015 13:15

Peter H,

When I create a new query in the project and want to test this via "Test The Query F9", then I get an error:

Error at line 14 of Initializing DA_ADM (server) process.
The 'WDApplication' element does not belong to the 'Site' configuration currently run. It cannot be used.

----- Technical Information -----

Project : DA_ADM

WL call:
Process of 'Initializing DA_ADM (server)', line 14, thread 0

What happened?
The 'WDApplication' element does not belong to the 'Site' configuration currently run. It cannot be used.

Error code: 1126
Level: fatal error (EL_FATAL)

Dump of the error of 'wd190vm.dll' module (19.0.176.4).
Identifier of detailed information (.err): 1126
Debugging information:
IS_ERREUR_ELEMENT_HORS_CONFIG_64
Additional Information:
EIT_PILEWL :
Initializing DA_ADM (server) (), line 14
EIT_DATEHEURE : 02/04/2015


When Test is run for a query, I think this query is run via en EXE from PCSoft.

This is my startup code (Image)
[attachment 1436 ProjectCode.png]

In normal project test/full run, the Webdev Code Block is active and runs OK.
But when testing a query (have not single tested other things yet), it seems that the Windows Code Block is executed. But those classes are not included in the project.
[attachment 1437 tree.png]

I cannot include those classes because they do not compile, there are for a different platform (Mobile, Windows). I am currently on Web.

For now I have a work around with this code in the 32/64Bit Windows Code Block


//Instanciate correct platform (Windows)
IF InTestMode() THEN
MyApp = new WBApplication
MyCtx = new WBContext
ELSE
MyApp = new WDApplication
MyCtx = new WDContext
END


But this is not a good or final solution for compiling this multi platform !

Any Idea on how to fix a situation like this. I would like to use the Test (F9) button todo testing of single queries, pages, reports,.... ;)

Thanks !
Danny

Antworten:

Re: [WB19] Test query gives error (WX Framework)

Hi Danny,

Interesting...
Indeed, it looks like the WX IDE is running a query from the query editor in test mode as a Windows executable and not as a WB app even if you are developing in WB.

It might be interesting to raise this behaviour to PCS via tech support.

Best regards,

Peter H.

von Peter Holemans - am 02.04.2015 17:25

Re: [WB19] Test query gives error (WX Framework)

Hi,

Posted it to PCSoft Support, and they where very quick in there anwser :)

It seems if you are in Project Test Mode with your project, and then create a new query and try to test that, It would not always run correctly. When you first stop the Test Mode, then create and test the query, it works OK.

Have a nice day
Danny

von Danny Lauwers - am 03.04.2015 10:13
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.