[WD20] Changing Table Styles

Startbeitrag von Curtis am 13.05.2015 17:41

I'm changing my table style to TABLEH_Simple (190_GenSteel). When I do so I get two errors per table.
[attachment 1505 errorcapture.PNG]

I have checked the general tab for each column and the Image of Column title is blank for everyone. I've tried recompiling, repairing, and refreshing the project style. What is going on here? F drive?

Antworten:

Hi Curtis

according to these error messages, you are using the SCM, but for an unknown reason the image in question is NOT in the project directory, and therefore not in the scm either... Copy it at the right place then point to it your style, and that should do the trick

Best regards

von Fabrice Harari - am 13.05.2015 18:08
Where can I find the images that belong to each table style? My table column headers look fine...

EDIT: I checked everything in to the SCM, and I am the only developer out of three that is getting these errors. I updated every single one of my tables and now have 94 GUI errors. :(

von Curtis - am 13.05.2015 18:33
Hey Curtis,

I had a "Style" issue a while ago (no, I'm not talking about a nylon track suit from the 80's! ;) ), where WD was trying to look at a non-existent F: drive when it should have been looking on the C: drive. Mine was caused by not transferring a project between version of WD correctly but shows a lot of similarities to your problem.

Take a look here; http://27130.foren.mysnip.de/read.php?27131,198300,306514#msg-306514 for some step by step instructions of how I sorted out my similar GUI style error messages - it might just help? :cheers:

von DarrenF - am 14.05.2015 22:30
Unfortunately I had already found your old thread. Didn't work for me. I can't find the offending "F:\WX\asdfasdf" in my description/style. I've checked everything in the description and every image path is either correct or empty. Thanks though!

von Curtis - am 15.05.2015 15:13
I know it sounds obvious, but have you searched your C: drive or whichever drive your projects are?

von DarrenF - am 15.05.2015 15:37


For the above GIF? Yup, have not been able to find it nor any of the folders in the path above.

At least it's not a problem right now. Except for the fact that my ire raises every time I see 'and 98 GUI errors'.

von Curtis - am 15.05.2015 15:50
With the following assumptions:

1) using SCM
2) 1 of 3 working in the project
3) your the only one experiencing issues

Make sure you have committed any changes in your project to SCM
Close Windev
Change the Directory name of your local project Directory (temporarily)
Open Windev
Open project from SCM it will rebuild local project directory

Do you still have issues?

If not and if you have no driving desire to understand why, delete your old project directory and all is good. If you must understand why then compare the 2 project directories with a 3rd party tool and lets discuss.

If your still having issues with the new project directory lets discuss

von Eric Wiegert - am 15.05.2015 17:18
Still having issues after following your steps Eric. Still have the same errors.

von Curtis - am 21.05.2015 21:21
Curtis

Ok, there are a number of items that are odd here and without the issues local I may state my thoughts out of order.

Again - under the assumption the the other two (2) developers are not experiencing these issues and both developers have synced with the SCM after your style change and they indicate that your changes have propagated to them.

First if you haven't already, delete the .cpl dir in the project dir. This appears to be saved in the SCM for each user. Recompile after this action.

The picture from your original posting indicates an image file titled "TABLE_COLTITLE.GIF"
I'm curious if this has been customized due to the default name being "Gensteel_Table_ColTitle.png"

As an example is "TABLE_COLTITLE.GIF" listed in the SCM and if so what are the properties/rights associated with this file?

Now - the other two (2) developers, do we have any information as to their project dir contents?

As a test ask one (1) of the other developers to perform the same procedure you just did. (temporarily change the local project dir and open from SCM again)

Since your original post shows a reference to Drive "F:" is this expected (since the SCM is the share location I'm curious if F: is local/mapped/etc)

Again I apologize for my disjointed thoughts here

von Eric Wiegert - am 22.05.2015 13:26
TABLE_COLTITLE.GIF is not listed in the SCM. I have no idea where the "F:" drive comes into play. It's got to be something virtual as I have no F drive.

I will have to wait a few days to have the other developers try changing the directory name and redownload from the SCM.

Thanks for your help!

von Curtis - am 22.05.2015 22:00
TABLE_COLTITLE.GIF is not listed in the SCM. I have no idea where the F: drive comes from. Must be something virtual.

I'll have to wait a few days to have the other devlopers try changing the name of the directory and redownloading from the SCM. Thanks for your help!

von Curtis - am 22.05.2015 22:11
Hi Curtis,

I'm still using WD16, so this may be a little different in WB20.
Select the style of the table and click on modify.
Select the style element "Column title border" and click the arrow on the right of the "Border" combo, you see the path of the gif and you can modify it.

HTH, regards,
Piet

von Piet van Zanten - am 23.05.2015 09:19
Thanks Piet, but I've already tried that. The path points to Gensteel_Table_ColTitle.png.

von Curtis - am 26.05.2015 13:25
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.