Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
10
Erster Beitrag:
vor 2 Jahren, 4 Monaten
Letzter Beitrag:
vor 2 Jahren, 4 Monaten
Beteiligte Autoren:
Michael Drechsel, GuenterP, Arie, kingdr

WD14 crashes at start

Startbeitrag von Michael Drechsel am 09.10.2015 09:50

Hi,

my Windev14 crashes all the time when I try to open a project (I tried a couple) or simple when I close the project open dialog.
Windows eventlog shows application error with wdprj.dll

I tried something like delete the registry key, reboot ....

Any ideas ?

Antworten:

Same here after installing V20.
The only way I found is to re-install WD14 and hope that V20 will still work.

von Arie - am 09.10.2015 10:06
This works for you ?

The windev installation is ISMO only a extraction of files to a folder, what should be better after this ? ...

von Michael Drechsel - am 09.10.2015 11:05
Reinstalling WD14 doesn´t help :-(

von Michael Drechsel - am 09.10.2015 11:48

Re: WD14 crashes at start [solved]

Hi,


reinstalling does´t help in this issue. Its an dongle driver thing.

What to do:

0. Plug out the dongles
1. In the folder hotline\hasp from the WD XX - installation directory run "hinstall -r" (remove the driver)
2. In the hotline\hasp from the WD 14 - installation directory run "hinstall -i" (install the driver)
3. Plug in the dongle - windows ask the update server and reinstalls the driver ...


Now both versions work

von Michael Drechsel - am 09.10.2015 12:41
Michael

I do have wx14 and I guess it's not compatible with any 64-bit wins7/8/10 and it is best
to have a crappy 32-bit/win7 or XP.

It's memory crash problem and I did troubleshoot once in awhile helping a software companyto resolve it by just changing the RAMs and worked as a charm and you never know when time to time using it read/write + overclocking CPUs that might crash the machine right away but there might be more beside that in your case.

I did get crash sometime while running wd14 dev on win7 32-bit but not often.

HTH

Cheers

King

von kingdr - am 09.10.2015 12:42

Re: WD14 crashes at start [not solved]

Quote
Michael Drechsel
Hi,
reinstalling does´t help in this issue. Its an dongle driver thing.
What to do:
0. Plug out the dongles
1. In the folder hotline\hasp from the WD XX - installation directory run "hinstall -r" (remove the driver)
2. In the hotline\hasp from the WD 14 - installation directory run "hinstall -i" (install the driver)
3. Plug in the dongle - windows ask the update server and reinstalls the driver ...
Now both versions work


Hi Michael,
imho, this will only help for a few hours, then, Windows Update will detect the "old" HASP driver and will replace it by the newest one and ho an below your WD14 will crash again!

The problem is not the driver, the problem is the dongle. The dongle has been rewritten some time ago and today the dongle definitely needs the newest driver only. So, the driver just appears to be the problem, but it is not.

Same problem with WINDEV 5.5 here. I have an old project and sometimes I want / have to do some maintenance on it. At first, PC Soft supplied a patch for WD5.5. This worked just fine, no problems. But, as it seems, only for a few weeks. When I came back to fire up WD 5.5 again it did not work anymore. I requested a new patch, but this time Tech Support recommended a lot of bs (which they knew very well that it was bs, I could even feel the grin through the wire). My solution (not for everyone, I do know) is to use an old v12 parallel dongle which we did not upgrade anymore. This one works with WD 5.5.

von GuenterP - am 09.10.2015 14:46

Re: WD14 crashes at start [not solved]

Hi Guenter,

really ?

Till last month I could open WD14 - WD20 without any major problems.
Then WD14 crashes at project opening, after a reboot it was fine.
Today that doesn´t helps ...
After installing the WD14 dongle driver and plugging in the dongles windows calls the update service (I see that in that little window near the clock)

Do you think there is another newer driver availible ? I don´t think so, but if that true, these steps are done in 5 minutes and I don´t need WD14 so often ...

von Michael Drechsel - am 09.10.2015 16:47

Re: WD14 crashes at start [not solved]

Hi Michael,

unfortunately, imho there's no new driver necessary but a patch to WINDEV 14 in order to use the new features or structure of the dongle. So I believe, for such purpose we have to request that from Tech Support. I fear, this will take time and there's no way out if you don't have an old WINDEV 14 - dongle. I think, it's better to migrate the application to v19 or v20 instead of waiting for PC Soft delivering a patch to an older tool.

von GuenterP - am 09.10.2015 17:09

Re: WD14 crashes at start [ Info+ ]

Hi,

using an old dongle (now a WINDEV v14 dongle) under Windows XP lets me start & work with WINDEV 5.5 without any problems.

von GuenterP - am 10.10.2015 02:16
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.