Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
11
Erster Beitrag:
vor 9 Jahren, 7 Monaten
Letzter Beitrag:
vor 4 Jahren, 9 Monaten
Beteiligte Autoren:
Mitchell, Leo, Kingdr8, amh, David Stevens, Paulo Oliveira, mitchell, Ben

Oracle Native Access Error message

Startbeitrag von Mitchell am 10.06.2008 11:26

Hi all,
does anybody knows how to fix this error messages from native access of oracle? or from where? i am trying to fix it but since 2days now i still cannot fix it....help please....message below :

"No library access to Oracle has been found (oci.dll or ociw32.dll): Oracle client layer is probably not installed correctly.
You must install a layer 7.3 minimum score Oracle to use native access WinDev for Oracle.
Dump error of module .

-- WL Call:
Processing , line , thread
Function , syntax #

-- Level: fatal error (EL_FATAL)

-- Error Code: 73001

-- WD55 Error Code: 3001

-- No system error code

-- No system error message

-- What happened?
ORACLE native access error.
Error Number = 1038

No library access to Oracle has been found (oci.dll or ociw32.dll): Oracle client layer is probably not installed correctly.
You must install a layer 7.3 minimum score Oracle to use native access WinDev for Oracle."



thanks in advance

Antworten:

It seems you did'nt install the Oracle client on your PC.
After that a listener should be configured.


Leo

ps A nice tool to manage Oracle is Toad (see Quest Software)

von Leo - am 10.06.2008 14:10
Hi leo,
I installed already the oracle client, but it seems still not working, anybody can suggest me here on how to used the oracle database native access ,and what are the other things might be needed..maybe i miss something here?

help please...

the procedure that i made is below : (maybe i miss somethng here?)
how to set the oracle native access
1. Install IIS / localhost must be running
2. create virtual directory for WIS
3. Install Oracle Client
4. Install oracle native access
5. Install oracle instant client
- configure by using the procedure : http://www.oracle.com/technology/pub/notes/technote_php_instant.html
6. Install WISWEB application (this is the application done in webdev using oracle native access)
7. Done

helps...

von mitchell - am 11.06.2008 09:27
Check the registry see if the oracle client is there.
Check the PATH variable to see if the oracle client is there, WEBDEV needs to know where is the oracle client.
In one of my servers( win 2k server) i had the same problem . After the installation of all the programs (WEBDEV,ORACLE NET and native access) WEBDEV still doesn't work and one restart of the server solve the problem.
you only need oracle net not all the oracle client to work with WEBDEV/WINDEV.
I'm using oracle 11g, i don't know if with other oracle version it is the same.


von Paulo Oliveira - am 11.06.2008 12:06
hayyyyyyyyyyy,its my 3 days nows troubleshooting for this issue, till now still not working at all :-( , very very very tiring...
helppppppppppppppppppppppppppppppppp......S.O.S...

:-(

von Mitchell - am 11.06.2008 14:34
Can you access Oracle via another tool ?
Via SQLPlus f.i. ? This should be installed together with Oracle automaticly.
If you cannot connect to a DB via SQLPlus, perhaps the listener is not configured well.


von Leo - am 12.06.2008 09:29
Hi leo,
I can access it through TOAD, sqlplus, and .net visual studio,...the listener is working well, but the error still comes....that error is strange to me..till today still not yet solved...if i run it in webdev server engine, that errors will come..on the same machine on which the webdev server is installed the SQLPLUS,TOAD is working fine... something is missing here i really don't know .. :-( :-( :-(

:confused:

von Mitchell - am 14.06.2008 07:10
Hi Mate,

You are using the Native driver if i read this correctly? Could you try using OLE DB just as a test?

Also, what client OS are you using? If you're using Vista try running Webdev in administrator mode just to be on the safe side.

A problem i had before with webdev is the context in which the app server runs. .NET uses a different policy, so my ASP.NET apps worked a charm, but webdev didnt on Oracle 9i. How do you authenticate to Oracle, ie. password or integrated?

What I had to do was changing the context in which the webdev app server runs, ie, give it a domain account to run under. Note that this was for OLE DB, so your case could be different. But again, this was with Vista Ultimate to a Win2003 server DB.

Regards




von Ben - am 16.06.2008 09:47
Have you been able to sort this native acces to Oracle using WebDev? I am also pulling-out my hair

von David Stevens - am 15.11.2012 13:28
Hi

Try something like this as below:

type in

PORT=1521;WD CLIENT LIBRARY=c:\oracle\product\11.1.0\client_2\BIN\ociw32.dll

in "Extend information: box
wdSql > Connection Wizard > Advanced button

p.s. you must locate exact path and wdSql.exe is in 32-bit
oci.dll should be in 64-bit

HTH

King

von Kingdr8 - am 16.11.2012 14:13
hi,
can i know if your problem were resolved? i have the same thing.
Please help.

von amh - am 03.04.2013 14:23
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.