Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
6
Erster Beitrag:
vor 2 Jahren
Letzter Beitrag:
vor 2 Jahren
Beteiligte Autoren:
Ola, Al, Stefan Bentvelsen, Joris

[WD19] AAAAARGHH!!! How to activate the TableInputSearch in a table control?

Startbeitrag von Ola am 04.02.2016 23:18

Hi all,

I have done this several times, and there are several tables in my app that use the TableInputSearch command to activate the search field in a column header, but now I can't do it in a new window!!! I can't make the magnifier glass icons in the key field colums visible!

I have checked and re-checked the settings in the working tables and compared them in the non-working one, but can't find the problem setting, if there is one.

I do realize that the "Proportional scrollbar" must be enabled in the table's "Detail" settings for the column search to work, and it is.

This is a file-based direct access table.

So, how to activate the column searches in a table control? Any hints are highly appreciated.

Best regards
Ols

Antworten:

Hi Ola,

IMHO it is only possible when it is a key in your file.
Or you must load them in memory instead of direct access.
But I could be wrong here, if I misunderstand the problem.

von Stefan Bentvelsen - am 05.02.2016 07:33
Thanks Stefan,

You are right. If it is s direct access table, only the key item colums can be used for searching.

But for some unknown reason, this problem table refuses to work as expected.

Maybe the window is defective, and I must rebuild it from scratch.

Best regards
Ola

von Ola - am 05.02.2016 10:35
Hi Ola,

IMHO it must be a setting of your table or some AAF that you activated by accident on the table.

Kind regards,

Joris

von Joris - am 05.02.2016 12:17
Hello Ola

You can create tables in two ways, manually through the control wizard or by dragging the file name onto the window.
I have had odd problems in the past with tables created using the drag and drop method and now I always create them through the wizard.

Regards
Al

von Al - am 05.02.2016 12:22
OK,

I finally found it. In the column's general settings there is a checkbox called "Magnifier (filter)". I had not checked them for the key columns. Now I did it, and the table works as expected.

Sorry for noise.
Thanks to all!

Best regards
Ola

von Ola - am 05.02.2016 12:23
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.