Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
14
Erster Beitrag:
vor 2 Jahren, 6 Monaten
Letzter Beitrag:
vor 2 Jahren, 6 Monaten
Beteiligte Autoren:
StanleyBarnett, Art Bonds, Davie, Al, Allard, Paulo Oliveira

Grayed Out... Option to enable > 2gb table limit

Startbeitrag von StanleyBarnett am 08.02.2016 07:25

Hi,

What option controls why the "Managing the data files exceeding 2 gb (NTFS only)" option is grayed out / disabled? I'm using OLE DB to MSSQL

And, does the 2 gb limit pertain to each file individually or as a group? Does the .fic have a 2gb limit and the .mmo have its own 2gb limit and so on? Or is it their combined size?

Thanks,
Stanley

Antworten:

You don't need this options for MSSQL, this options are only for HF.

von Paulo Oliveira - am 08.02.2016 09:24
Hi Paulo,

Sorry, I only told you the source side of it which is MSSQL via oledb and output is to HFSQL. After importing that generated this error:

Maximum size of file has been reached. Use WDOptimizer to reorganize data. If this operation is not sufficient, ask the application provider to increase the maximum file size.
File: BinFile

I went into the data description to set that option and found it grayed out, hence the question.

Thanks,
Stanley

von StanleyBarnett - am 08.02.2016 22:31
Hi,

I guess it is an option that can only be used when creating the hyperfile file. If you create a new one in the analyseis you get the option as well.

so I guess if you make the file empty it willnot be grayed out. If so remove anc create a new one

regards
Allard

von Allard - am 09.02.2016 18:03
Hi,

I cannot get the >2gb option to work in any case...

I opened hfsql control center as admin and enabled the >2gb switch, then stopped and restarted the service. I closed the hfsql control center and reopened it and confirmed that the switch was still enabled. It was.

I then deleted all the previously created tables where the 2gb switch and re-imported it again, and it too fails with the same error message.

I was importing via WinDev's gui using oledb. The source database and table are MSSQL and I'm trying to import it into a HFSQL database.

It appears that the import is only processing tables and not databases,

What am I to do?

Thanks,
Stanley

von StanleyBarnett - am 10.02.2016 05:18
Looking at one of your posts, it seems you are not talking about 'files', as in .FIC, but instead 'memos', or .MMO.

" "

According to the Help, the maximum size of .FIC and .NDX is either 1024 TB or 2 GB, depending on settings.

However, the maximum size for .MMO files are:

"Memo file (*.MMO): Maximum size
If the operating system supports NTFS and if the partition supports NTFS: 1024 TB
Otherwise: 4 GB."

So all this talk about '2 GB limits' may have clouded the question. After you get the error message, what is the size of the .MMO file on disk? Is the disk formatted NTFS?

von Art Bonds - am 10.02.2016 13:50
Hi Art,

>> it seems you are not talking about 'files', as in .FIC, but instead 'memos'
Actually, I'm talking about tables which is made up of .fic, .mmo, and .ndx disk files. In my case when the .mmo file hits 2gb, the import stops for that table and continues with another table.

I am using NTFS everywhere and the .mmo file size is 2,097,??? KB which is 2gb when the error is raised.

No matter how I set the settings, the import stops when 2gb is reached. I cannot get past that...

Thanks,
Stanley

von StanleyBarnett - am 10.02.2016 15:43
Hi Stanley,

What do you mean by this... "I'm talking about tables which is made up of .fic, .mmo, and .ndx disk files." You mean the browsing table that shows the file on screen?

Not sure what your issue is. I created a file in the analysis that had both regular fields (Int, String, etc) and a Unicode Text Memo field. Created a browsing table for the file. Created a procedure to loop and create records, putting in values in large enough to make the .mmo file larger than the .fic file. Kicked off the loop to create a million records and sure enough, an error message that the .mmo file was 2 GB. I could see the records in the browsing table on screen.

Deleted all .fic, .mmo and .ndx files. Set the option to go over 2 GB. Added a million records. The .fic is 3,169,927 KB (3.17 GB), the .mmo file is 12,875,001 KB (12.87 GB). And I could see them in the browsing table, BUT the scrolling was extremely slow.

I think you may have a problem with your NTFS formatting. Have you tried to take the ProgramName.exe file to another Windows computer and try it there?

On edit: How are you importing these records from the original database? A procedure?

von Art Bonds - am 10.02.2016 18:32
Hi Art,

>> What do you mean by this... "I'm talking about tables which is made up of .fic, .mmo, and .ndx disk files.
I am learning hfsql is similar to mssql and vfp whereas a table of data is made up of multiple files. A database is made up of tables and tables are made up of multiple files (disk storage units)...

For example, the customer table in VFP would be made up of customer.dbf, customer.fpt, customer.cdx and maybe an customer.idx.
In MSSQL the customer table is made up of customer.mdf, customer.ndf and customer.ldf
and in HFSQL, it uses customer.fic, customer.mmo, and customer.ndx files...
Hope that explains it...


>> How are you importing these records from the original database? A procedure?
I'm using the WinDev gui.
In Data Model Editor, I click the Analysis menu item,
1. Next I click on the Import Down Arrow and select "Import the descriptions of files/tables"
2. The "importing data files" wizard is shown, and I click the continue button (right arrow)
3. On the "type of database" step I select "OLE DB" and click continue,
4. On the "choosing the ole db source window I select "sql server (microsoft ole db provider for sql server) and click continue
5. On the "choosing the connection" step I choose the connection string, and click continue,
6. On the "importing data step, I select "convert the data to the hfsql format and click continue,
7. On the "selecting the data files (tables)to import" step, I click the "add all" button and all tables are moved fron the left pane to the right pane. I also check the "import the unicode text items in ansi"checkbox and click continue,
8. on the "creating the hfsql files" step, I click continue,
9. on the final "importing" step, I click the continue button and off it goes and returns with the >2gb error when importing the binfile table as its .mmo file is >2gb.

Also note 2 things here... at the start of the import the hfsql table files do not exist and when loading the hfsql control center, I have the >2gb setting checkbox checked under the system group. This is the only place I see to tell hfsql to use >2gb settings as the files themself do not exist.

What am I missing here?

Thanks,
Stanley

von StanleyBarnett - am 11.02.2016 00:31
Hello Stanley

I think you will have to set the file size in the analysis - NOT the HFCS control centre.
In the properties of the data file there is a "Details Tab" with a tick box for "Managing the files exceeding 2 GB (NTFS only)

"Tables" is the wrong word to use when discussing HF data files. In Windev a table is a grid control used in programming.

Regards
Al

von Al - am 11.02.2016 01:28
I would define both the HFSQL file (with >2 GB set) and the MSSQL table in the analysis. Then write a small program to read the MSSQL file and hAdd it to the HFSQL file.

von Art Bonds - am 11.02.2016 01:54
Hi Al and Art,

>> think you will have to set the file size in the analysis - NOT the HFCS control centre.

Hey guys, the data files DO NOT YET EXIST as they are about to be created by the import wizard, therefore there is only one place I've found that refers to the >2gb limits and that is in the HFSQL Control Center. For a non-existant data file I would expect the settings inside the HFSQL Control Center be respected as there is no reference to them in the analysis, therefore nothing to set.


>> "Tables" is the wrong word to use when discussing HF data files. In Windev a table is a grid control used in programming.

OK, however even WinDev's import wizard as I mentioned in step 7 above refers to them as tables as well as every other database that I've used...

Frustrating... 2gb limit in VFP and now 2gb limit in WX, (VFP replacement)... Why don't they get rid of this limit? I don't remember having to deal with this in SQL Express or MSSQL, ever...

Anyway, thanks guys for replying...
Stanley

von StanleyBarnett - am 11.02.2016 03:10
To use the import wizard > 2g files, you need to do this in three steps...

First step, generate the file descriptions in the analysis.

Second step, edit the file descriptions and change connection to HyperFile and set 2 gig management on details tab.

Third step, import data.

To do the first step, just select "Access Data in its current format Only" Instead of "convert the data to the hfsql format", in step 6 that you listed above.

To do the second step, select each file in the analysis pane, and edit description. Change the file connection to Hyperfile, and check the “Managing files greater than 2 gig”. Do this for every file you are importing.

{Edit} Set the "Managing files greater than 2 gig" on the files you expect to grow and exceed 2 gig limit. No point on setting for files that will never grow that large as it just adds additional unnecessary overhead during file access. {Edit}

To do the third step, select Import from the Analysis menu and select “Import data from another database”

Dave

von Davie - am 11.02.2016 04:23
Hi Mr Black,

Thanks you for helping...

I'v followed your instructions and when selecting “Import data from another database”
and get to the wizard's "selecting the data files (tables)to import" window, there are no data files to select. I changed the type to HFSQL and set the >2gb only on the files that is expected to grow beyond 2gb. I'm connecting to the source MSSQL database via ole db.

The only way I can see data files is by selecting "convert the data to the hfsql format" When importing with this option, the 2gb limit is still present.

Any ideas?

Thanks,
Stanley

von StanleyBarnett - am 12.02.2016 03:13
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.