Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
4
Erster Beitrag:
vor 1 Jahr, 6 Monaten
Letzter Beitrag:
vor 1 Jahr, 6 Monaten
Beteiligte Autoren:
Piet van Zanten, Luis Antonio Gutiérrez Flores, Allard, Michael PAce

WB Timer Procedures

Startbeitrag von Michael PAce am 10.04.2016 06:45

V20. I need to run a server procedure every 10 seconds. I have looked at help, i have followed the instructions, but I cant get it to work.

For testing I have only a single statement in the procedure STATIC = "last run at" SO no clever stuff here. I found that TRACE("HERE") causes it t abend

My settings are immediate, infinate, (it wont allow delay setting - grayed), no HFSQL etc.

Antworten:

Maybe set delay on 0,05 second?

I donnot work with timers in webdev but hae worked with them in windev. So Iam not an expert but i think it might just do the trick for you

regards

Allard

von Allard - am 10.04.2016 13:26
Maybe if you use timers combined with AJAXExecute you can get it to work.

von Luis Antonio Gutiérrez Flores - am 11.04.2016 16:56
Hi Michael,

If I understand the Help correctly, an automatic or delayed procedure will be installed on the deployment server when you deploy/update the site.
So I guess in testmode it won't work, because there's no permanent deployment engine on the dev machine.
I suggest you test it on a test sever.

Regards,
Piet

von Piet van Zanten - am 12.04.2016 09:01
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.