Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
4
Erster Beitrag:
vor 1 Jahr, 7 Monaten
Letzter Beitrag:
vor 1 Jahr, 7 Monaten
Beteiligte Autoren:
Terry Mullican, kingdr, Stewart Crisler

SocketConnectSSL Issues

Startbeitrag von Terry Mullican am 13.04.2016 14:30

Anyone used the WinDev socket functions with SSL? We are having issues with the SSL connection to a server inside a data center. The initial hand shake is getting messed up by the Sonicwall firewall.

We watch the communications between WinDev serivce and server. WinDev sends a packet with a reset flag after the tcp handshake completes but before the SSL handshake completes.

All the code worked fine until we changed it over to SSL. The SSL code works fine from inside of our office, but we would rather have all the traffic going thru the data center...

Anyone seen anything like this?

Antworten:

I tried taking working code using regular sockets and substituting SSL naively thinking it would just work. The first problem I ran into is that I could not drop just any string into the socket but had to parse the string into small increments and feed it to the SSL socket. This helped but didn't solve the problem. Eventually I gave up. This was in WD19. Have not tried WD20 or WD21.

von Stewart Crisler - am 13.04.2016 17:20
Looks like ssl-handshake violation in Sonicwall, give it a try to
uncheck the option "Enable TCP handshake timeout" to see it helps or
send errors report to sonicwall support, I think they can help instead.

What model/version of sonicwall you're running as we're running NSA2600 and TZ215 but
never try SSL socket inbound/outbound at all.

HTH

King

von kingdr - am 13.04.2016 18:52
Thanks for the info!

NSA 4500
SonicOS Enhanced 5.9.0.7-17o

von Terry Mullican - am 13.04.2016 19:07
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.