Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
7
Erster Beitrag:
vor 1 Jahr, 3 Monaten
Letzter Beitrag:
vor 1 Jahr, 3 Monaten
Beteiligte Autoren:
DerekM, Fabrice Harari, Kingdr, Piet van Zanten

Apache - IIS - different results [Resolved]

Startbeitrag von DerekM am 11.05.2016 04:47

Hello All

I have come up against a difficult issue.

This is WebDev 19.
Dev env. is using Apache 2.2
Prod is using IIS 7.5 on Window 2008 R2

This *may* be a Windows issue with some patch - but I can't really find any clues.

I have a "list" populated with person information and including a photo (image). When the person is selected - the details are copied to the main part of the page.

This works perfectly in the Dev env (Windows 10 client running local Apache server / and Windows 2008 R2 Server for HFSQL).

Also - I am pretty certain that this *was* working on Prod with IIS but I cannot be 100% certain as this code has not yet been released - there is a possibility that it could be an old issue that was missed.

The list is populated using a Looper control and LooperAddLine code.

When selected (clicked) - the server code assigns the the looper line attributes to the display area (i.e. name, details, and image/photo).

Now - when run on the production server - as soon as the image assignment line is reached - my session just disappears. I get no error condition - only that the next line says that the session was exited normally.

The code involved is simply : IMG_CONTACT_SELECTED = gsImagefile

I have tried many variations - changed the image attributes - checked all server permissions - but I am still clueless as to what is really going on.

I doubt it is a resource problem - as everything else just hums along fine. It simply bombs out when I assign the image value to the image control.

I am really hoping that I have just done something really stupid here that someone can point out - or give a clue as to how to debug this ...

Anyone got any clues? Windows OS? IIS? WebDev?

Thanks for any suggestions ..

Regards
Derek

I kinda suspected this after my original post - but until now no time to prove it.

The problem was a corrupted PAGE file. I came across similar issues when converting from WinDev to WebDev (but this was not a converted Page).

Rebuilding the project will not fix this. The "corruption" is something internal and not discover-able by any normal means.

To fix this - I simply made a new page - and copied in all the elements from the old page. Now it works.



[This is WebDev 19]

Antworten:

Re: Apache - IIS - different results

Hi Derek,

What debugging method do you use to find that this particular line of code is actually the last one executed?
What do you mean exactly by the session disappears? What happens on screen?
Did you check any OnTestMode() code that might interfere?
You may try reinstalling the site with a physical media setup package directly on the server. (Optionally delete all resources manually first)

Best regards,
Piet

von Piet van Zanten - am 11.05.2016 06:08

Re: Apache - IIS - different results

Hi Derek,

Quote
DerekM

IMG_CONTACT_SELECTED = gsImagefile


Your code seems to imply that gsImageFile contains a pth, and that the image is on disk, outside the DB.

Is that the case?
If yes, WHERE are the images?

Best regards

von Fabrice Harari - am 11.05.2016 12:33

Re: Apache - IIS - different results

Hi Piet and Fabrice

Thank you for your constructive suggestions

Debugging the old-fashion way with info() lines. The assignment line is the last line that gets executed..

What happens on screen? Nothing happens on screen. The information (sans the image) is displayed. I can see from the WebDev application monitor that the session has just "disappeared" - it just is not there anymore - and if I click anything on the web page - it informs me that there is no session and that it has exited "normally". (Also - there is no application exit code anywhere.)

The only OnTestMode() code is in the connection routines.

The site has been wiped and re-installed a number of times.

I used 2 different routines for the image. Both work in my dev env (Apache) and neither work in production (IIS)

(1) Simply assign the image retrieved and displayed in the Looper and
(2) Read the information again - i.e.
gsImagefile = fWebDir() + "\" + gnPatid + ".jpg"
HReadSeekFirst(PATIENT,PATIENTID,gnPatid,hKeepFilter)
IF HFound(PATIENT) THEN
res = HExtractMemo(PATIENT,PHOTO,gsImagefile)

The image file is created correctly and seemingly has all appropriate permissions.

I use similar image code in many WinDev/WebDev projects - and never had a problem until now - and this "disappearing" behaviour is not something that is easy to trace!

For the moment, though, I will just have to write this off as one of those Rumsfeldian unknown-unknowns - and move on. When I meet a brick wall, it's easier to walk around it rather than bash my head against it. I can actually live without this image - so I'll comment the code until I have time.

I'll post back if/when I find an answer to this :)

von DerekM - am 11.05.2016 13:16

Re: Apache - IIS - different results

Hi again

maybe you are just missing a dll on the prod server, one in charge of managing the images?

Best regards

von Fabrice Harari - am 11.05.2016 14:12

Re: Apache - IIS - different results

Hi

It might be the file access right issue in your Win2008 server for domain user(s) and
so does file mapped drives, pls chk your IIS user's authetication to see if it helps.

Couldn't think of anything but the security issue on windows server?

HTH

Cheers

King

von Kingdr - am 13.05.2016 10:40

Re: Apache - IIS - different results

Resolved. Comments at top.

von DerekM - am 23.05.2016 15:29
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.