Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
3
Erster Beitrag:
vor 1 Jahr, 4 Monaten
Letzter Beitrag:
vor 1 Jahr, 4 Monaten
Beteiligte Autoren:
Peter Hite, Piet van Zanten

Webdev: Problem using 2 configurations in PCSCLOUD

Startbeitrag von Peter Hite am 09.06.2016 20:11

I use WebDev20 and have a project that I would like to use two configurations on. The first configuration was successfully deployed into my pcscloud account. Call it SiteA which uses database DataA. I needed the exact same code to use a different database (DataB) so i used the "Manage the configurations" program to set up SiteB. It works fine testing on localhost, but when I try to deploy the site I get the permission errors below. I have tried active/passive ftp and about every option I can think of to no avail. Has anyone run across this?? Thanks.

[attachment 2023 frame4.png]

Antworten:

Hi Peter,

It seems a bit awkward to me to use configurations for that purpose.
A more common approach would be to use the same site and just change the connection to the database.
How to do that depends on if your site is public or private.
If it is private you can use the login to determine the datebase, if public you could use parameters, user choice or different urls for each database.

Best regards,
Piet

von Piet van Zanten - am 10.06.2016 12:01
Thanks for the advise. The problem was resolved as a bug in pcscloud. it is fixed now.

von Peter Hite - am 13.06.2016 17:35
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.