Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
5
Erster Beitrag:
vor 1 Jahr, 8 Monaten
Letzter Beitrag:
vor 1 Jahr, 8 Monaten
Beteiligte Autoren:
JP, Fabrice Harari

[WB21] - Trying to deploy a site

Startbeitrag von JP am 16.06.2016 09:29

Hi All

WinDev 21
Classic site

I am trying to deploy a test classic site. I have:

1) Setup the WebDev Administrator 10 user version on the server

2) Created a user in the WebDev hosting center as required

3) Created the Windows user accounts, one for the Windows user and one for running sites - Done by the setup

4) User folder is D:\WebDev\User_Name

5) The Virtual Website allocated to this user is the Default IIS website (which is working as a simple default site). This is the recommended setting in the PDF tutorial, pg 264, step #8

6) In the deployment wizard I enter the various parameters for the server IP, WebDev account, FTP account

7) When I run a test of the parameters the FTP works fine (a temp file is transferred)

[UPDATE]

I added "http://"; to the Address of Application Server (in the deployment wizard and the previous 404 error goes away. Now the error is:

"An error occurred while retrieving some information from one or more Application Servers"

Any suggestions what the issue is?


TIA

Antworten:

Hi JP

most of the time, when trying to deploy a first time on a newly installed server, this kind of errors comes from permissions problems on the server. This part has been a pain in the ass since the beginning when installing webdev server.

Best regards

von Fabrice Harari - am 16.06.2016 11:13
Fabrice

Well I cant think of anything else to try. The 2 users that the setup created; one is a member of Administrators (PowerUsers was recommended but I upgraded just in case) and the other is member of IIS_IUSRS (as recommended).

I have set the WebDev Admin account to use virtual website "Default" and tried the WEBDEV virtual website. No luck.

No idea what else to try. Does everyone have this painful experience ? Is there no other way to do upload a website easier than this?

von JP - am 16.06.2016 11:29
Hi again

creating the users is only half the work. You also have to be sure that each has the correct permissions.
For the site upload process, by example, webdev client FTPs the installer on the server in a directory, and then do a httprequest to the webdev server so that IT (ie probably IUSER) runs the installer.

So that means that IT (ie probably IUSER) needs permissions on the FTP directory (which it often doesn't have by default)...

and yes, I had the same problem nearly each time I installed a webdev server, and I had to tinker around till it worked properly

Now, of course, if you don't want to, you can
- deploy on an already configured webdev sever (kalanda.net, by example)
- do a manual install (ie create the installer via physical media), upload it and run it manually (teamviewer, by example)

Best regards

von Fabrice Harari - am 16.06.2016 18:20
Fabrice,

iro - do a manual install (ie create the installer via physical media), upload it and run it manually (teamviewer, by example)

It seems to me that this would be a simpler option, no? So just set up the WebDev Application Server 10 Users and then run the website installer - is that it?

von JP - am 19.06.2016 12:00
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.