Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
4
Erster Beitrag:
vor 1 Jahr, 4 Monaten
Letzter Beitrag:
vor 1 Jahr, 4 Monaten
Beteiligte Autoren:
Binod Lohani, Allard, Fabrice Harari

HTTPRequest problem

Startbeitrag von Binod Lohani am 18.06.2016 10:53

Hello Gang!! What is the difference between these two codes??
============================================
sPostParameter is string = "name = Andy"

IF HTTPRequest("www.mysite.com", "", "", sPostParameter) = True THEN
Info("Request OK, result:", HTMLToText(HTTPGetResult(httpResult)))
END

==========================================

HTTPCreateForm("FORM" )
HTTPAddParameter("FORM", "name", "Andy" )

IF HTTPSendForm("FORM","www.mysite.com" ) = True THEN
Info("Request OK, result:", HTMLToText(HTTPGetResult(httpResult)))
END

===========================================

The first code doesnot work while the second code works correctly.
Any Idea?? Thanks

Antworten:

Hi

in the first code, you are EXPLICITELY using the syntax requesting POST mode.
in the second you are not.

Everything is in the help

Best regards

von Fabrice Harari - am 18.06.2016 11:54
Hi

PostParameter is string = "name = Andy"

name= andy is seen as 1 string with = in it.

Try

"Name" + " "+ "Andy"

regards
Allard

von Allard - am 18.06.2016 18:46
Thanks Fabrice !!
I guess in second code also Post mode is explicitely defined . because the default value is post mode . Further why my first code is not working and second is working fine ??
Thanks !!

von Binod Lohani - am 18.06.2016 23:49
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.