Diese Seite mit anderen teilen ...

Informationen zum Thema:
Forum:
WinDev Forum
Beiträge im Thema:
6
Erster Beitrag:
vor 2 Jahren
Letzter Beitrag:
vor 2 Jahren
Beteiligte Autoren:
JP, Alexandre Leclerc, Fabrice Harari

[WB21] - Deploying a Site

Startbeitrag von JP am 20.06.2016 16:11

Hi All

Very frustrated :) It seems to be a very difficult thing to deploy a WebDev site. So far:

1) I installed the WebDev 20 Application Server 10 User Version 20 (cant find the version 21 setup package)
2) I followed step by step every line from the PDF file "WebDev_Deployment.pdf"
3) Created the groups
4) Created the registry entries
5) Specified the virtual server to use
6) Setup the accounts under Hosting Control Center
7) Setup an FTP Server (not using the IIS7 one - using a more secure one)
8) Ran the Checking Configuration Diagnostics - all OK

Then trying to deploy a site:

1) Provided username and password
2) Provided FTP username and password
3) Run the test - the FTP test tries to transfer a file to the correct folder - file is transferred

And then the deployment test says "failure" with ZERO information about what the problem is. Simply nothing. How can this be acceptable feedback?

I look at the FTP logs and it shows a successful connection, then a successful change folder request. Then it tries to change folder to the temporary file name ... what ??? This fails. Then it tries to transfer/create a temporary file. This works. Then it fails with no further feedback.

Fabrice suggested a deployment package. Great, tried that. First attempt it - created the package, transferred it, and ran it => comes up with a warning saying no Application Server is installed (but one is, version 20 but not version 21). So I uninstalled that application server and created a new deployment package with the Application Server included. Ran that. Useless - it doesn't ask what virtual website to install to (it just uses default website). And then when I try and run it the package crashes !

Surely there is a better way than this.... First time I am truly disappointed with WebDev ...

Does anyone have suggestions how to resolve this?

Antworten:

Hi JP

one thing is sure: you can't deploy w v21 site on a v20 server

Best regards

von Fabrice Harari - am 20.06.2016 17:05
Fabrice

Thanks - busy installing version 21 now. But the errors I have occur before even getting close to installing the website. But thanks for pointing it out anyway :)

von JP - am 20.06.2016 17:35
Hi All

OK, installed WebDev Application Server 21 but still the same problem. Everything checks out until I try and test deployment wizard against the server. I have screenshot the FTP log file and you can see that the connection is OK, the change folder command to the FTP folder is OK. Then for some strange reason the deployment wizard tries to change folders to a folder name XXXX.TMP. Such a folder does not exist, of course. Then it tries to transfer a file by the same name, i.e. XXXXX.TMP, into the FTP folder. This is succesfull. Transfer is complete and the deployment wizard logs off. And then gives a usefull error message "An error occured while retrieving some information from one of more Application Servers". And that's that.

I have tried Active and Passive variations.

Screenshot attached.

Any clues here?

Has anyone actually remote deployed a WinDev 21 website so far? I'm asking just in case this has not been tested yet ... ?
[attachment 2038 WebDev_Error.png]

von JP - am 20.06.2016 18:12
Hi JP,

This will not help you much, but we had this problem when migrating our websites from a hosted service to a virtual server. (And using IIS FTP.) This was just not working, but everything looked OK.

What I did is I deleted the whole website to have a clean folder. This I uploaded the project “from scratch” and then it worked. It seems there was something wrong in the file access rights. But cleaning the place and starting over (instead of starting from the previous files) did the thing. Also many IIS restarts along the way (to solve many other issues).

Kind regards,
Alexandre Leclerc

von Alexandre Leclerc - am 21.06.2016 13:00
Alexandre

Thanks but this is a clean install. We have not used WebDev before so there is no prior WebDev website on the server. I can't even get past the test of the parameters for uploading a site ... The error message is useless - no usable feedback at all. Thanks for responding.

von JP - am 21.06.2016 13:47
Zur Information:
MySnip.de hat keinen Einfluss auf die Inhalte der Beiträge. Bitte kontaktieren Sie den Administrator des Forums bei Problemen oder Löschforderungen über die Kontaktseite.
Falls die Kontaktaufnahme mit dem Administrator des Forums fehlschlägt, kontaktieren Sie uns bitte über die in unserem Impressum angegebenen Daten.